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Preface

Welcome to the TB8100 Service Kit User’s Manual. This manual provides you 
with information about the Tait TB8100 Service Kit in PDF format. You can 
view it online or print it if you want a paper copy. It describes how to use 
Version 1.00 of the Service Kit. 

■ New Service Kit users should begin at Part B: Getting Started.

■ For explanations of essential concepts, look in Part A: Introduction. 

■ The rest of the manual assumes that you are familiar with Part C: Basic 
Tasks.

Enquiries and Comments
Any enquiries regarding this manual as well as any comments, suggestions and 
notifications of errors, should be addressed to support@taitworld.com or to the 
Support Group Manager, Tait Electronics Limited, PO Box 1645 
Christchurch, New Zealand.

Updates of Manual and Equipment
In the interests of improving the performance, reliability, or servicing of the 
equipment, Tait Electronics Limited reserves the right to update the equipment 
or this manual or both without prior notice. 

Copyright
All information contained in this and other TB8100 manuals is the property of 
Tait Electronics Limited. All rights are reserved. These manuals may not, in 
whole or in part, be copied, photocopied, reproduced, translated, stored, or 
reduced to any electronic medium or machine-readable form, without prior 
written permission from Tait Electronics Limited. All trade names referenced 
are the service mark, trademark, or registered trademark of the respective 
manufacturers.

Disclaimer
There are no warranties extended or granted by these manuals. Tait Electronics 
Limited accepts no responsibility for damage arising from use of the information 
contained in the manuals or of the equipment and software it describes. It is the 
responsibility of the user to ensure that use of such information, equipment, and 
software complies with the laws, rules, and regulations of the applicable 
jurisdictions.

Typographical Conventions
‘File > Open’ means ‘click File on the menu bar, then click Open on the list of 
commands that pops up’. ‘Monitor > Module Details > Reciter’ means ‘click 
the Monitor icon on the toolbar, then in the navigation pane find the Module 
Details group, and select Reciter from it’. 

Associated Documentation
All available TB8100 product documentation is provided on the CD supplied 
with the base station. Updates may be published on the Tait support web.
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Online Help. The Service Kit also has online Help. It contains more or less the 
same information as this manual. To view it, start the Service Kit, then press F1 
or click the Help icon on the toolbar. If you are in a dialog box, click the Help 
button. The Alarm Center and the Calibration Kit also have online Help.

TB8100 Installation Guide.

TB8100 Operation Manual.  

TB8100 Service Manual. (service centers only) 

TB8100 Product Catalog provides information about base station parts and 
modules.

Technical notes are published from time to time to describe applications for 
Tait products, to provide technical details not included in manuals, and to offer 
solutions for any problems that arise. Look for them on Tait’s technical support 
website. The following have been published or are in development:

TN-742 Remotely Monitoring and Configuring the Tait TB8100.

TN-743 Using the TB8100 Base Station as a Talk-Through, Community, or Linked 
Repeater 

TN-745 Using the Tait TB8100 in TaitNet Trunked Networks.

TN-744 Using the Tait TB8100 as a Line-Connected Base Station.

Publication Record

Version Date Description

1.00 June 2003 First release of the manual. Describes version 
1.00 of the Tait TB8100 Service Kit software.
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Part A Introduction

The Service Kit is a Windows-based software program that 
makes it easy to monitor and configure a Tait TB8100 base 
station. You can also use it to carry out diagnostic tests and 
update the base station’s firmware. 

The introduction explains concepts that are fundamental to the 
base station. You need to understand them before you can use 
the Service Kit effectively.

Topics

From T800 to TB8100

Operation Modes

Channels

Profiles

Subaudible Signalling

Power Saving

Task Manager

Remote Connections

Alarms

System Interface

Software Feature Enabler
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From T800 to TB8100

The TB8100 is a software-based radio. This means that its programming 
software has far more scope. For those who are familiar with the Tait 
PGM800Win programming software, here are some key differences. 

The Service Kit does more than configure channels. It can monitor 
operational details, receive alarms, log a user-defined set of parameters, and 
carry out diagnostic tests. It can switch the base station’s operating mode 
from Run to Standby and back again and even reset the base station or 
upgrade its firmware. It also lets you edit Task Manager tasks, which enables 
you to customize the TB8100 for individual applications. See “Task 
Manager” on page 9.

The Service Kit can connect remotely to the base station via dial-up 
modems or radio modems. You can make routine monitoring checks and 
carry out diagnostic tests without needing to travel to the site.

The channel table does more than define the transmit and receive 
frequencies and the frequency of the tone used for CTCSS. It specifies a 
whole range of operational parameters. Because there are so many 
configurable parameters, most are grouped into profiles. There are two 
kinds of profiles: channel profiles and signalling profiles. See “Profiles” on 
page 6.

The Service Kit provides both a simple and a complex method for 
configuring the channel table. The simple way uses default profiles and lets 
you edit items directly in the table. The complex way is available if the base 
station has an Advanced Profiles and Task Manager license. You define a set 
of custom profiles then select the right ones for each channel. 

Custom profiles make it possible for you to assign up to 16 subtones to any 
channel, meaning that a tone panel is not needed for most applications.

The Service Kit can configure signal paths. In effect this means that you can 
customize ‘virtual backplanes’. These are profile-based so that the base 
station can change its virtual backplane in the middle of operations. For 
example, a Task Manager action can change the base station from a line-
connected base station to a talk through repeater, simply by changing to a 
channel with a different custom profile. 
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Operation Modes

A base station can operate in three different modes. Some functions are disabled 
until you shift the base station into the required mode. 

Run mode is used for normal operation. 

Standby mode is required if you want to program the base station or carry 
out diagnostic tests on it. Standby mode puts the base station out of service. 
However it will still transmit if you push the Carrier button on the control 
panel, use a microphone, or carry out a transmission test. 

Download mode is required if you want to update the base station’s 
firmware.

Appropriate messages alert you to the need to change mode so that you do not 
inadvertently leave the base station out of service when you end a Service Kit 
session.

The Mode icon on the toolbar displays the current mode of the base station you 
are logged in to.  

It is in the form of a traffic light:

Green indicates Run mode

Orange indicates Standby mode

Red indicates Download mode

Click on it to change mode.

The status bar also displays the current mode. 



TB8100 Service Kit User’s Manual   Channels 5

Channels

A TB8100 base station consists of the equipment needed to operate on just one 
channel. However, using the Service Kit you can program up to 255 channels 
into a single base station. This is confusing, until you realize that ‘channel’ has 
different meanings. The one channel is the transmit and receive frequency pair 
and the 255 channels are different channel configurations, each with its own 
number and name. You select one of these channel configurations and the base 
station operates according to all the settings defined by it. These include a 
transmit and receive frequency pair, a transmitter power output, a channel 
spacing, and many other configurable items.

Channel Table Each base station has a channel table. This is the database that stores the channel 
configurations. It is a good idea to maintain a single channel table for your 
system. This means that you can use almost the same configuration file for all 
base stations. To configure a new or replacement base station, all you need to 
do is copy the standard configuration file and select a different default channel. 
This simplifies maintenance. Alternatively, you can use the Export and Import 
functions to copy channels from one base station to another.

Default Channel You need to tell the base station which channel to use. The usual way to do 
this is to use the Service Kit to select one channel in the channel table as the 
default channel. When the base station starts up for the first time, it selects the 
default channel unless it is connected to external equipment that selects the 
channel. 

Current Channel The current channel is the channel that the base station is actually using. 
Usually, this is the default channel. However, external equipment can use 
digital input lines to choose another channel. Moreover, Task Manager can 
instruct the base station to change channel. It can even select another channel 
to be the default. Monitor > Monitoring > Channel displays the current 
channel.

Note: If the base station is reset, it starts up on the default channel, 
unless external equipment defines another channel.
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Profiles

Profiles are groups of configuration settings. They simplify the task of 
configuring channels. The base station has a large number of configuration 
settings, but most of these will be the same for all channels. Instead of 
configuring all options many times over for each channel, you configure them 
once in a profile. You then assign the profile to the appropriate channels (if you 
are working with the default profile, this is already done for you). 

Two profiles group almost all configuration settings: the channel profile (which 
defines the signal path for example) and the signalling profile (which defines the 
subaudible signalling and tail timers). 

The way you work with profiles varies, depending on whether the base station 
has an  Advanced Profiles and Task Manager license.

Using Default 
Profiles

The standard base station can only use the default profiles. You define most 
configuration settings globally in the two default profiles, and then you define 
the rest individually for each channel in the channel table. 

Using Custom 
Profiles

If the base station has the Advanced Profiles and Task Manager license, 
additional options are available and you can create a set of custom profiles. To 
configure an individual channel, you assign custom profiles to it. The only items 
you configure in the channel table are the transmit and receive frequencies. 
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Subaudible Signalling

The TB8100 base station can transmit and receive using subaudible signalling. 
Both CTCSS tones and DCS codes are supported. CTCSS attaches a 
subaudible tone to the carrier signal. DCS attaches a digital code. A receiver 
programmed with a particular tone or code will not unmute unless that tone or 
code is presented with the RF signal.

CTCSS tones and DCS codes are referred to collectively as subtones. Subtones 
make it possible for different groups of users to operate on the same channel 
without hearing or disturbing each other. The base station and the radios that 
use it need to be programmed with the same subtone(s). In some parts of the 
world, the use of subtones is regulated.

Assigning 
subtones

You assign a receive and a transmit subtone to a channel by editing the channel 
table. When the base station is operating on that channel, it opens the receiver 
gate to signals with the receive subtone and transmits using the transmit 
subtone.

If the base station has a license for the Advanced Profiles and Task Manager 
feature set, you can use a custom signalling profile to assign up to 16 subtones 
to a single channel. The receiver recognizes any of the assigned tones and 
responds according to its configuration for the particular tone. It can transmit 
the signal (encoding it with the same subtone), transmit the signal (with a 
different subtone), or carry out a Task Manager action. You can also add an 
audible reminder tone to the transmissions (for example, for customers who are 
behind with their payments). The 16 subtones can contain CTCSS tones and 
DCS codes. 

Matching DCS 
codes

Matching the base station’s DCS code to the code programmed into a group of 
radios can be tricky. This is because the polarity of a DCS code can become 
inverted. For example, a radio has a DCS code of 017 but the base station may 
need to be programmed with 050 (017 inverted). Either use simple trial and 
error to see which code works, or make test calls on the radios while running 
the base station’s subaudible scan diagnostic test, to find out what codes the base 
station is receiving.

Advanced options The base station always transmits a DCS end tone for muting the receive audio, 
but transmitting a CTCSS reverse tone burst is optional and configurable. The 
base station receiver can also be configured to respond to reverse tone bursts if 
they are expected. 
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Power Saving

The TB8100 base station can save power by switching off parts of its circuitry. 
The standard base station has a limited ability to reduce the current that the base 
station uses, but the Power Saving Modes license lets you configure three 
different power saving modes. This gives greatly increased flexibility and makes 
it possible to get the power savings needed with a minimum sacrifice in quality 
of service. 

Note: Power saving only occurs when the base station is battery-
powered. It is not available if the PMU supplies more than one base 
station.

Power saving 
modes

A base station with a Power Saving Modes license can operate in Normal, 
Sleep, and Deep Sleep modes. These modes are enabled and configured in the 
Service Kit. 

The base station begins in Normal mode. If the base station is idle (receives no 
valid signal) for a defined length of time, it switches to Sleep mode, which saves 
more power. If the base station is idle for a further defined length of time, it 
switches to Deep Sleep mode, saving even more power. When it receives a 
valid signal, it reverts to Normal mode.

Both receiver and transmitter contribute to the power saving.

The receiver is switched off, and then periodically switched back on. If it 
detects a valid signal, it stays on, otherwise it is switched off again. The power 
amplifier is always off when the base station is not transmitting. In power saving, 
other parts of the transmitter circuitry are switched off as well. The longer the 
Tx keyup time you select, the more circuitry is switched off. 

Quality of service The more power saved, the greater the effect on the quality of service. At the 
beginning of a call, the radio user needs to press PTT and wait before speaking, 
to give enough time for the receiver to come back on and for the transmitter 
to key up. 

Configuring 
power saving 

You configure power saving when you define the channel profile that the base 
station will use. For each mode, you specify Rx cycling (how long the receiver 
stays switched off before it wakes up to check if there is a valid signal and the 
Tx keyup time. In addition, you specify how long the base station must be idle 
before it enters Sleep and Deep Sleep modes. The exact amount of power saved 
varies, depending on the model of base station and the pattern of traffic.
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Task Manager

Task Manager is the ‘brains’ of the base station. When something changes, Task 
Manager carries out actions based on the intelligence contained in its list of 
tasks. Each task defines what you want the base station to do in response to a 
particular event. 

For example, when the battery voltage low alarm is triggered, Task Manager 
can tell the transmitter to reduce its power output. If an alarm you want to 
know about is triggered, Task Manager can tell the base station to start the over-
the-air alarm or email you a status message via the Alarm Center. If a line-
controlled base station’s line fails, Task Manager can tell the base station to 
function as a talk through repeater. 

Task Manager is essential for sending alarms to the Alarm Center, for emailing 
alarms and status messages, and for turning over-the-air and over-the-line 
alarms on and off. It can also carry out override actions that enable or disable 
many configured base station functions. 

If the base station has an Advanced Profiles and Task Manager license, you can 
initiate any action simply by sending the base station a CTCSS tone or DCS 
code. Task Manager can also change the whole operating configuration simply 
by changing to another channel that uses different profiles.

Task Manager only operates when the base station is in Run mode. 

Modifying Task Manager
To change the way Task Manager works, you add and modify tasks using the 
Service Kit, and then you program the changes into the base station. In effect, 
you are creating scripts that make the base station perform simple actions. This  
customizes the way the base station operates without modifying its firmware. 
Task Manager can perform many functions that previously required expensive 
external equipment. 
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In a standard base station, Task Manager can process up to 40 tasks. In a base 
station with an Advanced Profiles and Task Manager license, Task Manager can 
process up to 200 tasks.

Tasks and Comments
Task Manager acts only on the basis of the tasks in its task list. A task is rather 
like computer code and takes the form: 

 IF < input> THEN <action> 

When the IF part of the task becomes true, the THEN part is executed. There 
are also IF NOT tasks: when the input of such a task becomes false, the THEN 
part is executed. You can add comments describing the purpose of a task or 
group of tasks. Comments have no effect on Task Manager processing. 

Inputs
Task Manager inputs are of two main types, ‘basic’ and ‘override.’ Tasks are 
processed differently, depending on the kind of input they have. You need to 
understand these differences if you are creating complex sets of tasks.

Basic inputs Basic inputs come from various parts of the base station. They include all alarms. 
While basic inputs can become true at any time, Task Manager will only process 
them in the course of the regular 10 ms processing cycle. For example, if an 
input becomes true in the middle of a processing cycle, Task Manager won’t 
process tasks with that input until the next processing cycle. This is because it 
only learns of the change after the completion of the first cycle. 

Override inputs Override inputs can only become true through a Task Manager override action. 
They are internal to Task Manager. Most become true automatically each time 
the base station enters Run mode. 

There are some other inputs that don’t quite behave like basic or override 
inputs. Look under the input for more information.

Actions
Task Manager actions are of two main types, ‘override’ and ‘do now’. These 
actions have different effects. 

Override actions Override actions enable, disable, or toggle a configured base station function. 
As most of these functions are enabled by default, the main use of override 
actions is to let you turn off a function such as talk through repeater, power 
saving, or even the receiver as a whole. The action changes the state of a flag, 
which can only be changed by another override action. The status of each flag 
that is controlled by an override action is displayed in Monitor > Base Station 
> System Flags. 

This flag can also be an override input. When an override action is carried out 
(for example Enable power saving), the equivalent override input (for 
example Power saving enabled) becomes true and any tasks with that input 
will be processed. 
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Important: Override actions only enable a function if the base 
station is already configured for that function using the Service Kit. 
For example, enabling the talk-through repeater function will only 

have an effect if the current profile defines a talk-through repeater signal path. 
If the function is not configured, enabling, disabling, or toggling it will have no 
effect.

’Do now’ actions ‘Do now’ actions issue a command to the base station to do something 
immediately, for example to change channel or send the alarm log. This is a 
one-off action which has no continuing effect on the base station’s status. A ‘do 
now’ action cannot be re-triggered until the original action is completed. For 
example, Task Manager cannot carry out the action Transmit CWID now 
when the base station is still transmitting the CWID from a previous Transmit 
CWID now action. 

There are some other actions that don’t quite behave like override or ‘do now’ 
actions. Look under the action for more information.

Custom Inputs and Actions
A task can only have one input and one output. However, you can combine 
existing inputs or actions to form your own custom inputs or actions. 

A custom input combines up to eight different inputs. It becomes true when 
the combination becomes true, according to the rules of the Boolean logic that 
you specify for the combination.

Similarly, a custom action can combine up to eight actions. When a task with 
a custom action is processed, all its constituent actions are carried out. 

You can also use counters, timers, and your own flags when defining tasks.
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Remote Connections

The TB8100 base station is designed for remote monitoring, diagnostics, 
configuration, and control. The Service Kit can carry out all these functions 
remotely. Provided a remote link is in place, you can use the Service Kit to 
connect and log on to the base station just as if you were directly connected.

The remote link can consist of a telephone line with modems at each end, a pair 
of radio modems, or a pair of Tait radios that support the CCDI2 protocol. 

For each remotely linked base station, you need to create a ‘connection,’ which 
is a named configuration that tells the Service Kit how to communicate with 
the base station.

It is possible to limit remotely connected Service Kit users to read-only access 
to diagnostics and configuration or even to deny access completely. Local and 
remote connections have separate access profiles.

With a Remote Monitoring license, the base station can be remotely connected 
to an Alarm Center. On Task Manager instruction, the base station uses its 
modem to dial up an Alarm Center and pass on its alarm log or send a status 
message for emailing.
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Alarms

The base station monitors a large number of conditions. When a condition rises 
above or falls below a defined threshold, the base station generates an alarm and 
stores it in its alarm log. The alarm log contains the 50 most recent alarms.

Some alarms are inappropriate for particular systems; you can disable any that 
you do not want. 

Most alarms indicate a fault condition, but some are generated by conditions 
external to the base station, such as mains power failure or loss of RF input. 

Alarm Notification Options
The base station is able to notify you in the following ways when an alarm is 
activated: 

Transmitting pip tones

Sending pip tones over the line

Sending the alarm log to a PC running the Tait Alarm Center software

Emailing a status message via the Alarm Center. Status messages contain the 
alarm log and the current state of monitored parameters

Activating a digital output line

These methods are configured in the Service Kit but enabled by Task Manager 
action. As Task Manager has an input for each alarm, its response can vary 
depending on the alarm. You can create Task Manager tasks that optimize the 
response for your particular system. 

Enabling Alarm Notification
Alarm notification methods need to be set up and configured. Choose carefully 
which ones to implement, based on the available resources and your policy for 
remote monitoring. See TN-742, Remotely Monitoring and Configuring the Tait 
TB8100, for details.

To set up an alarm notification method, you may need a physical link (for 
example, modems and a telephone line). Then you use the Service Kit to 
configure the method. Finally, you define suitable Task Manager tasks. When 
something happens, a task is processed that tells the base station to use the 
method to notify the alarm.  Tasks can initiate notification:

When the base station is started or reset 

When any alarm occurs

When particularly important alarms are triggered
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System Interface

The base station reciter can be fitted with a system interface board. Several 
different boards make a variety of inputs and outputs available for different 
applications.

Select Monitor > Module Details > Reciter to see which system interface is 
fitted. Select Configure > Base Station > System Interface and choose the 
system interface that is fitted. The System Interface form now displays the 
current pin assignments and lets you configure some of them for external 
channel assignment. In addition, Task Manager actions make it possible to 
configure digital input lines to have any of a wide range of functions.
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Software Feature Enabler

The TB8100 base station has many capabilities, but some of them require a 
license before you can use them. The Service Kit lets you enable the feature sets 
you require. The following feature sets are available:

Default Radio 
System

Generally, base stations are already licensed with the Default Radio System 
feature set. Without it, the base station cannot operate in Run mode, but could 
be used for training.

Alarm Reporting The Alarm Reporting feature set enables the base station to remotely dial up 
using a modem. This means that the base station can report alarms to an Alarm 
Center or email status messages to a technician (this is done via the Alarm 
Center). 

Advanced Profiles 
and Task 
Manager

The Advanced Profiles and Task Manager feature set enables the base station to 
operate according to custom channel and signalling profiles that you define 
using the Service Kit. It also lets Task Manager process up to 200 tasks.

Power Saving 
Modes

The Power Saving Modes feature set makes it possible for the base station to 
operate in Sleep and Deep Sleep modes. This takes full advantage of the power 
management unit’s power saving capabilities. 
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Part B Getting Started

Establishing a Service Kit session with a base station is a three-
stage process. First you connect a cable (or set up a remote link), 
and then you establish communications with the control panel. 
Finally, you log on.

In a Service Kit session, you can monitor the base station and 
carry out diagnostic tests. You can also view the base station’s 
configuration.

To learn how to program the base station, go straight to the 
configuration tutorial.

Topics

Connecting and Logging On

Monitoring Alarms

Monitoring the Base Station

Viewing Configuration Settings

Diagnosing Problems

Configuration Tutorial
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Connecting and Logging On

The following instructions describe how to connect a Service Kit to a base 
station via a direct link to the control panel. You can connect remotely using a 
similar procedure, if a physical connection has been set up. For more detail, see 
“Connecting to a Base Station System” on page 38 and “Logging On to a Base 
Station” on page 39. 

To connect and log on to a base station

1. If the Service Kit is not already running, select Start > Programs > Tait 
Programming Applications > TB8100 Service Kit.

2. Connect the supplied cable or a standard mouse extension cable from a serial 
port on your PC to the serial port on the control panel. 

3. On the toolbar, click the Connect icon. The Connecting dialog box 
appears.

4. In the Connect to box, select a connection for the serial port you used. The 
Type field now shows ‘Direct connection.’ 

5. Click OK. The Log On dialog box appears.

6. Log on to one of the base stations in the base station system (BSS), as follows.

a. In the Base Station column, select a base station.

b. Select an access level. 

c. Enter the password for that level of access to the base station. (For more 
information, see “Logon Details” on page 40.)

d. Click OK to log on and close the dialog box. The status bar shows the 
name of the connection and the base station you are logged on to.

You can now monitor the base station, conduct diagnostic tests, and read and 
modify the base station’s configuration.
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Monitoring Alarms

When you are logged on to a base station, the Service Kit regularly polls the 
base station for alarms. If an alarm is detected, a flashing Alarms icon appears in 
the status bar. If the Alarms icon disappears, the Service Kit has detected that 
the alarm was cleared.

To monitor alarms

1. Check the status bar. If it has a flashing Alarms icon, click the Alarms button 
on the toolbar. This opens the Current Status form.

2. Look to see which LED is flashing red. A flashing LED means that the alarm 
is on. One problem can set off more than one alarm. 

Tip: To view a list of recent alarms, select Monitor > Alarms > 
Reported Alarms. 

Note: Most monitoring forms have an Alarm Status LED, which 
indicates whether the module has any active alarms.
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Monitoring the Base Station

Once you are logged on to a base station, you can monitor various aspects of it. 

To view a monitoring form

1. On the toolbar, click Monitor. The navigation pane displays a menu of 
options. 

2. In the navigation pane, click a subheading (for example ‘Reciter’).

The main part of the Service Kit window displays information relevant to 
the subheading.

Options To view the current status of all base station alarms, select Alarms > Current 
Status.

To view information about the modules belonging to the base station, select 
an item under Module Details.

To view information about the way the base station is currently operating, 
select an item under Monitoring.
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Viewing Configuration Settings

From the Service Kit, you can view a base station’s configuration settings. This 
information must be read after you have logged in to the base station. 

To view configuration settings

1. On the toolbar, click Read. 

The Reading dialog box displays progress.

2. On the toolbar, click Configure. The navigation pane displays a menu of 
options. 

3. In the navigation pane, click a subheading (for example ‘General’); the main 
part of the Service Kit window changes to display the corresponding form. 

In this way, you can view any aspect of the base station’s current 
configuration. 
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Diagnosing Problems

From the Service Kit, you can carry out a variety of tests on aspects of the base 
station you are logged on to. These can help you diagnose any problems you 
may be experiencing. The base station must be in Standby mode, which takes 
it out of active service.

To carry out a diagnostic test

1. On the toolbar, click Diagnose. The navigation pane displays a menu of 
options. 

2. Click the Mode icon and select Standby mode. This takes the base station 
out of service.

3. In the navigation pane, click a subheading (for example ‘Self Tests’); the 
main part of the Service Kit window changes to reflect your selection. 

4. Click Start Test. View the results of the test on-screen.

5. If necessary, click Stop Test.

6. Return the base station to Run mode. 
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Configuration Tutorial

The following tutorial shows you how to make some basic changes to the 
standard configuration that turn the TB8100 into a basic repeater. You modify 
the signal path, change from carrier gating to noise gating, optionally configure 
subaudible signalling, and set the receive and transmit frequencies. The aim is 
to get you started and to introduce you to some of the many configuration 
settings that are covered in the online Help and the manual. 

Step 1: Install the Service Kit and Calibration Kit on your PC
1. Insert the CD-ROM in your CD-ROM drive. 

2. If the CD does not autoplay, select Run from the Start menu and use the 
Browse button to select Setup.exe from the d: drive, where d is the 
CD-ROM drive, 

3. Follow the on-screen instructions.

You are given the opportunity to install the Alarm Center as well. If your 
system is designed for an Alarm Center, do this separately on a dedicated PC.

Note: If the base station does not have the required switching range, 
use the Calibration Kit to adjust it. This should be done before you 
configure the base station. See the Operation Manual and the 

Calibration Kit online Help for instructions.

Step 2: Connect and Log On
1. Using the cable supplied, connect a serial port on your PC to the serial port 

on the subrack front panel. 

2. Select Start > Programs > Tait Programming Applications > TB8100 
Service Kit.

3. On the toolbar, click Connect. 

The Connecting dialog box appears.

4. In the Connect to box, select Com1 or Com2, depending on the serial port 
you connected the cable to.
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5. Click OK. The Log On dialog box appears.

6. In the Base Station column, select a base station.

7. Select the User access level and enter the equivalent password (the default is 
user).

8. Click OK to log on.

Tip: You can get the base station receiving and transmitting on the 
frequencies you want without changing its configuration. Use the 
set receiver frequency and transmission diagnostic tests. 

Step 3: Read the Base Station’s Configuration
1. Click Read. The Reading dialog box displays progress.

2. Click Configure. The navigation pane displays a menu of options for 
configuring the base station. 

Step 4: Configure the Base Station as a Talk-Through Repeater
1. In the navigation pane, under Base Station, click General.
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2. Click Channel Profile. The Edit Channel Profile dialog box appears.

3. In the Receiver gating area, clear the RSSI gating check box and select the 
SINAD gating check box. Specify a level of 12 dB and a hysteresis of 2 dB. 

4. Click the Signal Path tab.

5. In the Talk through repeater list, click A-A. A thick line now connects 
the receive Path A to the transmit Path A.  

6. Make any other changes to the default channel profile, and click OK.
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Step 5: Configure a Channel
1. In the navigation pane, under Base Station, click Channel Table.

2. Decide which channel the base station will operate on.

3. In that channel’s row, enter receive and transmit frequencies.

4. Click in the Receive Signalling cell and select a CTCSS tone or DCS 
code. Do the same for Transmit Signalling.

5. Use the scroll bar to display the hidden columns in the table. 

6. In the Filter column, select Pre-De-Emph Speech Band. 

7. In the Channel Spacing column, select an option.

8. Click OK.

Step 6: Set the Default Channel.
1. Return to the General form. 

2. In the Default channel area, select the channel you configured.

3. Click OK.

Step 7: Program the Changes into the Base Station
1. Click Save to save your changes to a file, giving it a suitable name.

2. Click Mode and put the base station in Standby mode.

3. Click Program. The Programming dialog box appears and indicates 
progress.

When all the configuration information has been downloaded, it is 
programmed into the base station. When the Service Kit receives 
confirmation of this, it closes the dialog box. 

4. Return the base station to Run mode. It is now operational.
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Part C Basic Tasks

Before you can get down to the real work on a base station, you 
need to know how to carry out basic tasks such as setting up a 
connection, changing the base station’s mode, or reading 
configuration information. 

The Basic Tasks section explains in detail how to do these and 
other preliminary tasks. 

Topics

Using the Service Kit

Setting Service Kit Options

Setting Up and Configuring Connections

Connecting to a Base Station System

Logging On to a Base Station

Changing Base Station Mode

Working With Base Station Configurations

Logging Off and Disconnecting

Changing Base Station Passwords

Upgrading Base Station Firmware

Upgrading the Service Kit

Working with the Software Feature Enabler
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Using the Service Kit

When you start the Service Kit, a splash screen appears, followed by the 
application window.

By default, the Monitor icon on the toolbar is selected and the navigation pane 
gives you options for monitoring. When you click an item in the navigation 
pane, the main pane displays the corresponding form.

Toolbar
The toolbar gives you quick access to commonly used menu commands. For 
example, instead of selecting Base Station > Configure, click the Configure 
icon on the toolbar.

Open Lets you open a configuration file that is stored on the Service Kit computer.

Save Saves the open configuration. When saving a configuration file for the first 
time, you are asked to give it a name. 

Connect Lets you select a BSS to connect to. When you are connected, the button 
changes to Disconnect. See also “Connecting to a Base Station System” on 
page 38.

Log on Lets you log on to a base station, once you are connected to the BSS. When 
you are logged on, the button changes to Log off. See also “Logging On to a 
Base Station” on page 39

Read Reads in the configuration information of the base station you are logged on 
to. See also “Working With Base Station Configurations” on page 42.

Navigation pane

Status bar

Menu bar

Main pane

Toolbar
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Program Sends the whole set of configuration information in the Service Kit to the base 
station. The base station must be in Standby mode. Once programmed, the base 
station operates using the new configuration. See also “Working With Base 
Station Configurations” on page 42.

Mode Lets you change the base station’s operation mode. The traffic light indicates 
the current mode. Green means Run mode, Orange means Standby mode, and 
Red means Download mode. See also “Operation Modes” on page 4.

Monitor Lets you monitor the base station. See also “Monitoring the Base Station” on 
page 21.

Configure Lets you view and edit a configuration. If a configuration is not already selected, 
you are given the option of creating a new configuration, opening an existing 
one, or reading the base station’s current configuration. See also “Viewing 
Configuration Settings” on page 22.

Diagnose Lets you carry out diagnostic tests on the base station. See also “Diagnosing 
Problems” on page 23.

Alarms Turns red when any base station alarm is triggered. Click Alarms to display the 
current status of all base station alarms. See also “Monitoring Alarms” on 
page 127.

Help Displays a Help topic for the form or dialog box you are currently in.

Status Bar
The status bar provides you with useful information that supplements the 
display in the main pane.

 

Miscellaneous messages appear on the left. Four panels in the status bar contain 
a flashing alarm icon (when an alarm is triggered), any Service Kit requests, the 
name of the connection followed by the name of the base station that the 
Service Kit is logged on to, and the mode that the base station is currently in. 

‘Ready’ means that the Service Kit has completed the last user request and is 
ready to respond to another request.

Miscellaneous 
messages

Connection Service Kit 
requests

Current 
mode

Flashing alarm 
icon

Base station
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Setting Service Kit Options

The Options dialog box (Tools > Options) lets you indicate some preferences.

Temperature 
units

The Temperature units area specifies whether the Service Kit displays 
temperatures in Celsius or in Fahrenheit.

Default file locations
The Default file locations area specifies folders for configuration files, log files, 
license files, and firmware files. To modify a default location, click the button 
to the right of the box and select a folder.

Configuration 
files

When you save a configuration file for the first time, the folder specified in the 
Configuration files box is shown in the dialog box. You can select another 
folder if you want. (You already chose a folder for configuration files during 
installation.) 

Log files Specifies where the Service Kit stores the alarm log and error log.

License files Specifies where the Service Kit will look for license files when you ask it to 
enable additional feature sets in a base station. If you receive a license file, copy 
it to this folder.

Firmware files Specifies where the Service Kit will look for firmware files when you ask it to 
download new firmware into a base station. If you receive new firmware for a 
base station upgrade, copy it to this folder.
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Setting Up and Configuring Connections

The Connections dialog box (Tools > Configure Connections) displays a list 
of user-defined connections. It lets you add new connections or edit existing 
ones. When you connect to a BSS, you select one of the connections that you 
have created or edited.

There are different connection types, reflecting the different ways that the 
Service Kit can be physically connected to a BSS. (For information on remote 
connections to a BSS, see TN-742 Remotely Monitoring and Configuring the Tait 
TB8100.) You only need one connection for connecting directly to any BSS, 
but you need a different connection for each remotely connected BSS. 

 

If your PC has no serial port, obtain a USB to Serial (DB9) converter. When 
the driver for this is installed, the operating system makes a virtual serial port 
available.

Adding a Connection
The New Connection dialog box lets you define new connections and add 
them to the list of available connections. There should already be direct 
connections for COM1 and COM2. You need to set up one connection for 
each BSS with a remote link. 

Adding a Direct Connection
1. Select Tools > Configure Connections. The Connections dialog box 

appears.

2. Click New. The New Connection dialog box appears.



TB8100 Service Kit User’s Manual   Setting Up and Configuring Connections 35

3. In the Name box, enter a suitable name, for example ‘All’.

4. In the Connection type box, select Direct Connection. 

5. In the Serial Port Number box, select the port on your PC that will be 
used by the cable from the BSS. 

6. In the Baud rate box, select a suitable communications speed: for a direct 
connection, this can be 57,600 or even 115,200 Baud.

Note: You may experience slow or intermittent communications at 
baud rates of 56k and above. This is not a Service Kit or base station 
problem; it has been found that serial ports on some older PCs do 

not operate correctly. Moving the mouse makes the problem worse (use of one 
serial port affects the other). If you have this problem, select a slower Baud rate.

7. Set suitable polling intervals. These specify the interval from one poll of the 
base station to another. A direct connection can have very short intervals, 
for example 1 second for monitoring and 5 seconds for alarms.

8. Click OK. The new connection now appears in the Connections dialog 
box.

Adding a Modem Dialup Connection
For each BSS that is fitted with a dial-up modem, you need to define a 
connection. 

1. Select Tools > Configure Connections. The Connections dialog box 
appears.

2. Click New. The New Connection dialog box appears.

3. In the Name box, enter a name that uniquely identifies the BSS.

4. In the Connection type box, select Modem Dialup. 

The New Connection dialog box now looks like this:
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5. If your PC has more than one modem, select the one you want to use in the 
Connect using box. Normally, you do not need to click Configure and 
configure the PC’s port to the modem. The default settings can be left as 
they are. 

6. In the Phone number box, enter the telephone number of the line to the 
BSS’s dial-up modem. 

7. If the Service Kit needs to use the country code and the area code to access 
the BSS, provide this information as follows.

a. In the Area code box, enter the BSS’s area code.

b. In the Country code box, select the BSS’s country code.

c. Select the Use country code and area code check box.

8. Set polling intervals that are appropriate to the speed of your connection. 
The Alarms and Monitoring boxes specify the interval from one Service 
Kit poll of the base station to another.  

9. Click OK. The new connection now appears in the Connections dialog 
box.

Adding an Over-the-Air Connection
For each BSS that is fitted with a radio modem, you need to define a 
connection. 

1. Select Tools > Configure Connections. The Connections dialog box 
appears.

2. Click New. The New Connection dialog box appears.

3. In the Name box, enter a suitable name. The name should specify the BSS 
and the connection type

4. In the Connection type box, select Over the Air. 

The New Connection dialog box now looks like this:



TB8100 Service Kit User’s Manual   Setting Up and Configuring Connections 37

5. In the Modem protocol box, select CCDI 2.0 if the radio modem is a Tait 
radio that supports CCDI2. Otherwise, select RF modem. The equipment 
connected to the BSS must have the same setting.

6. In the Serial port number box, select the port on your PC that the radio 
modem is connected to. 

7. If the radio modem doesn’t use CCDI 2.0, define the other communications 
settings. (These settings are fixed for CCDI 2.0.)

8. Set appropriate polling intervals. The Alarms and Monitoring boxes limit 
how often the Service accesses the base station to obtain alarm and 
monitoring information. These intervals need to be long if the equipment 
is sharing the channel. 

9. Click OK. The new connection now appears in the Connections dialog 
box.

Editing a Connection
You may need to modify the settings of an existing connection, for example, if 
a telephone number changes or if the link is too slow for the polling intervals 
you selected. 

To edit a connection

1. Select Tools > Configure Connections. The Connections dialog box 
appears.

2. Click a connection to select it.

3. Click Edit. The Edit Connection dialog box appears.

4. Modify the settings as desired. For information about individual settings, see 
“Adding a Connection” on page 34.

5. Click OK. 
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Connecting to a Base Station System

Before you can work with a base station, you must connect to its base station 
system (BSS).

1. Connect the Service Kit physically to the base station subrack. (For a remote 
connection, this should already be in place: see TN-742 Remotely Monitoring 
and Configuring the Tait TB8100.) For a direct connection, follow these 
steps:

a. Connect one end of the supplied cable to the control panel serial port. 
This cable is an ordinary (straight through) RS 232 cable and is available 
separately (order code TBA0P10).

b. Connect the other end to a serial port on your computer. The serial port 
to use is the one specified when the direct connection was set up and 
configured.

2. Click Connect. The Connecting dialog box appears.

3. In the Connect to box, select a named connection from the drop-down 
list. If no suitable connection exists, click Edit Connection or New 
Connection to edit an existing connection or create a new one. For more 
information, see “Setting Up and Configuring Connections” on page 34.

4. Click OK. You can now log on to a particular base station.
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Logging On to a Base Station

Once the Service Kit is connected to a BSS, you can log on to one of its base 
stations. Logging on establishes a communication session with the base station. 
Data can go back and forth, for example, to display monitoring information or 
to carry out a diagnostic test. However, a further step is necessary before you 
can work with configuration information: you must read the base station or 
open a configuration file, even to view the configuration forms.

The Log On dialog box contains a table that lists the base stations in the BSS 
and a Logon details frame that lets you log on.

Base Station Table
Each row in the base station table displays information about a base station. 
LEDs indicate whether an alarm is active so that you can go first to the base 
station with the alarm and monitor or diagnose the module with the alarm. 

The PMU serial number is displayed in its own box, because it serves the whole 
BSS. 

Each module has an LED. If an LED is red, the module has an active alarm. If 
it is green, there are no active alarms. 

Base Station Displays the name of the base station. The LED to the left indicates whether 
the whole base station has any alarms.  The base station name is defined in  
Configure > Base Station > General: Identification area. 

Number The number of the base station’s reciter. This defines the reciter’s address on 
the control bus and is set by the rotary switch on the reciter front. Reciter 
number 1 is the control bus master.

Reciter S/N The serial number of the reciter. The LED to the left indicates whether the 
reciter has any alarms.

PA S/N The serial number of the power amplifier. The LED to the left indicates 
whether the PA has any alarms.
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Logon Details
The Logon details area lets you enter information for the log on.

Access level Defines the access level for the log on. An access level determines your access 
to the base station and your ability to carry out different functions. If your access 
level is ‘User’, what you can do depends also on the base station’s access profile. 
The access profile is configured by the Administrator.

  

Note: Authorized Tait service centers have a higher level of access 
when directly connected and do not need to select a level or enter 
a password. 

Password Enter the password into this box. This is the password for the base station and 
for the access level you selected. Each base station has its own set of passwords. 
Passwords can be changed by users with the Administrator access level (see 
“Password” on page 40). 

Access Level Description

User Lets you carry out the Service Kit functions that the 
administrator has selected for the base station in 
Configure > Security > Access Profiles. The administrator 
can specify one set of functions for a direct connection 
and another for the different kinds of remote connection.

Administrator Lets you carry out all Service Kit functions on the base 
station, including changing passwords for access to it.

Read only Lets you use the Service Kit to monitor the base station 
but not to change it or carry out any actions. You can read 
and view the base station’s configuration but not change 
it. You cannot carry out diagnostic tests. 

Access Level Default Password

User user

Administrator admin

Read only readonly
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Changing Base Station Mode

Some Service Kit operations can only be carried out when the base station is 
not in its normal operating mode. 

To change the base station’s operation mode

1. Click Mode. (Or, select Base Station > Change Mode.) If you have rights 
to change mode, the Change Operating Mode dialog box appears.

2. Select the mode you want.

Modes that you don’t have access rights to are disabled.

To leave Download mode, reset the base station. The Service Kit 
displays the Connecting dialog box. Wait about 10 seconds for the base 
station to start up, then re-connect and log on. The base station is now 
in Standby mode.

3. Click OK. 

Resetting the Base Station
You can reset the base station using the Service Kit. 

1. Click Mode.

2. Click Reset Base Station.

3. Wait for the base station to restart, and then connect and log on again.
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Working With Base Station Configurations

Base stations are programmed with many configuration settings. Using the 
Service Kit, you can view these settings, change them, and then program them 
into the base station. You can also create a new configuration from a template 
and save a configuration to a file.

Configuration works differently from other Service Kit functions. Once you 
are logged on, you can monitor the base station but you can’t yet view its 
configuration. First you must click the Read icon, which instructs the base 
station to supply its configuration information.

Programming the base station with a new configuration can only be done 
when the base station is in Standby mode.

You can obtain configuration information from a base station, from a 
configuration file, or from a configuration template. 

Figure 1: Obtaining Configuration Information

Ways of working 
with 
configurations

There are several different methods that you can use to create and maintain base 
station configurations.

Read the base station’s configuration, modify it, and program the changed 
configuration back into the base station.

Create a template from a base station’s configuration and use it to create 
configurations for other base stations.

Export one base station’s channels or task list and import it into other base 
stations.
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Creating a New Configuration
You can create a new base station configuration from scratch, modify it, and 
save it as a new configuration. This means that you can define a configuration 
without being connected to a base station. This is a good way to learn how to 
use the configuration part of the Service Kit program. It also means that you 
can do all the work of configuring before a base station is delivered. When it 
arrives, you just open the configuration file and program it into the base station. 
(This method completely overwrites the base station’s current settings.)

To create a new configuration

1. Select File > New. The Select Template File dialog box appears. 

2. Select an appropriate template (*.t8t file) from the templates in the 
Template folder. This template will provide a set of default settings. 
Templates can be provided by Tait or created for your system or 
organization.

3. Click Open.

The title bar displays ‘Untitled.t8c’, indicating that you have not given the 
configuration a name and saved it. 

You can now click Configure to view the current configuration settings, make 
any configuration changes, and save the configuration settings to a file. You can 
also program a base station with these settings. 

Reading a Configuration
Before you can view a base station’s configuration settings, you must read them. 
If they were saved to a file, they also exist in the Service Kit’s Configurations 
folder. 

Note: Reading configuration settings overwrites any settings that the 
Service Kit has in memory. If you have opened a configuration file, 
save and close it first.

1. Connect to the BSS and log on to the base station.

2. Click Read.

The Service Kit reads the base station’s configuration information. If this 
information was saved to a file, the Service Kit loads the information from 
that file. This is much quicker, especially for remote connections. It checks 
to make sure that the information on file is the same as the information in 
the base station. If some parts of the configuration in the base station have 
been updated after the file was saved, these parts are read from the base 
station.
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Important: When you read a configuration and the base station 
cannot detect its PA or PMU, it is unable to provide the 
configuration settings that are stored in the module. The Service Kit 

fills in the gaps by providing default settings. If this occurs, you might 
subsequently overwrite the module’s settings with defaults that are unsuitable 
for your system.  Before re-programming the base station, check and edit these 
default settings. They include alarm thresholds and the auxiliary power output 
configuration.

The Reading dialog box displays progress and gives you the option of 
canceling the process. The title bar displays the name of the configuration 
file. Any changes you make and save will be saved to this file. (If the title bar 
displays ‘Untitled.t8c,’ you need to specify a file name when you save your 
changes.)

You can now click Configure to view the current configuration settings, make 
any configuration changes, and save the configuration settings to a file. You can 
also put the base station into Standby mode and program it with the new 
settings. 

Saving a Configuration
It is a good idea to regularly save your current configuration settings as you 
work on them. You should also save them when you program them into a base 
station. In this way, you have a backup. The Service Kit can automatically use 
this to quickly load the settings if you need to read them again. It is also available 
in case the base station fails or its memory becomes corrupt.

To save configuration settings

1. After making any changes to configuration settings, click OK to confirm 
them.

2. Select File > Save or click Save.

If the configuration settings are already named, they are saved. If not, the 
Save Configuration File dialog box appears and you must continue as 
follows:

3. Enter a name for the configuration file into the File name box.

4. If you want to save the configuration file somewhere other than in the 
Configurations folder, alter the default path.

5. Click Save. The name you provided appears on the title bar. 

Programming a Base Station
To change a base station’s configuration settings, you must make the changes 
using the Service Kit, and program them into the base station. Programming 
only affects the settings that you can view after clicking Configure.

To program a base station

1. Log on to the base station (if you aren’t already). 

2. Click Mode and put the base station into Standby mode. 

3. Check that the current configuration settings displayed in the Service Kit are 
what you want. Click OK to confirm this.

4. Select File > Save to create a copy of the configuration settings as a file in 
the Configurations folder.
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5. Click Program. 

The Programming dialog box appears and indicates the download progress.  
When the base station has successfully received all the configuration settings 
and programmed them in, the Programming dialog box closes. 

If the download is not completely successful, programming is aborted and a 
message appears. Later, you can open the file you saved and try again. 

Important: When you program a base station, any changes to the 
PMU configuration will affect the operation of the PMU, which 
supplies the other base station in the BSS. That base station’s 
operation may be interrupted or otherwise affected. 

6. Return the base station to Run mode.

Creating a Configuration Template
The base station comes with templates that define configuration settings for 
different applications. When you create a new configuration, the template you 
select provides the configuration with sensible default settings. This enables you 
to concentrate on the main things that need to be changed.

You may want to add your own template. You can then quickly create a 
configurations with the settings you want. These could be settings common to 
all base stations in a system or settings that a system integrator generally uses. 

To create a configuration template

1. Edit the settings in a configuration file until they are as you want them. 
Click OK.

2. Save the file.

3. Select File > Save as Template. The Save Configuration Template dialog 
box appears.

4. Enter a name for the template.

5. Click Save. The Service Kit saves the configuration settings to a template 
file. This file has the name you entered and the template extension (.t8t). 
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Changing Base Station Passwords

Each base station stores its own password for each of the three access levels. If 
you log on to the base station as Administrator, you can change any of these 
passwords. While the base station is password-protected, the Service Kit is not. 

To change a password

1. Select Base Station > Change Passwords, and then select the appropriate 
sub-option for the password that you want to change. The Change User 
Password dialog box appears.

2. Enter the Administrator password.

3. Enter the new password.

4. Re-enter the password in the next box.

5. Click OK to change the password and close the dialog box.

Important: Take care not to lose the Administrator password.
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Logging Off and Disconnecting

When you have finished working with a base station, click Log Off to log off 
or Disconnect to disconnect from the BSS. Logging off lets you immediately 
log on to the other base station in the BSS.

If the base station is in Standby or Download mode, you are reminded of this 
and asked to confirm that you want to proceed. This is to make sure that you 
do not inadvertently leave the base station out of service when you end a 
Service Kit session. Select No to cancel logging off or disconnecting, and then 
change the base station’s mode back to Run before logging off or 
disconnecting. 
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Upgrading Base Station Firmware

Before you can upgrade the firmware in a base station, you must obtain an 
upgrade package from Tait. This contains firmware files as well as a 
compatibility file that provides information about firmware versions and the 
hardware that they can run on. 

To upgrade base station’s firmware

1. Copy the firmware files and the compatibility file into the Service Kit’s 
firmware files folder (to find out where this folder is located, select Tools > 
Options). 

2. Using a direct connection, connect to the BSS and log on to the base station 
as Administrator. Put the base station in Download mode. 

3. Select Tools> Firmware Download. The Firmware Download dialog box 
appears.

The Service Kit obtains information about the base station’s modules and 
displays it in the Current Versions area. It then determines whether the new 
firmware is compatible with the base station’s hardware. If it is, the version 
number of the new firmware appears in the Target Versions area. (To view 
the compatibility file and see what firmware versions are available, click 
Show Details.) 

4. In the Target Versions area, select the check boxes of the modules you 
want to upgrade.

5. Make sure that the Progress area displays Ready for the modules you want 
to upgrade, and then click Download. 

The Service Kit reads the base station’s configuration information, stores it 
on disk, and then downloads firmware for the modules you selected. The 
Progress area indicates what is happening. 

Note: When the PMU is being upgraded it can still provide power 
to the entire BSS, but it cannot control its fan or provide 
information about alarms, monitoring, or diagnostics. 

If a step in the process is unsuccessful, you are given some options. You may 
be able to skip to the next module leaving the failure as is, restart the 
firmware download (this means going back to the Firmware Download 
form and trying again), or retry the step that failed. If necessary, contact Tait 
for assistance. It helps if you can provide the error log (this is stored in the 
LogFiles folder (see Tools > Options for its location).
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When all LEDs are green and the text box displays ‘Done’, the firmware 
upgrade has been successfully completed. The firmware has been 
downloaded and written to flash memory. 

6. Wait while the Service Kit resets the base station and automatically logs on 
again. It checks that the base station is operating with the downloaded 
firmware versions, and then programs the stored configuration information 
back into the base station. It resets the base station again and automatically 
logs back on.

7. When the message Firmware Download Complete appears, return the base 
station to Run mode. 

The base station is now operating with the new firmware.
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Upgrading the Service Kit

If standard Task Manager inputs or actions or additional system interface board 
options are added to base stations, the Service Kit cannot recognize them until 
it is upgraded.

To upgrade the Service Kit

1. Select Tools > Upgrade Service Kit. The Open Service Kit Upgrade Script 
dialog box appears.

2. Select the upgrade script file. 

3. Click Open.
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Working with the Software Feature Enabler

The software feature enabler (Tools > Software Feature Enabler) lets you 
enable additional feature sets in the TB8100 base station. The base station 
already has these feature sets but it needs license keys to enable them. The 
software feature enabler also displays the status of all feature sets and lets you 
disable any that are enabled.

The form displays the name and reciter serial number of the base station you are 
connected to. Each row in the table displays information about a feature set: the 
Feature code used to order a feature set, its name, and whether it is enabled or 
disabled. The Seq column indicates how many times it has been enabled or 
disabled. 

Enabling Additional Features
If you want a feature set, obtain a license key from Tait for that feature set, and 
then use the Service Kit to enable it.

To enable a feature set

1. Connect and log on to the base station.

2. If you received the license key in a license file, copy that file (and any others 
that you received for other feature sets or other base stations) to the Service 
Kit’s license file folder (select Tools > Options to see which folder the 
Service Kit uses).

3. Go into Standby mode, and then select Tools > Software Feature Enabler. 

4. Click the feature set to select it.

5. If you received a license file, click Find License File. This searches the 
license file folder for a license file for the current base station and the selected 
feature set. If the Service Kit finds one, it displays the license key (in the 
feature set’s row and in the Feature License Key boxes), and increments the 
Seq column by 1. 

6. If you don’t have a license file, enter the license key into the Feature License 
Key boxes.

7. Click Enable. This enables the feature set. The license key appears in the 
feature set’s row and the Seq column is incremented by 1.
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Disabling a Feature Set
Feature sets are not normally disabled. However, disabling may be desirable in 
special circumstances, for example, if you are trying out the feature set and 
decide not to purchase it.

Disabling the Alarm Reporting Feature Set
You can only disable this feature set if the base station does not use it. 

Important: A disabled feature set can only be re-enabled by 
purchasing a new license key. The original feature license key 
cannot be re-used. 

1. Check the Reciter Serial Number box to make sure that you are logged 
on to the correct base station.

2. Make sure that communications with the Alarm Center (Configure > 
Communications > Alarm Center) and communications  using email 
(Configure > Communications > Email) are disabled.

3. Go into Standby mode. 

4. Select Tools > Software Feature Enabler.

5. Select the feature set’s row. 

6. Click Disable.

The progress bar indicates how far the disabling has progressed. On 
completion, a new number appears in the Feature License Key column. 
Communicate this new number to Tait if you are entitled to a refund or if 
you want to re-enable the feature set. 

Disabling the Advance Profiles and Task Manager Feature 
Set
You can only disable this feature set if the base station does not use it. 

Important: A disabled feature set can only be re-enabled by 
purchasing a new license key. The original feature license key 
cannot be re-used. 

1. Check the Reciter Serial Number box to make sure that you are logged 
on to the correct base station.

2. Make sure that no channels use customized channel or signalling profiles. (In 
other words, they all use default profiles.)

3. Make sure that there are no more than 40 enabled task manager tasks.The 
number of enabled Task Manager tasks is displayed in all Task Manager 
forms. If necessary, disable unneeded tasks until the total number is 40 or 
less. 

4. Go into Standby mode. 

5. Select Tools > Software Feature Enabler.

6. Click the feature set’s row. 

7. Click Disable.

The progress bar indicates how far the disabling has progressed. On 
completion, a new number appears in the Feature License Key column. 
Communicate this new number to Tait if you are entitled to a refund or if 
you want to re-enable the feature set. 
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Disabling the Power Saving Modes Feature Set
You can only disable this feature set if the base station does not use it. 

Important: A disabled feature set can only be re-enabled by 
purchasing a new license key. The original feature license key 
cannot be re-used. 

1. Check the Reciter Serial Number box to make sure that you are logged 
on to the correct base station.

2. Make sure that all channel profiles have Sleep and Deep Sleep modes 
disabled. 

3. Go into Standby mode. 

4. Select Tools > Software Feature Enabler.

5. Select the feature set’s row. 

6. Click Disable.

The progress bar indicates how far the disabling has progressed. On 
completion, a new number appears in the Feature License Key column. 
Communicate this new number to Tait if you are entitled to a refund or if 
you want to re-enable the feature set. 

Disabling the Default Radio System Feature Set
If the Default Radio System feature set is disabled, the base station cannot 
operate in Run mode. You can configure it, monitor it, and carry out 
diagnostic tests on it, but not use it as a base station. It is suitable for training 
purposes only. 

Important: A disabled feature set can only be re-enabled by 
purchasing a new license key. The original feature license key 
cannot be re-used.

1. Check the Reciter Serial Number box to make sure that you are logged 
on to the correct base station.

2. Go into Standby mode. 

3. Select Tools > Software Feature Enabler.

4. Select the feature set’s row. 

5. Click Disable.

The progress bar indicates how far the disabling has progressed. On 
completion, a new number appears in the Feature License Key column. 
Communicate this new number to Tait if you are entitled to a refund or if 
you want to re-enable the feature set. 
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Part D Monitoring

The Service Kit lets you monitor the TB8100 base station. It can 
provide details about each module and monitor the level of 
incoming and outgoing signals. The Service Kit can also display 
the base station’s log. Monitoring can take place while the base 
station is in Run mode; it has no effect on base station operation.

The Service Kit also shows you whether any alarms are active. 
You can view the status of all alarms or a list of recent alarms. 
See “Alarms” on page 125.

To monitor a base station, log on to it, click Monitor, and select 
an item from the navigation pane. 

Topics

Module Details

Operational Information

Viewing System Data
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Module Details

The Service Kit can display details about the reciter,  PA, and  PMU of the base 
station you are logged on to. Items under the heading Module Details give you 
information about the module such as its frequency range and firmware version. 
To monitor the way the base station is operating, see “Operational 
Information” on page 61.

Viewing Reciter Information
The Reciter form (Monitor > Module Details > Reciter) lets you view 
information about the reciter module of the base station you are logged on to. 
Use it to confirm exactly what it is that you are dealing with.

 

The form has several read-only fields, an LED indicating whether there are any 
reciter alarms, and an area that gives version information.

Module The name of the module (reciter) followed by a number. This number is set by 
the rotary switch on the front of the reciter and plays a role in control bus 
communications within the BSS. 

Product code The product code and name for the type of reciter. 

Band The RF frequency band of the reciter. This is the frequency range that the 
reciter is type-approved to operate in.

Receiver setting The current switching range of the receiver. This can be changed using the 
Calibration Kit.

Exciter setting The current switching range of the exciter. This can be changed using the 
Calibration Kit.

System interface The type of system interface card that the reciter is fitted with.
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Alarm status Indicates whether the reciter currently has any alarm conditions. If the LED is 
green, there are no active reciter alarms. If the LED is red, the text box displays 
‘Alarms active,’ and there is at least one active alarm. To see which alarm is 
active, select Monitor > Alarms > Current Status. 

Serial number A unique identifier assigned to the reciter in the factory.

Versions
The Versions area (Monitor > Module Details > Reciter) displays version 
numbers for aspects of the reciter. 

Hardware The version number of the reciter’s hardware.

Firmware The version number of the reciter firmware and its creation date.

Calibrated The date when the reciter was last modified using the Calibration Kit. (This 
includes adjusting the switching range and tuning the frequency response.)

System interface The version number of the system interface board installed in the reciter.

Viewing Power Amplifier Information
The Power Amplifier form (Monitor > Module Details > Power Amplifier) lets 
you view information about the PA module of the base station you are logged 
on to. Use it if you need to confirm exactly what it is that you are dealing with.

Module The name of the PA. This non-editable name is used internally to identify the 
PA.

Product code The product code and name for the type of PA. 

Band The RF frequency range that the PA is type-approved to operate in.
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Power Specifies the RF power output rating of the PA. There are 5 W, 50 W, and 
100 W variants.

Isolator Indicates whether the PA is fitted with an optional isolator. 

Alarm status Indicates whether the PA currently has any alarm conditions. If the LED is 
green, there are no active alarms. If the LED is red, the text box displays ‘Alarms 
active,’ and there is at least one active alarm. To see which alarm is active, select 
Monitor > Alarms > Current Status. 

Serial number A unique identifier assigned to the PA in the factory.

Versions
The Versions area (Monitor > Module Details > Power Amplifier) displays 
version numbers for aspects of the PA. 

Hardware The version number of the PA hardware.

Firmware The version number of the PA firmware and the date when the PA was updated 
to its current firmware.

Calibrated The date when the PA was last calibrated using the Calibration Kit.

Viewing Power Management Unit Information
The Power Management Unit form (Monitor > Module Details > Power 
Management Unit) lets you view information about the PMU of the base 
station you are logged onto. Use it if you need to confirm exactly what it is that 
you are dealing with.

Module The name of the PMU. This non-editable name is used internally to identify 
the module on the rack frame bus.

Product code The product code and name of the PMU module. 
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Alarm Status Indicates whether the PMU currently has any alarm conditions. If the LED is 
green, there are no active alarms. If the LED is red, the text box displays ‘Alarms 
active,’ and there is at least one active alarm. To see which alarm is active, select 
Monitor > Alarms > Current Status. 

Serial number A unique identifier assigned to the PMU in the factory.

Inputs
The Inputs area (Monitor > Module Details > Power Management Unit) 
indicates which inputs the PMU is able to use.

Mains ‘Available’ indicates that the PMU is fitted with an AC-DC converter 
submodule. It can use mains input.

Battery ‘Available’ indicates that the PMU is fitted with a DC-DC converter 
submodule. It can use DC power as an input.

Outputs
The Outputs area (Monitor > Module Details > Power Management Unit) 
indicates whether the PMU is able to supply an optional output.

Auxiliary power ‘Available’ indicates that the PMU is fitted with an auxiliary power supply 
submodule. It can provide an output for auxiliary equipment or for charging 
the batteries. 

Versions
The Versions area (Monitor > Module Details > Power Management Unit) 
displays version numbers for aspects of the PMU. 

Hardware The version number of the PMU hardware.

Firmware The version number of the PMU firmware and its creation date.

Calibrated Indicates when the PMU was last calibrated using the Calibration Kit.
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Operational Information

The Service Kit can monitor the base station’s current settings and the way the 
reciter, PA, and PMU are operating. You must be logged in to that base station. 
Click Monitor, and then choose one of the items under Monitoring. To display 
information about the modules themselves, see “Module Details” on page 57. 

Monitoring the Current Channel
The Channel form (Monitor > Monitoring > Channel) displays information 
about the channel that the base station is currently operating on. 

The Current channel area specifies which channel is current and displays its 
most important details. 

The Channel profile and Signalling profile areas display information about the 
profiles assigned to the current channel.

The Current source area tells you whether the channel was selected by software 
(the Service Kit) or by hardware (external channel selection lines). If an external 
reference source is connected, it tells you what frequency the base station 
expects. 

Current Channel
The Current channel area (Monitor > Monitoring > Channel) displays details 
about the channel that the base station is currently using. The Channel 
number and Channel name boxes identify the channel. The Rx frequency 
box indicates the frequency that the base station is receiving on and the Tx 
frequency box indicates the frequency that it transmits on. Channels are 
created in Configure > Base Station > Channel Table.

Profile Information
The Signalling profile and Channel profile areas (Monitor > Monitoring > 
Channel) indicate which profiles have been assigned to the channel and display 
information about them. This information is the same as appears in the channel 
table.
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Current Source
The Current source area (Monitor > Monitoring > Channel) indicates what 
selected the current channel and which source provided the reference 
frequency. 

Note: The current source’s choice of channel can be overridden by 
Task Manager action.

Channel source The Channel source box indicates whether hardware or software selected the 
current channel.

Clock reference The Clock reference box indicates what is providing the base station with a 
reference frequency (from which it derives the channel frequencies). 

Option Description

Hardware The channel number was selected externally using equipment 
that is connected to channel selection lines on the base 
station’s external interface. Hardware channel selection is 
enabled in Configure > Base Station > System Interface.

Software The channel number was selected by software. The channel 
number is the default channel (set by the Service Kit in 
Configure > Base Station > General).

Option Description

Internal The base station’s own clock signal is the reference source.

External External equipment is providing the reference source via a BNC 
connector at the rear of the reciter. The Service Kit must tell the 
base station whether to expect 12.8 or 10 MHz (Configure > 
Base Station > Miscellaneous).
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Monitoring the Reciter
The Reciter form (Monitor > Monitoring > Reciter) lets you monitor the 
RSSI and SINAD of the received signal and the audio levels on the input and 
output lines. Each level is displayed graphically as a gauge. The equivalent 
numeric value appears under the gauge heading.  If the value is red, it has 
exceeded the maximum or fallen below the minimum that the gauge can 
display.

The first box in the form displays the internal name of the reciter.

Alarm status The Alarm status box indicates whether the reciter has an alarm. If the LED is 
red, select Monitor > Alarms > Current Status to see which alarm is active.

Received signal The Received signal area displays the RSSI and SINAD levels. (If you want to 
know the equivalent RSSI in microvolts, see “Converting Between Microvolts 
and dBm” on page 78). The SINAD is only an approximation.

Input lines The Input lines area displays the audio levels for the balanced and unbalanced 
line inputs. 

Output lines The Output lines area displays the audio levels for the balanced and unbalanced 
line outputs. 
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Monitoring the Power Amplifier
The Power Amplifier form (Monitor > Monitoring > Power Amplifier) lets 
you monitor the levels of various parameters. Each level is displayed graphically 
as a gauge or thermometer. The equivalent numeric value appears in or under 
the heading.  If a value goes off the scale, it turns red. 

The first box in the form displays the internal name of the PA.

Alarm status The Alarm status box indicates whether the PA has an alarm. If the LED is red, 
select Monitor > Alarms > Current Status to see which alarm is active.

Transmitter 
output

The Transmitter output area displays the forward and reverse power. Click 
Watts or dBm to view these parameters as watts or dBm. Underneath is the 
VSWR. If the VSWR is greater than 10:1, an alarm is triggered and the PA 
folds its output back to 10% of its capability. Only when the VSWR falls below 
5:1 will the power output begin to recover.

Duty cycle 
(5 minutes)

Indicates the average duty cycle over the past 5 minutes. This parameter is 
updated once every minute. 50% means that the PA was transmitting for 2.5 of 
the last 5 minutes. 

Duty cycle 
(24 hours)

Indicates the average duty cycle over the past 24 hours. 25% means that the PA 
was transmitting for 6 of the last 24 hours.

Heatsink 
temperature

Displays the highest of the three temperatures measured at the PA driver, 
Final 1, and Final 2 transistors. 

Air intake 
temperature

This thermometer displays the temperature measured at the air intake to the PA 
heatsink. 
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Monitoring the Power Management Unit
The Power Management form (Monitor > Monitoring > Power Management) 
lets you monitor the operation of the PMU. You can:

Check the voltage of the battery and the current that the PMU outputs to 
the PA.

See whether the base station is running on battery or mains power.

Check the status of the PMU’s inputs and outputs.

This form has a gauge displaying the battery voltage and another displaying the 
output current. Boxes represent different PMU submodules and LEDs indicate 
the status of power inputs and outputs. A box is disabled if the equivalent 
submodule is not installed.

The first box in the form displays the name of the module: power management 
unit.

Alarm status The Alarm status box indicates whether there is a current alarm. If the LED is 
red and the box displays ‘Alarms active’, one or more PMU alarms have been 
triggered. Select Monitor > Alarms > Current Status to see which alarms are 
active.

Battery voltage 
gauge

The battery voltage gauge indicates the voltage of the DC power supply to the 
PMU (whether or not it is currently being used).

Power inputs
LEDs in the boxes in the middle of the form indicate the status of the different 
power inputs.
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AC-DC converter The LED in the AC-DC Converter box indicates the state of AC power.

The box label indicates the voltage the DC-DC converter is designed for (12, 
24, or 48 V). 

DC-DC converter The LED in the DC-DC converter box indicates the state of the battery input, 
whether or not that input is currently being used.

Standby converter The LED in the Standby converter box indicates the state of the DC supply to 
the standby converter. This submodule operates only when the PMU enters 
deep sleep mode, in which it provides power only to the reciter.

Power outputs
The right-hand side of the form displays information about the PMU’s power 
output to other TB8100 equipment in the rack frame. 

There are three arrows going into the Output switch box. The one that is not 
disabled indicates which converter is currently providing power

PA The PA LED displays green if the PMU is supplying power to the PA and gray 
if it is not. When the PMU is using mains power, it always supplies power to 
the PA. When it is using battery power, it supplies power unless it is in sleep 
mode and using the standby converter. 

Reciter/control 
panel

The Reciter/control panel LED indicates the status of the power supply to the 
receiver and the control panel. Green means that it is supplying power. Gray 
means that it is not, because the PMU is in battery protect mode. 

LED Text Description

Green On AC power input is usable

Red Off AC power input is too low or too high 

Gray Off Mains Failure test is running

LED Text Description

Green On Battery input is usable.  The PMU can provide up to 500 W 
(or up to 40 W of power in low power mode). 

Red Off Battery voltage is too low or too high.

Gray Off No battery power supply is fitted (the box is also disabled).

LED Text Description

Green On The standby DC supply has been turned on. The PMU is 
providing only 10 W of power to the exciter.

Red Off Battery voltage is too low or too high.

Gray Off No standby battery power supply is fitted. 
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Auxiliary output The Auxiliary output box has an LED that indicates the status of the auxiliary 
power or battery charging output.

The box label indicates the voltage that the auxiliary power submodule is 
designed to produce (12, 24, or 48 V). 

Output Current 
gauge

The Output Current gauge shows how much current the PMU is supplying to 
the rest of the BSS. 

LED Text Description

Green On The standby DC supply has been turned on. The PMU is 
providing only 10 W of power to the exciter.

Red Off There is a fault. This could be because there has been a 
current overdraw and the fuse is blown. On cooling, the 
fuse will automatically reset.

Gray Off No auxiliary power supply unit is fitted or the PMU has 
turned the output off.
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Viewing System Data

The base station stores data about its own operation. It keeps count of some 
items, records the maximum or minimum value of others, and also calculates 
some averages. Averages are rolling averages over the last 24 hours.  For 
example, the base station stores the highest temperature that the PA has reached 
and it adds up the total number of hours that the fan has been operating for. 
You can view this information in the System Data form (Monitor > Data 
Logging > System Data).

The Resettable and Permanent option buttons give you the choice of two 
sets of data. These sets are rather like the trip meter and the odometer of a car.

Click Permanent to display the permanent data set.  This data set is maintained 
for the whole life of the base station and can only be reset by authorised service 
centers, for example after repairs to a module. 

Click Resettable to display the ‘trip meter’ set of data. With administrator 
access, you can reset any or all of the data. 

Reset buttons let you reset an individual parameter and the Reset All button 
resets all system data values. These buttons are disabled when you view the 
permanent set of values, unless you are logged on as a service center. If you reset 
a counter, it starts counting again from zero. If you reset a maximum, average, 
or minimum, it initially displays the current parameter value. 

Base Station Data
The Base station area (Monitor > Data Logging > System Data) displays the 
following data.

Base station 
operating time

The number of hours that the base station has been powered up and operating 
in Run, Standby, or Download mode.

Transmitter duty 
cycle

The percentage of the operating time that the base station has actually been 
transmitting. 
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VSWR The highest, the average, and the minimum voltage standing wave ratio 
readings are shown. The base station reads the VSWR once in every 
transmission.

RSSI The  highest, the average, and the minimum RSSI readings are shown in dBm. 
The base station reads the RSSI once each time the base station receives a valid 
signal.

Watchdog resets The total number of times that the watchdog circuit reset the reciter because 
the reciter firmware locked up.

Task Manager 
resets

The total number of times that Task Manager reset the base station.

Service Kit resets The total number of times that Service Kit users reset the base station.

Power Amplifier Data
The Power Amplifier area (Monitor > Data Logging > System Data) displays 
the following data.

Temperature The Power Amplifier area displays maximum, average, and minimum 
temperatures. The maximum temperature is the highest maximum temperature 
recorded by any of the three PA temperature sensors. These temperatures are 
read hourly. 

Air intake 
temperature

The Power Amplifier area displays maximum, average, and minimum air intake 
temperatures. The air intake temperature is read hourly.

PA fan operating 
time

The number of hours that the PA fan has been operating.

Power Management Unit Data
The Power Management Unit area (Monitor > Data Logging > System Data) 
displays the following data.

Battery voltage The area displays maximum, average, and minimum battery voltages. The 
battery voltage is read hourly whether or not the PMU is using the battery as 
its power supply.

PMU fan 
operating time

The number of hours that the PMU fan has been operating.
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Part E Configuring the Base Station

The Service Kit lets you configure the TB8100 base station.

Click Configure, and select an item from the navigation pane. 

For information about configuring channels and their profiles, 
see “Configuring Channels” on page 85.

Topics

Choosing a Configuration

Configuring General Options

Configuring the System Interface

Configuring Miscellaneous Items

Defining Access Profiles

Printing a Base Station Configuration
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Choosing a Configuration

If you click Configure and the Service Kit doesn’t already have a configuration 
loaded, it asks you to choose one to work with. 

Click New to open a new configuration based on the default template.

Click Open to select an existing configuration file.

Click Read to read a base station’s configuration. You may need to connect 
to a BSS and log in to a base station first. 
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Configuring General Options

The General form (Configure > Base Station > General) names the base station 
and specifies the default channel. From this form, you can customize the default 
channel and signalling profiles. A panel on the right gives you high-level 
instructions on how to configure channels in a simple system. 

Identification Specifies the name of the base station. Enter a suitable name. This name is used 
in the Log On form to help you select the correct base station within the BSS. 
You may need to disconnect and turn the base station off, and then turn the 
base station on again and re-connect, before a new name appears in the log on 
window and on the status bar.

Default profiles Lets you configure default profiles. Click Channel Profile or Signal Profile 
to open the editing dialog box for the corresponding default profile.   

Default channel Specifies the default channel. Select a channel from the drop-down list to make 
it the default channel (see “Default Channel” on page 5). The drop-down list 
contains all the channels that have been defined in the channel table (Configure 
> Base Station > Channel Table). Each entry in the list contains a channel 
number followed by the corresponding channel name. 
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Configuring the System Interface

The System Interface form (Configure > Base Station > System Interface) lets 
you configure the base station’s system interface. 

Simple repeater applications do not require any interface. 

The form displays the pin assignments and other information for the selected 
system interface. It lets you configure the RSSI output line and the external 
channel selection lines. 

Viewing System Interface Details
You can view the pin assignments for the system interface.

1. Log on to the base station and select Monitor > Module Details > Reciter 
to find out which system interface is fitted.

2. Select Configure > Base Station > System Interface.

3. In the Type list, select the system interface that has been fitted. 

The table underneath the Type box now shows you the pin assignments for 
that system interface. The pin assignments will update to reflect any changes 
you make to external channel selection. See “Configuring External Channel 
Selection” on page 75. 

Configuring External Channel Selection
Usually, the channel that the base station normally operates on is selected using 
the Service Kit (see “Default channel” on page 74). If you want the channel to 
be selected by equipment external to the base station, enable external channel 
selection and configure the base station’s system interface to reflect the way that 
equipment works.
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To configure external channel selection

1. Select Configure > Base Station > System Interface. 

2. Select the Channel selection check box. This enables external channel 
selection.

3. In the Pins to use box, select an option. For each bit in the binary channel 
number, you need a pin. 

The table to the left updates to indicate which pins are for channel selection 
and the Number of selectable channels box updates to indicate the high-
est channel number that the hardware will be able to select.

4. Specify whether the external equipment selects the channel number using 
binary or BCD format. 

Important: The base station interprets a line as ‘1’ when it is active 
(when the external equipment is pulling it to ground, the voltage is 
low, and current is flowing). 

5. If the external equipment pulls a line to ground to indicate a ‘0’, select the 
Invert box.

6. Use the Service Kit to test your setup. See “Testing Hardware Channel 
Selection” on page 157.

Note: Setting the channel to 000 (by switching all DIP switches 
off—or on, if the selection is inverted) disables external channel 
selection. The base station will operate on the channel selected by 
the Service Kit or by Task Manager action.

Configuring RSSI Output
If your system has equipment external to the base station that needs an RSSI 
voltage, you can configure that voltage to suit the equipment. 

If the equipment is configured to operate with older Tait base stations, you can 
specify that the RSSI output behaves like the output from a Tait T800 VHF or 
UHF base station. 

For other equipment, specify the maximum and a minimum output voltage that 
your equipment expects, and the maximum and minimum signal strengths that 
the base station needs to deal with. The base station will then map the signal 
strength range to the output voltage range. When it receives a valid signal, it 
outputs an RSSI voltage based on the strength of that signal. 

Tip: Alternatively, leave the RSSI output as it is and adjust the 
external equipment to work with that output. Use the RSSI output 
test when making the adjustment (Diagnose > Reciter > Misc I/O).
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To configure the RSSI output

1. Select Configure > Base Station > System Interface.

2. If your equipment is configured to work with Tait T800 equipment, in the 
Characteristics box, select Emulate T800 VHF or Emulate T800 UHF. 
This sets the parameters for the RSSI output. Otherwise, select User 
Defined and continue.

3. In the Voltage boxes, set the maximum and minimum voltages that the 
RSSI output will provide when the received signal varies from maximum 
to minimum.

4. In the Signal level boxes, specify the received signal strengths in dBm to 
correspond to the minimum and maximum voltages. (If you work in 
microvolts, see “Converting Between Microvolts and dBm” on page 78.)

When the signal strength reaches the lower value, the RSSI output line will 
have the minimum voltage. As the received signal strength increases, the 
voltage will increase linearly. When the received signal strength reaches the 
upper value, the RSSI output line will have the maximum voltage. Further 
increases in signal strength will not significantly increase the RSSI voltage. 
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Converting Between Microvolts and dBm
The following table lets you convert displayed levels in dBm into microvolts. 

Level in 
Microvolts

Level in dBm
Level in 
Microvolts

Level in dBm

0.10 -126.99 10.00 -86.99

0.20 -120.97 12.50 -85.05

0.25 -119.03 15.00 -83.47

0.30 -117.45 17.50 -82.13

0.40 -114.95 20.00 -80.97

0.50 -113.01 30.00 -77.45

0.60 -111.43 40.00 -74.95

0.80 -108.93 50.00 -73.01

1.00 -106.99 60.00 -71.43

1.50 -103.47 70.00 -70.09

2.00 -100.97 80.00 -68.93

2.50 -99.03 90.00 -67.90

3.00 -97.45 100.00 -66.99

4.00 -94.95 150.00 -63.47

5.00 -93.01 200.00 -60.97

7.50 -89.49 250.00 -59.03 



TB8100 Service Kit User’s Manual   Configuring Miscellaneous Items 79

Configuring Miscellaneous Items

The Miscellaneous form (Configure > Base Station > Miscellaneous) gathers 
together a number of settings.

Tx relay operation
The Service Kit lets you enable the control of an antenna relay and configure 
its operation. The base station’s reciter must be fitted with a system interface 
board that has a Tx Relay Driver line for connecting to the antenna relay (see 
Configure > Base Station > System Interface for pinout information). 

Antenna relays (also known as coaxial relays) are used in simplex applications. 
Before the transmitter keys up, the base station activates the relay, disconnecting 
the receiver and connecting the transmitter to the antenna. It waits for the ‘relay 
closing settling time’, and then powers the transmitter up. After it powers the 
transmitter down, it waits for the ‘delay before relay opens’, and then opens the 
relay. 

To enable and configure the operation of an antenna relay

1. Select Configure > Base Station > Miscellaneous

2. Select the Tx relay operation check box.

3. Adjust the values of the Relay closing settling time (A) and the Delay 
before relay opens (B) boxes to reflect the expected delays in switching 
the relay. 

4. Set up Task Manager tasks that disable the receiver when the transmitter is 
operating (see “Simplex Operation” on page 196).



80 Part E: Configuring the Base Station MB8100-00-00-806  © TEL 2003

Minimum battery voltage
The Power configuration area (Configure > Base Station > Miscellaneous) 
defines the lowest possible voltage for the DC power input to the PMU. Three 
pairs of voltages are displayed, corresponding to the PMU’s different DC-DC 
converter options (a nominal 12 V, 24 V, or 48 V input). The voltages that 
apply have a white background and can be edited. If there is no AC power and 
the battery voltage falls below the value in the relevant Power shutdown 
voltage box, the BSS shuts down. If the voltage rises above the value in the 
Power startup voltage box and the PMU is fitted with a standby module, the 
BSS re-starts.

Important: The values you define in this area affect any other base 
stations in the BSS.

Auxiliary power type
If the PMU is fitted with an auxiliary power supply unit, you need to configure 
it to suit the way it will be used. Generally, its output can be used to charge 
batteries or to power other site equipment. This equipment can include 
TaitNet trunked modules. These can be powered via the reciter’s system 
interface board (additional connection required). 

Caution: While the auxiliary power output can be used for more than one 
purpose at once, this is not generally recommended. It can result in a short-
circuit and equipment damage. The output is floating. If it is connected to a 

negatively earthed battery and to positively earthed auxiliary equipment, a short-circuit 
will result.

In the Power configuration area (Configure > Base Station > Miscellaneous), 
the Aux power type box specifies what kind of auxiliary output the PMU 
provides. Select one of the following options.

CTCSS characteristics
The CTCSS characteristics area (Configure > Base Station > Miscellaneous) 
lets you globally configure CTCSS subaudible signalling to emulate the T800 
or to follow the TIA/EIA603 standard.

Option Description

Enabled Output is provided when the PMU uses mains power and 
when it uses battery power. Suitable for powering auxiliary 
equipment. 

Disabled No auxiliary power output is provided.

Mains Output is provided only when the PMU uses mains power. 
Suitable for re-charging the batteries used for the PMU’s DC 
power input.

Option Detection time
Detect 
bandwidth

Reject 
bandwidth

T800 < 150 ms 2 Hz 3 Hz

EIA603 120 – 250 ms
(for  250  – 67 Hz)

1.8% 3%
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Select external clock reference frequency (if fitted)
The Select external clock reference frequency (if fitted) area (Configure > Base 
Station > Miscellaneous) lets you specify the frequency of an external reference 
frequency source. If an external source is connected to the reciter, select the 
appropriate option to tell the base station what the source’s frequency is. 

Quasi Synch mode If the base station is part of a simulcast system, select the Quasi Synch mode 
check box. This changes the characteristics of the transmit synthesiser and 
reduces the maximum carrier deviation. It has no effect when the base station 
uses its internal reference. 

Fan
The Fan area specifies how the base station monitors its fans. 

Note: Fans used in the TB8100 must have the correct wiring. Power 
and ground (2-wire fans) or power, ground and rotation detect (3-
wire fans). Both fans in a subrack should be of the same type.

To configure the monitoring of fans

1. Select Configure > Base Station > Miscellaneous.

2. In the Fan area, specify a number of fan operating hours. When the PA or 
PMU fan has actually been operating for this total length of time, the task 
manager input PA fan servicing advised or PMU fan servicing advised 
becomes true.

3. Create appropriate Task Manager tasks to define how you want to be 
notified when a fan needs servicing. For example, Task Manager could start 
over-the-air pips.

4. Specify whether the fan type is 2-wire or 3-wire. If you select 3-wire, the 
base station will use the third wire as a rotation detector. If it has turned the 
fan on but does not detect rotation, it activates the ‘Fan failed’ alarm.

Quasi 
Synch 
Mode

Carrier Frequency
Maximum Carrier Deviation 
(Relative to the Frequency 
Reference)

Off Any <30 Hz

On Multiple of 5 kHz or 6.25 kHz 0 Hz (locked)

On Not a multiple of 5 kHz or 6.25 kHz <1 Hz
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Defining Access Profiles

The Access Profile form (Configure > Security > Access Profiles) displays 
information about the access that Service Kit users have to the base station. This 
access level varies, depending on the access level.

The ‘Administrator’ access level gives unrestricted access. 

The ‘Read Only’ access level lets you view everything but change nothing. 

The ‘User’ access level has a configurable access profile. This means that 
your access to the base station varies, depending on the type of connection 
and the Service Kit function. 

Tait-authorized service centers always have unrestricted access when locally 
connected. 

Users with the ‘Administrator’ access level can configure the access profile. You 
may, for example, want to assign full access to Configuration and Diagnostics 
when locally connected but read-only access when remotely connected. 

Note: Any Service Kit user can make access profile changes if they 
are not connected to a base station and if they save the changes to a 
file. However, Administrator access is required to program the 
changes into a base station.

Note: It is not possible to download firmware when remotely 
connected. 

The form displays a matrix indicating the kind of access that the base station 
grants. There is a row for each major area of the Service Kit program. 

Local Connection The cells in this set of columns specify the access when using a Direct 
connection.

Remote 
Connection

The cells in this set of columns specify the access when using a Modem dialup 
or Over the air connection.

Read Only The cells in the Read Only column display the access for those with a Read 
Only access level. These users can always view a screen but not make any 
changes.
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 User The cells in the User column let you select the access for those with a User 
access level, if you are logged in as Administrator. If you are logged in as User 
or Read Only they simply display the current access. You have the following 
options:

Admin The cells in the Admin column display the access for those with an 
Administrator access level. This is always Full, except when the connection type 
does not support a function. (Firmware upgrades cannot be carried out when 
remotely connected.)

Option Description

Deny The Service Kit opens the form you request, but it is disabled 
and displays no data.

Read The Service Kit opens the form and displays the data, but you 
cannot edit it. You can display the information in diagnostic 
screens, but not initiate any diagnostic tests.

Full The Service Kit lets you do anything it is capable of.
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Printing a Base Station Configuration

The Service Kit lets you print configuration data that you have opened from a 
configuration file or read from a base station.

Note: Printing to an old-style text printer is not supported; the 
layout requires the use of large and small fonts.

To print a configuration

1. Select File > Print. The Print Selection dialog box appears. 

2. Using the arrow buttons, select the configuration items you want printed. 
An item is selected for printing when it is in the right-hand box.

The >> and << buttons move all configuration items.

The > and < buttons move the highlighted item. Click an item to 
highlight it.

3. Click Printer Settings and check the printer setup.

4. Click Print to send the configuration information to the printer.
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Part F Configuring Channels

The Service Kit lets you configure the TB8100 base station’s 
channels and their underlying profiles.

Click Configure, and then select an appropriate item from the 
navigation pane. 

Topics

Getting Started with Channels

Customizing the Default Channel Profile

Customizing the Default Signalling Profile

Using Advanced Profile Features

Working with Channel Profiles

Working with Signalling Profiles

Working With the Channel Table

Selecting a Channel

Printing Channel Data
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Getting Started with Channels

To set up channels, you first edit the default channel and signalling profiles. This 
defines the configuration items that are the same for all channels. Then in the  
channel table you create the channels you need, for example, by editing the one 
channel in the table and block copying it to give a set of channels all with the 
same channel spacing. You then edit the channels as needed, for example, to 
vary the subaudible signalling for different channels. Finally, you select one 
channel to be the default.

The following instructions describe the main steps you need to follow. If the 
base station has the Advanced Profiles and Task Manager license, more options 
are available. See “Using Advanced Profile Features” on page 91.

To set up channels

1. Open a suitable configuration file or read the configuration of the base 
station you are logged on to. For more information, see “Working With 
Base Station Configurations” on page 42.

2. Select Configure > Base Station > General. In the Default profiles area, 
click Channel Profile. 

3. Edit the settings in the Edit Channel Profile form to reflect the requirements 
of the channels in the system. For more information, see “Customizing the 
Default Channel Profile” on page 88. Click OK to confirm your changes 
and return you to the General form.

4. In the Default profiles area, click Signal Profile. 

5. Edit the settings in the Edit Signalling Profile form to reflect the 
requirements of the channels in the system. For more information, see 
“Customizing the Default Signalling Profile” on page 90. Click OK to 
confirm your changes and return you to the General form.

6. Select Configure > Base Station > Channel Table to open the Channel 
Table form. 

7. Pick a channel from the table (there may only be one), and give it the first 
transmit and receive frequencies in the band plan. Make any other 
configuration changes needed. For details, see “Editing a Channel (Default 
Profiles)” on page 120.

8. Click Block copy and specify the number of channels that you need. 

If the interval between channels is not regular, or if block copy is not appro-
priate for any other reason, use Insert Copy instead. Copy an existing 
channel as needed and edit the copies to get the results you want.

9. When the channels are set up to your satisfaction, return to the General 
form (Configure > Base Station > General) and select a channel as the 
default. All the channels you created will appear in the drop-down list.

10.Click OK to commit your changes and close the form. 

11.Save the changes to a configuration file.

12.Program the changes into the base station. 
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Customizing the Default Channel Profile

The Edit Channel Profile dialog box lets you customize the default channel 
profile to suit your system. Some items display ‘See channel table.’ You 
configure them in the  channel table so that you can give different channels 
different values.

To customize the default channel profile

1. Select Configure > Base Station > General.

2. In the Default profiles area, click Channel Profile. The Edit Channel Profile 
form appears.

3. In the General tab, define the following:

a. The subaudible deviation if the base station will transmit with CTCSS 
or DCS.

b. The talk-through repeater gain if the base station will be used as a 
repeater.

c. The criteria for receiver gating (see “Configuring Receiver Gating” on 
page 94). 

4. In the Signal Path tab, do the following:

a. Use the check boxes to enable the audio paths you require. Enabled 
paths are displayed as dark lines. 

b. Select levels for any line inputs and outputs.

Note: The base station can only provide line in and line out audio if 
the system interface card fitted in the reciter has these audio 
interfaces.
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5. In the Power Saving tab, configure Normal power saving mode. If the base 
station has a Power Saving Modes license, you can also configure Sleep and 
Deep Sleep modes. (See “Configuring Power Saving” on page 94).

6. If your system needs to broadcast its ID using Morse code, select the CWID 
System tab and configure the profile appropriately.

7. In the Task Manager tab, use Task Manager to define any inputs and actions 
to customize the way channels with the default profile will respond in 
different situations. 

8. Click OK to confirm your changes and close the dialog box.
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Customizing the Default Signalling Profile

The Edit Signalling Profile dialog box lets you modify the default signalling 
profile to suit your system. Some items display ‘See channel table.’ You 
configure them in the  channel table so that you can give different channels 
different values.

To customize the default signalling profile

1. Select Configure > Base Station > General.

2. In the Default profiles area, click Signal Profile. The Edit Channel Profile 
form appears.

Nothing in the Subaudible Signalling tab can be configured. Subaudible sig-
nalling is defined for each channel in the channel table. The tone table is 
only available for custom profiles. 

3. In the Tx Timers tab, configure the way the audio, signalling, and carrier 
end at the end of a transmission. You can also enable transmit lockout and 
anti-kerchunking.

4. In the Advanced tab, check that the settings for CTCSS gating are suitable. 

5. Click OK to confirm your changes and return to the General form.
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Using Advanced Profile Features

There are two different ways to configure channels. The basic way uses default 
profiles and the advanced way uses custom profiles.  The advanced way requires 
an Advanced Profiles and Task Manager license.  

The basic way defines most settings in the profiles. The rest are defined in the 
channel table. You select values for each channel. 

The advanced way defines nearly all the settings in custom profiles. The channel 
table only defines the transmit and receive frequencies for each channel. The 
channel table still displays the same items, but their settings are determined by 
the profiles assigned to the channels.  The advanced way is more flexible and 
powerful. In the following situations, you must use custom profiles:

The base station needs to respond to more than one subtone. In other 
words, one channel must be able to decode/encode several different 
subtones.

Different parts of the audio path need to use different filters.

Channel or signalling profile settings need to be different for different 
channels. In other words, the settings that you specify for the default profiles 
cannot be used for all channels.

The receive and the transmit frequencies need to have a different channel 
spacing.

You want to use Task Manager to change a profile setting. This is done by 
getting Task Manager to switch the base station to a channel with a different 
custom profile.

Many users combine both ways to configure channels. They use default profiles 
for most channels but create a set of their own profiles for channels with 
advanced configuration requirements.
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Working with Channel Profiles

The Channel Profiles form (Configure > Base Station > Channel Profiles) lets 
you work with channel profiles. You can view the profile list, add a new profile, 
or edit an existing one.

The form displays a row of information for each profile. ‘See channel table’ 
means that the channel table, not the default profile, defines the setting.

The Channel profile name column indicates the name of the profile. 
‘Default’ is a built-in profile; it can be edited but not deleted. 

The Filter column indicates the audio filter that the profile specifies. ‘Multiple’ 
means that different audio paths use different filters. The Default profile does 
not specify an audio filter; this is done in the channel table.

The Transmitter power column indicates the defined transmitter power 
output. If a custom profile defines different values for mains and battery power, 
the value for mains power is displayed.

The Channel spacing column indicates the nominal or minimum channel 
spacing of channels that are assigned the profile. If a custom profile defines 
different values for the transmit and receive frequencies, the value for the 
receive frequency is displayed.

For more detail about these columns, and about other profile details, see 
“Editing a Channel Profile” on page 95.

Buttons along the bottom of the form let you add a new profile or copy, edit, 
or delete the selected profile.

Adding a Channel Profile
The Add Channel Profile dialog box lets you define the settings for a new 
channel profile and add it to the list of available profiles. You can only do this 
if the base station has the Advanced Channel and Signalling Profiles feature set.

The following instructions do not deal with all configuration items. For more 
detailed information about these dialog boxes, see “Editing a Channel Profile” 
on page 95 (the Add Channel Profile and Edit Channel Profile dialog boxes are 
almost the same).

Important: If the base station doesn’t have an Advanced Profiles 
license, don’t add profiles. The channel table cannot use them.
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Tip: Set up a test profile and assign it to a channel. Use this channel 
when testing your system before commissioning.

To add a channel profile

1. Select Configure > Base Station > Channel Profiles. The Channel Profile 
form appears.

2. Click Add. The Add Channel Profile window appears.

3. In the General tab, define the following:

a. A suitable name for the profile. 

b. The channel spacing for the receiver and the transmitter (they do not 
need to have the same setting).  

c. The subaudible deviation if the base station will transmit with CTCSS 
or DCS.

d. The talk through repeater gain if the base station will be used as a 
repeater.

e. The transmitter’s RF power output, for mains and for battery operation. 
You may, for example, want to specify the full output for mains opera-
tion, but a lower value when the transmitter is operating from battery 
power.

f. The criteria for receiver gating (see “Configuring Receiver Gating” on 
page 94). 

4. In the Signal Path tab, do the following:

a. Use the check boxes to enable the audio paths you require. Enabled 
paths are displayed as dark lines. 

b. Using the Filter drop-down lists, select for each audio path the filter you 
want. Thumbnail sketches display graphs of the selected filter’s audio 
characteristics.

c. Select levels for any line inputs and outputs.

Note: The base station can only provide line in and line out circuits 
if the system interface card fitted in the reciter has pins for them.

5. In the Power Saving tab, configure power saving in the Power Saving tab. 
If the base station has a Power Saving Modes license, you can configure all 
three modes (see “Configuring Power Saving” on page 94).

6. If your system needs to broadcast its ID using Morse code, select the CWID 
System tab and configure the profile appropriately.

7. In the Task Manager tab, use Task Manager to define any inputs and actions 
to customize the way channels with this profile will respond in different 
situations.

8. Click OK to confirm your changes and close the dialog box. The profile 
you defined appears in the Channel Profiles form.
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Configuring Receiver Gating
The Rx Gating area of the General tab lets you configure the way the receiver 
gates the audio signal. 

Figure 2: Receiver Gating

To configure receiver gating

1. Open the Add or Edit Channel Profile dialog box for the profile whose 
receiver gating you want to configure.

2. Select whether the receiver gate will open based on RSSI, SINAD, or both.

3. In the RSSI and/or SINAD areas, enter a gating level. When the level you 
set is reached, the receiver gate opens. (If you enabled both gating types, 
both RSSI and SINAD levels must reach their level.)

4. Set the hysteresis. This defines the amount that the RSSI or SINAD must 
fall below the gating level before the receiver gate closes. For example, if the 
RSSI gating level is -110 dBm and the hysteresis is 6 dB, the RSSI must fall 
to -116 dBm before the gate closes.

5. Specify whether the receiver will output line audio only when the receiver 
gate is open, or under all circumstances. 

Tip: You can configure the base station to output line audio 
differently in different circumstances. Define two profiles with the 
different options. Create two channels that are the same except for 

the assigned channel profiles. Then define Task Manager tasks that switch the 
base station between the two channels, for example, when it receives a 
particular subtone.

Configuring Power Saving
For each channel profile, you can configure three power saving modes: 
Normal, Sleep, and Deep Sleep. The configuration will be applied to channels 
with the profile you are working on.

Note: Sleep and Deep Sleep modes are only available if the base 
station has a Power Saving Modes license.

Time
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Gate 
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Gating level
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To configure power saving

1. Open the Add or Edit Channel Profile dialog box for the profile whose 
power saving you want to configure.

2. Select the Power Saving tab.

3. For each power saving mode, follow these steps:

a. Select the check box to enable the mode (Sleep and Deep Sleep only).

b. In the Rx cycling box, select a time from the drop-down list. This spec-
ifies how long the receiver is turned off before being turned on again. If 
you select ‘off’, there is no receiver power saving in this mode. 

c. In the Tx keyup time box, select a time from the drop-down list. This 
specifies the amount of time that the transmitter will need to key up. The 
longer the time, the more circuitry can be switched off. (In Sleep and 
Deep Sleep modes, the Tx keyup time is fixed.)

d. In the Start after box, specify a length of time. When the base station 
has been idle for this length of time, it switches from Normal to Sleep 
mode, or from Sleep to Deep Sleep mode. ‘Idle’ means not operating as 
a talk through repeater or line-connected base station. A base station still 
counts as idle, even if it makes scheduled CWID transmissions or trans-
missions using the front panel microphone.

Tip: Use the Task Manager action Disable Power Saving to disable 
power saving when it is not needed. 
For example:

IF Battery voltage low THEN Enable power saving
IF NOT  Battery voltage low THEN Disable power saving

Editing a Channel Profile
The Edit Channel Profile dialog box lets you view the details of the selected 
channel profile and modify them. 

Next Profile and Previous Profile let you move from one profile to another 
without leaving the dialog box. 

Important: If you have made changes to the current profile, click 
OK to confirm them before moving to another profile. 

Some items in the Default channel profile display ‘See channel 
table.’ You specify them individually for each channel in the channel table 
(Configure > Base Station > Channel Table).
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 General
The General tab in the Add or Edit Channel Profile dialog box names the 
channel profile and defines its general characteristics.

Profile name Specifies the name of the profile. You can edit the name of custom profiles.

RF Configuration
In the Add or Edit Channel Profile dialog, General tab, the RF configuration 
area lets you specify the nominal channel spacing for the receiver and the 
transmitter. No hardware modification is necessary when the RF configuration 
is changed.

Note: Your country may use Narrow band, Mid band and Wide 
band to refer to different channel spacings. Make sure that the 
option you select has the correct value. 

Receiver channel Specifies the receiver’s nominal channel spacing. The available options are 
expressed both as a description (for example, Mid Band) and as the kHz value 
of the nominal channel spacing.

Note: The Receiver channel box does not determine the actual 
spacing between channels. It determines the receiver IF bandwidth. 
For example, 20 kHz Mid Band sets the receiver IF bandwidth to 

12 kHz. Normally, you would select this option if the channels in your band 
plan have a 20 kHz channel spacing. However, your band plan may be 
irregular, or you may want to specify (in the channel table) a greater spacing 
between channels, for example, 50 kHz. 

Option Equivalent Rx IF Bandwidth

12.5 kHz Narrow Band 7.5 kHz

20 kHz Mid Band 12 kHz

25 kHz Wide Band 15 kHz
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Max Tx deviation Specifies the highest deviation that the transmit channel is permitted to have. 
The available options correspond to the following channel spacings:

Subaudible 
deviation

Specifies the deviation that CTCSS or DCS signalling will cause to the carrier 
frequency. Options are specified both absolutely in Herz and relatively as a 
percentage of the selected Max Tx deviation. Gain will be applied to the 
CTCSS signalling to cause the deviation specified. If you subsequently alter the 
Max Tx deviation, the Herz value of the subaudible deviation will alter, but not 
its percentage.

Talk through 
repeater gain

Specifies the gain in dB that will be applied to received audio that is fed into 
the transmitter. See “Repeater Options” on page 102. 

AGC Specifies whether automatic gain control is applied to received audio. AGC 
provides enhanced high signal handling capabilities and receiver 
intermodulation protection. When signal levels are high, however, the 
minimum sensitivity may be degraded.

AGC is normally enabled, but Tait recommends disabling it when: 

The anticipated receive signal strength is < -107 dBm (1 microvolt) and 
strong interfering signals (> -30 dBm (7000 microvolts)) are anticipated at 
the receiver input.

TIA/EIA or AS-4295 RF performance testing is being carried out.

Transmitter Power Output
In the Add or Edit Channel Profile dialog, General tab, the Transmitter 
power output area specifies the output power of the transmitter. 

The output power is specified separately for mains-powered and for battery-
powered transmissions. The boxes alongside display the equivalent power in 
dBm. 

If you specify 100 W and the PA is rated at 50 W, it will run at 50 W. There 
is therefore no need to alter this value if you temporarily substitute an amplifier 
with lower power, for example, if there is a fault and you don’t have a fully 
powered module on hand.

Option Channel Spacing

2500 Hz Narrow Band 12.5 kHz

4000 Hz Mid Band 20 kHz

5000 Hz Wide Band 25 kHz
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Receiver Gating
In the Add or Edit Channel Profile dialog, General tab, the Receiver Gating 
area configures receiver gating (also known as receiver squelch). 

You can have gating based on RSSI or  SINAD. If you select both options, 
gating is enabled once both values reach the required level. 

RSSI gating operates more quickly and is suitable for repeater links. SINAD 
gating takes longer but is more accurate and is suitable for the repeater itself or 
for a line-connected base station. 

RSSI Gating 
(Carrier)

Enables gating based on the base station’s measurement of the received signal 
strength. This is also known as Carrier gating.

SINAD Gating 
(Noise)

Enables gating based on the ratio of signal to noise and distortion. This is also 
known as noise gating. 

Level The two Level boxes define the level (of RSSI or SINAD) required to enable 
receiver gating and pass the received audio. 
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Hysteresis The two Hysteresis boxes specify how far the RSSI or SINAD must fall below 
the level set in the corresponding Level box to disable receiver gating and mute 
the received audio. 

Only output line 
audio when Rx 
Gate is valid

This option is generally selected. This applies receiver gating to line output; 
audio is only output when the required conditions (RSSI, SINAD, subaudible 
signalling) are met.

Always output 
line audio

This option lets you temporarily override receiver gating on line output. It 
makes continuous listening to the channel possible, for example, when 
troubleshooting. 

Signal Path
In the Add or Edit Channel Profile dialog, the Signal Path tab lets you configure 
the path that incoming and outgoing signals take. In effect, you can design your 
own virtual backplane for the base station. 

The left-hand side of the tab defines RF filter characteristics. Each panel has a 
drop-down list you can choose from, and a thumbnail graphic showing you the 
response characteristics of the filter you chose.

The middle of the tab displays possible audio paths as light gray lines. Check 
boxes and a drop-down list let you select path options. When you select an 
item, the path it enables appears as a thick green (transmit path) or red (receive 
path) line. 

Both the receiver and the transmitter have two paths. Path A connects to a 
balanced line and Path B to an unbalanced line. You can select different filters 
for each path.
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Note: You can use Task Manager to disconnect or re-connect parts 
of the signal path in particular circumstances. See “Channel Profile 
Actions” on page 187. Also, Task Manager actions can connect the 

balanced line input to the balanced line output, or the unbalanced line input to 
the unbalanced line output. See “Loopback actions” on page 184.   

Important: The transmitter can be keyed from several differerent 
sources. If the instruction to key up is received from more than one 
keying source, the source with the highest priority level takes 

precedence. Only the audio that belongs to the keying source will be used to 
modulate the transmission. The keying sources and their priority levels are:

Tip: To transmit audio that is summed from line input and from the 
receiver, connect one line output to the corresponding line input 
and connect external audio to the other line input. In other words, 

loop the received audio back externally because the internal  signal path from 
receiver to transmitter will not be used when the Tx Key line is active. 

Receive Path
In the Add or Edit Channel Profile dialog box, the top half of the Signal Path 
tab lets you configure receive paths. A receive path connects the receiver to the 
speaker output and to a line output.

Note: The path to the speaker is always enabled.  However, the 
speaker buttons on the control panel let you turn the speaker off and 
mute or unmute its audio.

Priority 
Level

Keying Source Audio Used

1 Carrier button on control panel None

2 PTT on microphone connected to 
base station

Microphone

3 External Tx Key line Balanced and/or unbalanced 
line input

4 Valid Receive signal (no separate Tx 
Key line required)

Output from receiver
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Filter The Filter drop-down lists let you select an audio filter for each enabled receive 
path.

Rx path A Enables the audio path from the receiver to balanced audio output, using the 
filter selected for Path A. 

Rx path B Enables the audio path from the receiver to unbalanced audio output, using the 
filter selected for Path B.

Line level The Line level boxes on the receive path set the audio level at the line output 
pins. When the reciter receives a signal that is modulated to 60% of a maximum 
transmit deviation that is equivalent to the receiver setting, it outputs audio on 
the line at the level you set. For channels using the default profile, the receiver 
setting is determined by the channel spacing (see “Channel Spacing” on 
page 119). For channels using custom profiles, it is defined by the Receiver 
channel box  (see “Receiver channel” on page 96).  

The line level units are dBm for the balanced line output and Vpp (voltage 
peak-to-peak) for the unbalanced line output.

Option Description

Flat full band Passes audio evenly across the audio spectrum. 

Flat speech 
band

Passes only speech frequencies.

De-emph 
speech band

Passes audio in the speech range, attenuating higher 
frequencies. This option can be used if the base station will  
receive pre-emphasised transmissions. 

De-emph full 
band

Passes all audio, attenuating higher frequencies.This option 
can be used if the base station will receive pre-emphasised 
transmissions.

Subaudible 
band

Passes only the subaudible band, containing any CTCSS tones 
or DCS codes. This option can be used to separate out the 
signalling and put it on the line output that is connected to a 
tone panel.

Receiver setting 
Equivalent Max Tx 
deviation (Hz)

60% of Max Tx  
deviation (Hz)

12.5 kHz Narrow Band 2500 1500

20 kHz Mid Band 4000 2400

25 kHz Wide Band 5000 3000
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Repeater Options
In the Add or Edit Channel Profile dialog box, Signal Path tab, the Talk 
through repeater box specifies the audio path from receiver to transmitter. 

Note: You can vary the gain that the base station applies to talk 
through audio. See “RF Configuration” on page 96.

Microphone Panel
In the Add or Edit Channel Profile dialog box, Signal Path tab, the two Mic 
drop-down lists specify the line output and transmit audio paths for any 
microphone connected to the control panel.

The upper drop-down list specifies the microphone’s line out audio path. 

Mic The lower drop-down list specifies the microphone’s transmit audio path.

Tip: Select Tx A or Tx B so that a technician can use a microphone 
to transmit using the base station.

Option Description

Disabled There is no audio path. The base station does not function as a 
repeater.

A-A The base station filters received audio using the receive Path A 
filter and transmits it using the transmit Path A filter.

A-B The base station filters received audio using the receive Path A 
filter and transmits it using the transmit Path B filter.

B-A The base station filters received audio using the receive Path B 
filter and transmits it using the transmit Path A filter.

B-B The base station filters received audio using the receive Path B 
filter and transmits it using the transmit Path B filter.

Option Description

None The microphone has no line audio path

Balanced Connects the microphone to the balanced line output

Unbalanced Connects the microphone to the unbalanced line output

Option Description

None The microphone has no audio path to the transmitter

Tx A Connects the microphone to the transmitter using the Path A 
filter

Tx B Connects the microphone to the transmitter using the Path B 
filter
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Transmit Path
In the Add or Edit Channel Profile dialog box, Signal Path tab, the lower area 
lets you configure transmit paths. A transmit path connects received audio or a 
line input to the transmitter.

Filter The Filter drop-down lists let you select an audio filter for each enabled 
transmit path. The options are the same as for the receive paths, except that Pre-
emphasis filters replace the de-emphasis ones. 

Line level The Line level boxes on the transmit path define the level of the line input that 
the base station expects. The line level you select affects the gain across the 
transmit path. 

When the base station receives a line input at the level you select, it transmits 
at 60% of the maximum transmit deviation. For channels using the default 
profile, the maximum transmit deviation is determined by the channel spacing 
(see “Channel Spacing” on page 119). For channels using custom profiles, it is 
defined by the parameter Max Tx deviation (see “Max Tx deviation” on 
page 97).

Option Description

Flat full band Passes audio evenly across the audio spectrum. 

Flat speech 
band

Passes only speech frequencies.

Pre-emph 
speech band

Passes speech, amplifying higher frequencies. This option can be 
used for transmitting to systems with de-emphasis.

Pre-emph full 
band

Passes all audio, amplifying higher frequencies. This option can 
be used for transmitting to systems with de-emphasis.

Subaudible 
band

Passes only the subaudible band, containing any CTCSS tones or 
DCS codes. This option can be used to separate out the signalling 
and put it on the line output that is connected to a tone panel.

Channel spacing 
Equivalent Tx max 
deviation (Hz)

60% of Tx max 
deviation (Hz)

12.5 kHz Narrow Band 2500 1500

20 kHz Mid Band 4000 2400

25 kHz Wide Band 5000 3000
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Line levels are expressed as dBm for the balanced line input and Vpp (volts 
peak-to-peak) for the unbalanced line input. 

Power Saving
In the Add or Edit Channel Profile dialog box, the Power Saving 
tab lets you specify how power saving will be applied when the base 

station is running on battery power. A graph shows the meaning of Rx cycling 
and Tx keyup time. The three areas below the graph define the parameters 
for Normal, Sleep, and Deep Sleep modes. Sleep and Deep Sleep modes require 
a Power Saving Modes license.

Normal Defines how the base station operates normally. Normal mode can involve a 
degree of power saving.

Sleep The Sleep check box enables Sleep mode. The related group box defines how 
the base station operates in Sleep mode. A base station enters Sleep mode when 
the receiver has been idle for the length of time specified in the Sleep mode’s 
Start after box. 

Deep Sleep The Deep Sleep check box enables Deep Sleep mode. The related group box 
defines how the base station operates in Deep Sleep mode. A base station in 
Sleep mode enters Deep Sleep mode when the receiver has been idle for the 
length of time specified in the Deep Sleep mode’s Start after box. 

Rx cycling Rx cycling is the length of time in milliseconds that the receiver is switched off 
for. Usually, the receiver runs continuously, but this may not be necessary.

Power saving is effected by switching off the receiver, switching it back on to 
check if there is a valid signal, switching it off again, and so on. Rx cycling is 
therefore the maximum gap between periods of reception. It is slightly shorter 
than the maximum detection time, by an amount that depends on system 
conditions. 
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The longer the Rx cycling time, the more base station circuitry can be switched 
off and the greater the power saving. Even shorter Rx cycling times improve 
the power consumption significantly and are not noticeable to users.

Tx keyup time The length of time that the transmitter needs for keying up. The longer the 
time, the more base station circuitry can be switched off.

Start after The length of time that the base station waits before switching from Normal 
mode to Sleep mode or from Sleep mode to Deep Sleep mode. If the base 
station has to operate as a repeater or line-connected base station, it restarts the 
timer. Scheduled CWID transmissions and transmissions using the control panel 
microphone do not restart the timer.

 CWID System
In the Add or Edit Channel Profile dialog box, the CWID System tab lets you 
configure the way the base station broadcasts its identity using Morse code. In 
the USA, the FCC requires that base stations broadcast their identity. 

Tip: Transmit using CWID before your radio system is 
commissioned; if there are any other users of the frequencies you 
have been assigned, this gives them advance warning. 

Tip: Use CWID as an alarm notification method additional to the 
over the air alarm. Task Manager can disable CWID on startup, and 
then enable it when particular alarm conditions occur. See “CWID 

Actions” on page 188.

Option Description

1 ms Required for some data systems. The PMU can deliver full 
power within this time. The PA is running, ready to key up. 
The exciter synthesizer is running and locked and the exciter 
output is live.

5 ms The exciter output is disabled. The PA is in a (relatively) idle 
mode. The PMU is running in Hysteresis mode. 

20 ms The exciter synthesizer is powered down. 

Medium In Sleep mode, the Tx keyup time is fixed 

Slow In Deep Sleep mode, the Tx keyup time is also fixed and is 
significantly slower. 
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The Automatic CWID system area lets you enable and configure the regular 
sending of identity broadcasts. The Morse area defines what the base station 
broadcasts. 

Automatic CWID 
system

Enables the automatic sending of a base station identifier. Currently the only 
option is to use Morse code. 

Transmission Interval
In the Add or Edit Channel Profile dialog box, CWID System tab, the 
Transmission interval area lets you specify when the station ID is transmitted.

Transmit every Specifies the interval in minutes between one identity broadcast and the next.

Wait until Tx tail 
before CWID 
transmission

Determines what happens if the base station is transmitting when a CWID burst 
is due. 

If the check box is selected, the base station delays the CWID burst until the 
transmit tail. Any tail timers start to count down immediately after the CWID 
burst. 

If the check box is cleared, the station ID is transmitted as soon as the 
transmission interval after the previous transmission has elapsed. This may 
interrupt speech or signalling. Any other modulating signal is temporarily 
suppressed to prevent interference with the Morse code. 

Tip: Use the Task Manager action Transmit CWID now to set up 
identity broadcasts in ways that the Transmission interval area does 
not permit.

Morse
In the Add or Edit Channel Profile dialog box, CWID System tab, the Morse 
area lets you specify a unique ID for the base station. The speed of transmission 
and the tone used can also be configured, but you should not need to alter the 
default settings. 

Words per minute Specifies the speed of Morse code transmission. The 5-letter word PARIS is 
used to establish the number of words per minute. This word corresponds to 
50 dots. 

Tone frequency The frequency of the tone used to transmit the Morse code.

Message Enter into this box up to 30 characters to be transmitted as the station ID. You 
can enter any character or digit that the international morse code alphabet 
supports (A-Z, 0-9, and punctuation marks). These characters will be 
transmitted using the International Morse Code convention. You can also enter 
spaces. They result in a silence equivalent in duration to seven dots. 

Task Manager
In the Add or Edit Channel Profile dialog box, the Task Manager tab opens a 
Task Manager form and displays the tasks that apply to the selected channel 
profile. Use it to edit or add Task Manager inputs and actions that apply to the 
channel profile.
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Working with Signalling Profiles

The Signalling Profiles form displays a list of the current signalling profiles.

Buttons along the bottom of the form let you add a new profile or copy, edit, 
or delete the selected profile.

Adding a Signalling Profile
The Add Signalling Profile dialog box lets you define the settings for a signalling 
profile and add it to the list of available profiles. It is almost the same as the Edit 
Signalling Profile dialog box. For detailed information, see “Editing a Signalling 
Profile” on page 109. 

Important: If the base station doesn’t have an Advanced Profiles 
license, it makes no sense to create profiles. The Service Kit lets you 
create them, but you will not be able to apply them to the channels 
in the channel table. 

Tip: Set up a test profile and assign it to a channel. Use this channel 
when testing your system before commissioning.
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To add a signalling profile

1. Select Configure > Base Station > Signalling Profiles. The Signalling 
Profiles form appears.

2. Click Add. The Add Signalling Profile window appears.

3. In the Profile name box, enter a suitable name for the profile.

4. In the Subaudible Signalling tab, set up the default encoding of 
transmitted signals.

a. In the Line-controlled base/mic box, specify the subaudible 
signalling type and the tone frequency that the base station will use when 
it transmits audio from its line in. 

b. In the Talk through repeater box, optionally specify the subtone that 
the base station will encode by default when it transmits received audio. 
If you tell the base station to decode any subtone and gate the receiver, 
this setting is disabled. 

5. In the table, specify up to 16 subtones that you want the base station to 
recognize.

a. In the Decode Signal column, select a tone or code. CTCSS tones 
appear prefaced by a ‘C’ and DCS codes are prefaced by a ‘D.’ The rest 
of the row now displays default settings.

Note: When using CTCSS tones, select frequencies that are spread 
out across the available range. Do not select tones that are close to 
one another in frequency, as the tone reject bandwidth may not 

permit separating them. For example, if 67 Hz is received, both the 67 Hz and 
the 69.4 Hz decoders may operate. The exact select and reject bandwidths vary, 
see “CTCSS characteristics” on page 80. 
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b. If you want the subtone to initiate a Task Manager action, but not to 
produce any audio, change the Action column to display ‘Task Manager 
only’.

c. In the Encode Signal column, you can tell the base station to transmit 
a different subtone from the one it received.

6. In the Tx Timers tab, configure the way the audio, signalling, and carrier 
end at the end of a transmission.

7. In the Advanced tab, configure advanced parameters for CTCSS signalling. 

8. In the Task Manager tab, define any inputs and actions to customize the way 
channels with this profile will respond in different situations.

9. Click OK to confirm your changes and close the dialog box. The profile 
you defined appears in the Signalling Profiles form.

Setting Up a Reminder Tone
If a group of radios using a community repeater are in arrears with their 
payments, you can configure the base station to send out a reminder tone. If 
necessary, you can disable audio so that they can transmit but not hear each 
other. 

1. Select Configure > Base Station > Signalling Profiles.

2. Open the editing form of the signalling profile assigned to the base station’s 
current channel.

3. In the row that specifies the decode signal that the group of radios use, click 
the Reminder Tone cell, and select Enabled from the list that appears.

When you program the base station with these changes, it adds a reminder 
tone to the transmissions from the group that it re-transmits. 

Note: To configure the reminder tone, select the Advanced tab of 
the Edit Signalling Profile dialog box.

Editing a Signalling Profile
The Edit Signalling Profile dialog box lets you view the details of the selected 
signalling profile and modify them. Subaudible signalling is defined for the 
Default signalling profile in the channel table.
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Profile name Specifies the name of the profile. This name is used in the Channel Table and 
Signalling Profile forms.

Previous Profile Displays the next profile. This means you don’t need to return to the list of 
profiles. 

Next Profile Displays the next profile in the list.  

Important: If you have made changes to the current profile, click 
OK to confirm them before moving to another profile. 

Tabs

Subaudible Signalling
In the Add or Edit Signalling Profile dialog box, the Subaudible Signalling tab 
specifies the subtones that the receiver recognizes and that the transmitter 
applies. The base station supports CTCSS frequencies and DCS codes.

Most of the tab is taken up by a table. Each row in the table specifies a subtone 
that the base station will recognize and the action that it will take. Default 
subtones for the transmitter are specified in the Default encode signalling area. 
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Subtone table
In the Add or Edit Signalling Profile dialog box, a table defines up to 16 
subtones that the receiver will accept and specifies the base station’s response. 
The left-hand side specifies the receive response and the right-hand side the 
transmit response. 

The table lets you configure the base station as a community repeater, with each 
subtone having its own group of users. It also lets you set up the means of 
remotely initiating Task Manager actions. A radio can send carrier with a 
particular subtone and the decoding of this subtone initiates a Task Manager 
action. The left side specifies a subtone. The base station will recognize 
transmissions containing that subtone. The row defines the base station’s 
response. 

Decode Signal Specifies a subtone and instructs the base station to decode it. To begin adding 
a subtone to the list that the base station will recognize, click in the cell. A pop-
up menu appears. Click an option. When you select a subtone, it becomes 
unavailable. If the subtone is a DCS code, its inverse also becomes unavailable. 
This is to prevent you selecting the same subtone twice. 

Note: When using CTCSS tones, select frequencies that are spread 
out across the available range. Do not select tones that are close to 
one another in frequency, as the tone reject bandwidth may not 

permit separating them. For example, if 67 Hz is received, both the 67 Hz and 
the 69.4 Hz decoders may operate. The exact select and reject bandwidths vary, 
see “CTCSS characteristics” on page 80. 

Action Specifies the action when the base station detects the specified subtone. 

Option Action

Gate receiver Opens the receiver gate and passes the received audio on. Also sets the system flag 
‘Tone nn detected’ where ‘nn’ is the number of the subtone. This flag is a Task 
Manager input; any tasks with this input will be executed when the base station 
detects the subtone. 

Task Manager only Sets the system flag ‘Tone nn detected’ where ‘nn’ is the number of the subtone. This 
flag is a Task Manager input; any tasks with this input will be executed when the base 
station detects the subtone. 
In systems that use subaudible signalling, the receiver does not pass the received 
audio on (the receiver gate only opens when the receiver decodes a tone configured 
to gate the receiver).
In systems that do not use subaudible signalling, the receiver still passes the received 
audio on (the receiver gate opens irrespective of the subaudible signalling) .



112 Part F: Configuring Channels MB8100-00-00-806  © TEL 2003

Encode Signal Specifies the subtone that the base station encodes when it repeats signals with 
the subtone specified in the Decode signal column.

Reminder Tone When the Reminder Tone column is set to ‘Enabled’, the base station includes 
a reminder tone in its transmissions. You configure the reminder tone in the 
Advanced tab. 

Audio Path By default, the Audio Path column is set to ‘Enabled.’ When it is set to 
‘Disabled,’ the audio path is disabled, and the base station transmits carrier (and 
a reminder tone if it is configured to do so), but no audio. 

Default encode signalling
In the Add or Edit Signalling Profile dialog box, Subaudible Signalling tab, the 
Default encode signalling area lets you specify the subtone to be used when 
transmitting audio from line in and when repeating received signals without 
subaudible signalling.

Line controlled 
base/mic

Specifies the subtone to be used when the base station transmits audio from the 
balanced line input, unbalanced line input, or microphone connected to the 
control panel.

Talk through 
repeater

Specifies the subtone to be used when the base station repeats any valid received 
signal. This box is disabled and has no effect if the subtone table below specifies 
any subtone and gives it the action ‘Gate receiver’. 

Option Action

Same as received Encodes the transmission with the same subtone that was 
in the received signal.

None Gives the transmission no subaudible signalling.

[any CTCSS tone or 
DCS code]

Encodes the transmission with the subtone you specify
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Tx Timers
In the Add or Edit Signalling Profile dialog box, the Tx Timers tab lets you 
configure tail timers that the transmitter users.

You can also set up a transmit lockout and enable anti-kerchunking. 

Three different tail timers give you power and flexibility in tail timing. The 
total tail time is the sum of all three timers. The graphic at the top of the tab 
shows the difference between them. Tail timers are used to:

eliminate squelch tail (the ‘tish’ sound caused when the CTCSS detector 
doesn’t immediately re-mute the user’s radio when carrier ceases) 

prevent users on different subtones from taking control of the repeater 
during a temporary lull in the conversation

Transmit lockout
To prevent radio users from monopolising the base station, you can set a time 
limit and have the transmitter lock users out for a defined period after this time 
limit is exceeded. Transmit lockout terminates the current call and gives other 
users the opportunity to use the channel.

In the Add or Edit Signalling Profile dialog box, Tx Timers tab, the Transmit 
lockout check box enables the temporary disabling of the transmitter after a 
call that exceeded the time limit.

The Transmit timer box specifies the time limit for calls. If a call exceeds the 
time limit, the transmitter is locked out and the call cannot continue. The 
transmitter is unable to transmit for the length of time specified in the Lockout 
duration box. 

Anti-kerchunking
Anti-kerchunking discourages radio users from repeatedly pressing PTT briefly 
to ascertain whether they have service or to reserve the base station for 
themselves. 
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In the Add or Edit Signalling Profile dialog box, Tx Timers tab, the Anti-
Kerchunking check box enables this feature. If a transmission is short, either 
the transmitter is not keyed up or there will be no tail timers, depending on the 
option selected.

The Transmissions less than box specifies which transmissions are short; 
those with a duration less than the value in the box. Anti-kerchunking is only  
applied to short transmissions.

If the Will not key transmitter option is selected, short transmissions do not 
key up the transmitter at all. In effect, this option lengthens the key-up time for 
all radio users.

If the Will not enable tail timers option is selected, short transmissions are 
transmitted but not given a tail timer. The base station becomes available to 
other users quickly. The radio user hears nothing on releasing PTT and 
therefore does not know whether the base station has responded. 

Hang time
The hang time is the length of time at the end of each transmission when the 
base station continues to transmit subaudible signalling after Tx keying has 
ceased.

In the Add or Edit Signalling Profile dialog box, Tx Timers tab, the Hang time 
check box enables this timer and the Duration box specifies the length of the 
hang time. 

Reverse tone burst
The base station can send a reverse tone burst at the end of each transmission. 
This applies only to transmissions with a CTCSS tone. The reverse tone burst 
consists of the same tone, but is out of phase with it. In suitable radios, this 
quickly mutes the receiver. 

Note:  Transmissions with a DCS subtone have an equivalent: the 
DCS end tone. This consists of a 134 Hz tone that lasts 180 ms and 
is not configurable.

In the Add or Edit Signalling Profile dialog box, Tx Timers tab, the Reverse 
tone burst check box enables reverse tone bursts. 

The Duration box specifies the length of the tone burst. You can specify this 
in milliseconds or in cycles. If the burst has too many cycles, it comes back into 
phase with the original subtone and the radio may detect it again, re-opening 
the receiver gate. Specifying the duration in cycles for different CTCSS 
frequencies can help prevent this. 

The Phase angle box specifies the amount that the burst is out of phase with 
the original CTCSS subtone. If you select +120 or -120 instead of 180, more 
cycles are required before the burst comes back in phase with the original 
subtone. 
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Soft-off time
The base station can also send only carrier (carrier without modulation of any 
kind) at the very end of each transmission. 

In the Edit Signalling Profile dialog box, Tx Timers tab, the Soft-off time 
check box enables the feature and the Duration box specifies the length of time 
that only carrier is transmitted. 

Advanced
In the Add or Edit Signalling Profile dialog box, the Advanced tab lets you 
define the way the receiver gate responds to signals with  CTCSS  and configure 
reminder tones if the base station is being used as a community repeater.

CTCSS gating
In the Add or Edit Signalling Profile dialog box, Advanced tab, the CTCSS 
gating area configures the opening and closing of the receiver gate in response 
to CTCSS tones.

Open gate You can configure the receiver to open its gate as fast as possible, or after a 
defined time. 

Close gate You can tell the receiver whether to recognize reverse tone bursts, closing the 
gate quickly, or whether to close the gate only after ceasing to detect the 
CTCSS tone.

Option Description

As fast as 
possible

The base station declares that the receiver input is valid as soon 
as it detects a valid CTCSS tone. This happens more quickly at 
higher tone frequencies. The actual speed depends on the 
CTCSS characteristics (see “CTCSS characteristics” on 
page 80).

After nnn ms When RF appears on the RF input, the base station starts a 
timer and begins decoding the CTCSS tone. After decoding, it 
waits for nnn milliseconds before declaring that the input is 
valid and opening the receiver gate. 

Option Description

As fast as possible (RTB decode) The receiver recognizes the reverse tone 
burst and closes its gate.

On subtone end The receiver ignores any reverse tone 
bursts. When it detects that the 
subtone on the RF input has ceased, it 
closes its gate.
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Reminder tone
In the Add or Edit Signalling Profile dialog box, Advanced tab, the Reminder 
tone area lets you configure the reminder tone that can be added to 
transmissions for a particular talk group. 

One pip every Specifies the interval between pips.

Pip duration Specifies the length of time that the pip tone sounds for.

Tone level Specifies the amplitude of the pip tone relative to the nominal audio level.

Tone frequency Specifies the frequency of the tone. 

Task Manager
In the Add or Edit Signalling Profile dialog box, the Task Manager tab opens a 
Task Manager form and displays the tasks that apply to the signalling profile 
named above the tab. 

Use it to configure Task Manager inputs and actions that apply to the channel 
profile.
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Working With the Channel Table

The Channel Table form (Configure > Base Station > Channel Table) lets you 
work with channels. You can view the configured channels, edit them, and add 
more channels using a variety of different methods. 

Channel Table Details
The Channel Table form (Configure > Base Station > Channel Table) displays 
the channels defined in the channel table of the configuration file that you 
opened or the base station database that you read.

The form contains a table that displays a row for each channel. The row 
indicates which profiles have been assigned to the channel and displays the main 
configuration items. 

If default profiles are assigned, all columns are editable. If a custom profile is 
assigned, the columns to its right are defined by the profile.

Not all columns are visible; scroll the display to see the rest. 

An arrow at the left of one row indicates that it is selected; if, for example, you 
click Insert Copy, that row will be copied. Use the mouse or the arrow keys 
to change your selection. When you make any changes to a row, the arrow 
changes to a pencil.

Important: The arrow does not define the current or default 
channel. To find out the channel the base station is currently 
operating on, select Monitor > Monitoring > Base Station. To 

specify the default channel, select Configure > Base Station > General. 

A set of buttons along the bottom lets you work with the channels in the table.

Columns
In the channel table (Configure > Base Station > Channel Table), the first two 
columns indicate the number and name of each channel. The other columns 
define the main characteristics of each channel. Not all columns are visible; 
scroll the display to view them. You can also adjust their width. Some columns 
you can edit directly; in others a drop-down list appears when you click in the 
cell. ‘Multiple’ means that the profile definition defines more than one value for 
the column’s parameter.
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Num The number of the channel. This is the number that external channel selection 
and Task Manager actions use when changing the channel that the base station 
operates on. If you move a row up or down, its channel number changes. If you 
edit the channel number, its position in the table changes.

Channel Name The name of the channel. When you create a channel, it is given a default name 
of the form ‘Channel nnn’ where nnn is the channel number. You can edit this 
name to reflect the channel’s purpose or users. 

Receive Frequency The radio frequency that the channel receives on.

Transmit 
Frequency

The radio frequency that the channel transmits on. 

Signalling Profile The signalling profile assigned to the channel. This profile defines a group of 
operating parameters. If the profile is ‘Default’, the next two columns are 
editable.

Receive Signalling Indicates the subtone that the channel recognizes as a valid signal on its receive 
frequency. If the signalling profile is ‘Default’, you can edit this column, 
otherwise it is defined by the profile. ‘Multiple’ means that the profile assigned 
to the channel defines more than one subtone.

Transmit 
Signalling

Indicates the subtone that the channel includes in its transmissions. If the 
signalling profile is ‘Default’, you can edit this column, otherwise it is defined 
by the profile. ‘Multiple’ means that the profile assigned to the channel defines 
different subtones for different receive signalling.

Channel Profile The channel profile assigned to the channel. This defines a further group of 
parameters. If the profile is ‘Default’, the next two columns are editable.

Filter Specifies the audio response characteristics of the channel. ‘Multiple’ means that 
these are different for different audio paths or that the receive characteristics are 
different from the transmit characteristics (custom channel profiles only). ‘Pre/
De-Emph Speech Band’ and ‘Pre/De-Emph Full Band’ mean that pre-
emphasis is applied to any enabled transmit path and that the equivalent de-
emphasis is applied to any enabled receive path.

Power The RF power output that the channel is configured to provide when it is 
provided with mains power. (The channel profile may specify a different power 
output for battery power). 
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Channel Spacing The nominal channel spacing of the channel (the actual channel spacing is 
determined by the interval between this channel and the adjacent channels in 
the channel table). Channel spacings correspond to the following IF bandwidths 
and transmit deviations. 

If the channel is assigned a custom profile, the receiver can have one channel 
spacing while the transmitter has another. In this case, the channel table displays 
the receiver channel spacing. 

Buttons
A row of buttons along the bottom of the channel table (Configure > Base 
Station > Channel Table) lets you work with channels. You can add or remove 
channels, create a whole new block of channels, or rearrange them into a better 
order. 

Insert New Inserts an additional channel at the end of the channel table. The channel is 
identical to the last channel in the table except for the channel number.

Insert Copy Inserts a copy of the selected channel at the end of the table. 

Block Copy Lets you add a number of channels to the channel table, each with the 
properties of the selected channel, except that the channels all have a channel 
spacing that you specify. See “Block Copying Channels” on page 121 for more 
information.

Move Up Shifts the current row above the previous row, effectively renumbering it with 
the previous channel number. You can use Move Up and Move Down to give 
the list of channels a more logical or tidy order, or to group channels in 
particular ways.

Important: Move Up and Move Down assign a different number to 
the channel. If you use them, you may need to alter the default 
channel selection, any external channel selection, and any Task 

Manager actions that change channel.

Move Down Shifts the current row below the previous row, effectively renumbering it with 
the next channel number.

Delete Removes the current row from the channel table.

Import Lets you add a set of channels from a file exported from another base station. 
See “Importing Channels” on page 122.

Export Lets you save a set of this base station’s channels to a file so that you can import 
them into other base stations. See “Exporting Channels” on page 122.

Channel Spacing 
(kHz)

Name
Rx IF Bandwidth 

(kHz)
Tx Max Deviation 

(Hz)

12.5 Narrow Band 7.5 2500

20 Mid Band 12 4000

25 Wide Band 15 5000
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Editing a Channel (Default Profiles)
When a channel has the default profiles assigned to it, you can edit most of the 
cells in its table row.

To edit a channel

1. In the channel table (Configure > Base Station > Channel Table), click in 
the row that defines the channel. An arrow appears at the left of the row 
indicating that it is selected.

2. If desired, click in the Channel Name cell and edit the channel’s name.

3. If necessary, alter the receive frequency and the transmit frequency.

Note: The Service Kit does not check whether the base station can 
operate on these frequencies.

Note: You cannot assign a frequency in the range 406.0-406.100 
MHz. These frequencies are reserved internationally for distress 
beacons. 

4. If the system requires subaudible signalling, configure it as follows:

a. In the Receive Signalling column, select the subtone that the base 
station will receive. 

b. In the Transmit Signalling column, select the subtone that the base 
station will transmit.

5. In the Filter column, select the appropriate audio filter. See “Filter” on 
page 101 for more information about the available options. 

6. In the Output Power column, specify the transmitter’s RF output power.

7. In the Channel Spacing column, specify a nominal channel spacing for the 
transmit and receive channels. For more information, see “Channel 
Spacing” on page 119. 

8. Click OK to confirm your changes and close the form. 

Note: If you are editing a large number of channels, periodically 
select File > Save to save the changes to a file on disk. 

Editing a Channel (Custom Profiles)
If you assign custom profiles to a channel, most of the columns become read-
only. The channel is largely defined by the settings in the assigned profiles. 

To edit a channel

1. In the channel table (Configure > Base Station > Channel Table), click in 
the row that defines the channel. The arrow appears at the left of the row 
indicating that it is selected.

2. If desired, click in the Channel Name cell and edit the channel’s name.

3. If necessary, alter the receive frequency and the transmit frequency.

Important: Do not assign a prohibited frequency to the transmitter. 
For example, 406.0-406.100 MHz is reserved internationally for 
distress beacons.

Note: The Service Kit does not check whether the base station can 
operate on these frequencies.
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4. Click in the Signalling Profile cell. An arrow appears at the right of the 
cell. Click it and select a profile from the drop-down list. This list contains 
all the profiles defined in Configure > Base Station > Signalling Profiles.

5. If you selected the Default profile, you can edit the Receive Signalling and 
the Transmit Signalling cells. If you selected a custom profile, these cells 
are read-only; they display what has been defined in the profile. To change 
them, you must select a different profile or alter the current profile’s settings.

6. In a similar way, select a channel profile.

7. Click OK to confirm your changes and close the form. 

Note: If you are editing a large number of channels, periodically 
click OK, and then Save. 

Adding and Copying Channels
The Channel Table form (Configure > Base Station > Channel Table) has a 
row of buttons along the bottom that give you a variety of methods for adding 
to the number of channels.

Insert New The Insert New button inserts a row below the current row. The row is 
contains default values and is assigned the Default profiles.

Insert Copy The Insert Copy button copies the current row and inserts it below that row. 
The channel number is incremented.

Block Copying Channels
In the channel table, Block Copy lets you create a block of channels. Each 
channel in the block has its own frequency pair, but all other configurations are 
the same. You can subsequently edit any channel as desired.

1. Select Configure > Base Station > Channel Table.

2. Click in the row of the channel that you want to block copy.

3. Click Block Copy. The Block Copy dialog box appears.

4. In the Channel block start box, enter the channel number of the first 
channel you want to create.

5. In the Channel block end box, enter the channel number of the last 
channel in the block. 

6. In the Receive frequency increment box, enter a number of kHz. This 
determines how much the receive frequency of a channel differs from the 
previous channel. For example, if you enter 15 kHz and the previous 
channel’s receive frequency is 10 MHz, the next channel’s receive 
frequency will be 10.015 MHz.
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Important: Do not assign a prohibited frequency to the transmitter. 
For example, 406.0-406.100 MHz is reserved internationally for 
distress beacons.

Note: The Service Kit does not check whether the base station can 
operate on these frequencies.

7. In the Transmit frequency increment box, specify the number of kHz 
that the transmit frequency will increment for each channel you add. 

8. Click OK to create the block of channels and close the dialog box. The 
channels appear in the Channel Table form.

Importing Channels
You can import a file containing channels that have been exported from 
another base station. Importing overwrites any channels with the same number 
as the imported channel. Imported channels always have the default signalling 
and channel profiles.

To import channels

1. In the Channel Table form (Configure > Base Station > Channel Table), 
click Import.

2. Navigate to the folder containing the TB8100 channel file (*.t8h), select it, 
and click Open. 

Exporting Channels
You can export channel configurations. This provides an exported channel file 
that you can import into other base station channel tables. It also generates a 
text file for your records. 

To export channels

1. In the Channel Table form (Configure > Base Station > Channel Table), 
select the channels you want to export by holding down the Control key 
and clicking the row selector at the left of the table.

2. Click Export.

3. Specify the path and file name for the file you want to create.

4. Click Save.

The Service Kit saves the file, giving it the extension .t8h. It also saves an 
equivalent text file with the same name and with the extension .txt. The text 
file gives you a readable view of the exported channel. Editing this file has 
no effect on the exported channels.
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Selecting a Channel

After you have set up a number of channels, you need to specify the one that 
the base station will actually operate on. 

1. Select Configure > Base Station > General.

2. In the Default channel box, choose a channel from the drop-down list. 

This is the channel that the base station will operate on, unless it uses exter-
nal channel selection or a  Task Manager action changes channel or makes 
a different channel the default. 
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Printing Channel Data

You can print channel and other configuration data that you have opened from 
a configuration file or read from a base station.

Note: Printing to an old-style text printer is not supported, because 
the layout  requires the use of large and small fonts.

To print channel data

1. Select File > Print. The Print Selection dialog box appears. 

2. Using the arrow buttons, select the configuration items you want to print. 
An item is selected for printing when it is in the right-hand box.

The >> and << buttons move all configuration items.

The > and < buttons move the highlighted item. Click an item to 
highlight it.

3. Click Printer Settings and check the printer setup.

4. Click Print to send the configuration information to the printer.
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Part G Alarms

The Service Kit can monitor the current status of a base station’s 
alarms. It can also display the alarm log (a list of recent alarms). 
Many alarms have thresholds that you can alter to suit the 
application. Unwanted alarms can be disabled.

The base station can notify you in various ways when alarms 
occur. Use the Service Kit to enable and configure these 
notification methods.   

Topics

About Alarms

Monitoring Alarms

Viewing Recent Alarms

Disabling Unwanted Alarms

Altering Alarm Thresholds

Notifying Alarms

Configuring Alarm Center Communications

Configuring Email Messaging
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Monitoring Alarms

The Current Status form (Monitor > Alarms > Current Status) shows the 
current status of alarms in the base station. The Service Kit must be connected 
and logged on to the base station.

LED-like icons indicate the status: 

Red (flashing) means that the alarm is active.

Green means that the monitored condition is OK and that there is no alarm.

Gray means that the alarm has been disabled or that the monitored condition 
is not available; for example, Final 2 alarms are gray if there is no Final 2 
stage.

Alarms are triggered when a monitored condition crosses a defined threshold. 
Some thresholds are fixed and built into the module firmware. Others are 
configurable in Configure > Alarms > Thresholds. Some parameters such as 
high voltage and high reverse power have two thresholds. When the 
configurable threshold is crossed, the base station generates an alarm. When the 
built-in threshold is crossed, the base station responds by protecting itself against 
damage. 

Tip: Use Task Manager to configure an automatic response to 
alarms. In general, each alarm has an equivalent Task Manager 
input. When the alarm occurs, Task Manager executes any tasks 

with that alarm as an input.
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Reciter
The Reciter area shows the Alarm status of the reciter. 

Power up failure The reciter has failed one or more of its initialisation self-tests and has gone into 
Download mode. The transmitter and receiver are disabled and any system 
interface outputs are deactivated. 

Note: This alarm will not show if the reciter cannot communicate 
with the Service Kit.

1. Make sure that there isn’t another reciter in the BSS with the same control 
bus number. 

2. Reset the base station. This may clear the fault.

3. Send the reciter to a Service Center.

Channel invalid The base station has received an instruction to select an invalid channel number 
and has stopped transmitting and receiving. 

The channel could be invalid for one of the following reasons:

1. The channel number specifies a UHF frequency, but the base station is 
VHF, or vice versa. 

2. The base station cannot lock onto the specified frequency. To verify if this 
is the cause, do a diagnostic test to see if the base station can lock onto the 
frequency. See “Determining Synthesiser Lock Ranges” on page 153. 

3. There is a problem with the external selection of the channel.

a. Select Monitor > Monitoring > Base Station to determine whether the 
channel number is determined by hardware.

b. Select Diagnose > Reciter > Digital I/O to see what the base station 
thinks the hardware channel is set to. 

c. Select Configure > Base Station > System Interface to check that the 
base station is configured to correctly interpret the channel selection. Are 
the settings for Binary or BCD format and for Invert correct?

d. Select Configure > Base Station > Channel Table to see whether a con-
figuration for the externally selected channel exists.

4. A  Task Manager action asked the base station to go to a channel number 
that does not exist in the channel table. 

a. Check to see if a recent Task Manager action has changed the channel 
number (Monitor > Task Manager > Recent Actions). 

b. Look in the channel profile folders in the Task Manager task list to see if 
there are any ‘go to channel’ actions. Note the number of the channel 
that Task Manager instructed the base station to go to.
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c. Select Configure > Base Station > Channel Table to see whether a con-
figuration for that channel exists.

Synthesiser out of 
lock

The reciter has three different synthesiser alarms.

Synthesiser out of 
lock: Exciter

The exciter synthesiser is unable to lock on to the frequency it is configured to 
operate at. In response, the base station disabled the transmitter.

1. Check that this frequency is within the exciter’s RF frequency range. 

2. Do a diagnostic test to determine the reciter’s  switching range, and then 
check that the frequency is within the exciter’s switching range. 

3. If the frequency is outside the switching range, use the Calibration Kit to 
alter the switching range. Otherwise send the reciter for repair.

Synthesiser out of 
lock: Digital

One or more of the DSP and sampling clocks is out of lock. In response, the 
base station disabled the receiver and the transmitter.

1. The base station is configured for an external reference of a particular 
frequency, but the actual frequency of the external reference is different. 

2. The master synthesiser is unable to lock onto the frequency. The base station 
will run, but the accuracy of its receive and send frequencies cannot be 
guaranteed. Send the reciter for repair.

Synthesiser out of 
lock: Receiver

The receiver synthesiser is unable to lock onto the frequency it is configured to 
operate at. In response, the base station disabled the receiver.

1. Check that this frequency is within the receiver’s RF frequency range. 

2. Do a diagnostic test to determine the lock range, and then check that the 
frequency is within that range. 

3. If the frequency is outside the lock range, use the Calibration Kit to alter the 
switching range. Otherwise send the reciter for repair.

Power Amplifier
The Power Amplifier area shows the alarm status of the PA associated with the 
reciter you are logged on to. When a fault is no longer active, any actions (for 
example, inhibiting transmission) are reversed.

No PA detected The reciter cannot obtain a response from a PA over the using the  control bus. 
The PA may still be operating but the system has lost the ability to monitor PA 
alarms, carry out diagnostics, change configuration, or detect PA fan failure.   

1. No PA is installed.
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2. Your system uses a third party PA which does not use the control bus and 
cannot respond to the reciter.

3. The control cable or exciter cable is not connected.

4. The PA is faulty and unable to communicate with the exciter. 

Fan failed The PA told the reciter that its fan is on, but the reciter cannot detect fan 
motion. The base station takes no action when this alarm occurs, but it will act 
if the PA temperature becomes too high.

The fan has failed. Replace it.

Shutdown The PA has detected a fault condition and has disabled the transmitter to 
prevent damage. Check the other alarms to see what fault condition or 
conditions have caused this. 

VSWR high The VSWR is above the configured threshold. A normal VSWR is ≤ 2:1. 
A high VSWR automatically means reduced output power. If the VSWR 
increases to 10:1 or more, the PA folds back its power output to a minimal level. 
If the VSWR returns to 5:1 or less, the PA recovers.

Check for a load mismatch on the PA’s RF output. 

Power foldback The PA has detected a fault condition and has reduced its power output to a 
minimal level to prevent damage. 

Check the other alarms to see what fault condition or conditions have caused 
this. If the fault condition clears, the PA automatically returns to its previous 
power output level and the alarm changes to green.

Forward power 
low

The PA forward power output is below the configured minimum limit. If the 
VSWR is also raised, check for a load mismatch. Otherwise, there may be a 
fault in the output driver(s). 

Reverse power 
high

The PA’s reverse power is above the configured maximum. Check for a load 
mismatch. With a resolution of only 1 W, this alarm is not sensitive if the power 
output is lower than 20 W. Check the VSWR fault alarm instead.

Calibration invalid This alarm can only be triggered on startup, when the PA carries out self-tests. 
It indicates that settings stored in firmware have values outside acceptable limits. 
In response, the base station disables the transmitter. Re-calibrate the PA using 
the Calibration Kit or send it to a service center for repair. 

H/w configuration 
invalid

The PA has an invalid hardware configuration. Either the driver is not present 
or the configuration says that there is a Final 2 output stage but no Final 1, 
which is impossible.
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Current The Current group of alarms detects excessive or inappropriate current draw. 
If an alarm shows red, the PA needs servicing.

Supply voltage The PA can detect whether its power supply voltage is too high or too low.

Supply voltage 
high

The PA supply voltage is 29 V or more.

1. The third party power supply is incorrectly configured. 

2. A voltage regulator has failed. 

Note: The base station is not type-approved for operation when the 
supply voltage is outside the specified range. 

Supply voltage 
low

The PA supply voltage is 26 V or less, probably because the battery is running 
low. The fault condition disappears when the voltage exceeds 26.1 V.

Temperature high This group of alarms shows whether the temperature in the driver, Final 1, or 
Final 2 output stage has exceeded the configured threshold. If a temperature 
exceeds a built-in limit, the PA folds back its power output until the 
temperature is within the normal range.

To see the actual temperatures, select Diagnose > Power Amplifier > Control 
Tests. 

System
The System area displays alarms that are triggered by system conditions. These 
alarms do not indicate base station faults. You can set a threshold for these 
alarms if this is appropriate for your system. For example, if the base station 
should always receive a signal on the balanced input, you can set a threshold so 
that the alarm is triggered if the signal fails. Otherwise leave the threshold at 
zero, so that the alarm is never triggered.

Alarm Description

Driver high The driver is drawing excessive current. A fixed limit has been 
exceeded.

Final 1 The Final 1 output stage is drawing excessive current. A fixed 
limit has been exceeded.

Final 2 The Final 2 is drawing excessive current. A fixed limit has been 
exceeded.

Imbalance One of the final stages is drawing significantly more current 
than the other.
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Balanced input 
low

The audio level on the base station’s balanced input lines has fallen below the 
configured minimum. This alarm can be used to indicate when audio is lost.

Unbalanced input 
low

The audio level on the base station’s unbalanced input lines has fallen below the 
configured minimum. This alarm can be used to indicate when audio is lost.

External 
Reference

The base station can detect whether an external reference is present and 
whether it is useable.

External reference 
absent

The base station cannot detect an external reference frequency source. It is now 
using its own source.

1. There is no external reference source. Most applications do not need one.

2. The source has become unplugged.

3. The source is not working.

An external reference is critical for Quasi-Sync applications.

External reference 
invalid

An external reference frequency is connected to the base station, but the base 
station cannot lock on to its channel frequency using that reference. It is now 
using its own source.

1. The base station is configured (Configure > Base Station > General) to 
expect a 10 MHz frequency, but the source is 12.8 MHz (or vice versa). 

2. The reference source is faulty.

RSSI The base station measures the strength of the incoming RF signal and can 
determine whether it is stronger or weaker than a pre-defined level.

RSSI high The signal that the base station is receiving is stronger than the configured 
maximum.

RSSI low The signal that the base station is receiving is weaker than the configured 
minimum.

Air intake 
temperature

The base station is normally fitted with a sensor that measures the air 
temperature at the PA fan intake and determines whether it is above or below 
the configured limits.

Air intake 
temperature high

The temperature has exceeded the configured maximum. The PA can sustain 
full-powered continuous operation at an air intake temperature of up to 60° C. 
Fan operation and PA power foldback are unaffected by this alarm; it is the 
heatsink temperature, not the air intake temperature, that turns a base station 
fan on or folds back PA power.

Air intake 
temperature low

The temperature is below the configured minimum. The base station is not 
designed for operation below the default minimum.
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Power Management Unit
The Power Management Unit area shows the alarm status of the PMU that 
supplies the base station with power.

No PMU detected The reciter is unable to detect the PMU on the control bus. There may be a 
fault or the PMU may still be operating satisfactorily. However, the system has 
lost the ability to monitor PMU alarms, carry out diagnostics, change 
configuration, or detect PMU fan failure. Power saving is disabled.  

Fan failure The PMU told the reciter that its fan is on, but the reciter cannot detect fan 
motion. The base station takes no action when this alarm occurs, but it will act 
if the PMU temperature becomes too high.

The fan has failed. Replace it.

Shutdown 
imminent

This alarm only appears if the PMU has a DC-DC converter and a Standby 
converter. A battery is currently being used to power the base station and its 
voltage has fallen to the absolute minimum. The PMU will stop operating 30 
seconds after activating this alarm. 

The main value of this alarm is as an input for Task Manager actions. You can, 
for example, have the base station send the alarm log just before shutting down. 

Mains supply 
failed

The mains power supply to the PMU is absent or its voltage is outside 
acceptable limits. The PMU is using DC power from its battery source. 

Power up fault The PMU has detected an internal error and will reset itself. If the reset is 
successful, the alarm will clear.

Temperature high One of the PMU temperature sensors has detected a temperature that is above 
the fixed limit. 

Battery The PMU measures the voltage of its battery input.

Battery voltage 
high

The PMU’s battery voltage is higher than the configured maximum. The base 
station takes no action until the voltage reaches the fixed maximum, when it 
shuts down. 

Battery voltage 
low

The battery voltage is below the configured minimum. This minimum may 
have been set to alert you to the risk of damage to the battery from 
overdischarge. If the voltage falls below a fixed minimum, the PMU 
automatically shuts down to protect the battery and base station equipment. 

Battery protection 
mode

Battery protection mode is on. This happens when a base station is operating 
on mains power, but the battery voltage is still below the configured minimum. 
Battery protection mode requires a PMU with a standby converter. 
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If mains power fails when the PMU is in battery protection mode, the base 
station shuts down instead of using battery power. This protects the battery.

1. The system has been operating on battery power; the battery has become 
flat and mains is restored. No action required.

2. The battery is not being charged. Check the PMU’s auxiliary output line, if 
it is being used for charging.

3. The battery is flat. Replace it.

4. The minimum battery voltage is set too high. 

Output The PMU measures the voltage and the amperage of its DC output to the PA 
and to the reciter. 

Output voltage 
high

The PMU’s DC output (nominally 28 V) is higher than the fixed maximum of 
32 V. 

Output voltage 
low

The PMU’s DC output (nominally 28 V) is lower than the fixed minimum of 
24 V.

Output current 
high

The PMU is providing more than 15 A of current and is automatically limiting 
its output, lowering the output voltage. There is a short circuit or the PMU is 
faulty.
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Viewing Recent Alarms

The Reported Alarms form (Monitor > Alarms > Reported Alarms) displays 
recent alarms from the base station you are logged on to. The base station stores 
the last 50 alarm messages. When you log on, these messages become available 
and are displayed in this form. 

Note: The Alarm Center can also display recent alarms that have 
been sent to it by various base stations. 

The form displays information about the alarms, one row for each alarm. The 
display is updated with any new alarms each time the Service Kit polls the base 
station. The polling interval is set when you configure the connection. 

Each row contains the following information.

Date & Time The date and time that the alarm was reported to the base station (the date is 
provided by the base station’s clock).

Module The name of the base station module reporting the alarm.

Serial Number The serial number of the module reporting the alarm.

Reported Alarm The text of the alarm.

Save to File Click Save to File to save the displayed information. This enables you to store 
a record of alarms, for example, to help with troubleshooting an intermittent 
problem. The Alarm log can only store the most recent 50 alarms and these are 
lost if the base station is reset. 

Alarms are stored in CSV format. The default extension is *.csv.
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Disabling Unwanted Alarms

You can disable any of the base station’s alarms. Some alarms may not be 
appropriate for your system. For example, the Balanced input low alarm is only 
helpful if the absence of a line input indicates a system failure.

If you disable an alarm, it does not function in the Service Kit, appear in the 
alarm log, or turn on the control panel LED. However, Task Manager tasks 
with that alarm as an input are still processed.

To disable unwanted alarms

1. Select Configure > Alarms > Alarm Control. 

2. Clear the check boxes of the alarms to be disabled.

3. Click OK.
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Altering Alarm Thresholds

The Thresholds form (Configure > Alarms > Thresholds) lets you alter the 
thresholds for base station alarms.

Some alarm thresholds are fixed; they are built in to the base station and cannot 
be changed. Others have default values. You may want to adjust them to better 
reflect your system’s operating conditions or monitoring procedures. This can 
be important if an alarm is used as an input in Task Manager tasks.

The form displays a list of upper and lower limits. Alongside each threshold is 
the applicable unit. To the right, a box displays the current value of the relevant 
parameter. When a parameter value goes outside its limit, the base station 
triggers the corresponding alarm.

To adjust a threshold, edit its value or click one of the adjacent arrows, and then 
click OK to confirm your changes and close the form.

The alarms that these thresholds apply to are described in “Monitoring Alarms” 
on page 127. The equivalent Task Manager inputs are described in “Alarm 
Inputs” on page 180. 

Minimum PA 
power output

Defines the lower limit for the PA forward power output. When the output 
falls below this limit, the base station triggers the alarm Forward power low and 
the Task Manager input Forward power low becomes true.

Maximum PA 
reverse power 
output

Defines the upper limit for the PA’s reverse power. When the reverse power 
exceeds this limit, the base station triggers the alarm Reverse power high and 
the Task Manager input Reverse power high becomes true.

Maximum PA 
VSWR

Defines the upper limit for the VSWR. When the VSWR exceeds this limit, 
the base station triggers the alarm VSWR high and the Task Manager input 
VSWR fault becomes true.
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Maximum PA final 
temperature

Defines the upper limit for the operating temperature at the Final 1 and Final 2 
stages of the PA. When the temperature exceeds this limit, the base station 
triggers one of the Temperature high alarms and the Task Manager input PA 
temperature high becomes true.

Maximum PA 
driver 
temperature

Defines the upper limit for the operating temperature at the driver stage of the 
PA. When the temperature exceeds this limit, the base station triggers one of 
the Temperature high alarms and the Task Manager input PA temperature high 
becomes true.

PA air intake 
temperature

The Maximum box defines the upper limit for the air intake temperature that 
is measured at the PA. When the temperature exceeds this limit, the base station 
triggers the Air intake temperature high alarm and the Task Manager input PA 
air intake temperature high becomes true.

The Minimum box defines the lower limit for the air intake temperature that 
is measured at the PA. When the temperature falls below this limit, the base 
station triggers the Air intake temperature low alarm and the Task Manager 
input PA air intake temperature low becomes true.

PMU battery 
voltage

The Max box defines the upper limit for the battery voltage that is supplied to 
the DC-DC converter. Different limits apply, depending on which nominal 
voltage the DC-DC converter is designed for. When the voltage exceeds the 
relevant limit, the base station triggers the Battery voltage high alarm and the 
Task Manager input Battery voltage high becomes true.

The Min box defines the lower limit for the battery voltage that is supplied to 
the DC-DC converter. Different limits apply, depending on which nominal 
voltage the DC-DC converter is designed for. When the voltage falls below the 
relevant limit, the base station triggers the Battery voltage low alarm and the 
Task Manager input Battery voltage low becomes true.

Both the upper and lower limits have a hysteresis of 0.1 V. 

Balanced line 
input level

The Minimum box defines the lower limit for the level of the audio signal on 
the balanced line in. When the audio level falls below this limit, the base station 
triggers the Balanced input low alarm and the Task Manager input Balanced 
input low becomes true.

Unbalanced line 
input level

The Minimum box defines the lower limit for the level of the audio signal on 
the unbalanced line in. When the audio level falls below this limit, the base 
station triggers the Unbalanced input low alarm and the Task Manager input 
Unbalanced input low becomes true.

RSSI level The Maximum box defines the upper limit for the received signal strength as 
measured in the receiver. When the RSSI exceeds this limit, the base station 
triggers the RSSI high alarm and the Task Manager input RSSI high becomes 
true.

The Minimum box defines the lower limit for the received signal strength as 
measured in the receiver. When the RSSI falls below this limit, the base station 
triggers the RSSI low alarm and the Task Manager input RSSI low becomes 
true.



TB8100 Service Kit User’s Manual   Notifying Alarms 139

Notifying Alarms

The Notification Methods form lets you configure the way the base station lets 
you know over the air and over the line that there is an alarm. 

Important: Configuring these notification methods does not enable 
notification. This is done by Task Manager tasks that must be 
configured for your system.

Base stations with an Alarm Reporting license can send alarms to an Alarm 
Center and status messages (which contain the current state of all alarms and the 
alarm log) via email. 

Notifying Over the Air
The Service Kit lets you configure the way the base station notifies alarms using 
the base station’s own transmissions. To start and stop the over-the-air alarm, 
set up Task Manager statements. See “Over the air alarm actions” on page 190.

Tip: Use CWID as an additional over-the-air alarm notification 
method. Task Manager can disable CWID on startup, and then 
enable it when particular alarm conditions occur. See “CWID 

Actions” on page 188.

To configure the over-the-air alarm

1. Select Configure > Alarms > Notification Methods. 

2. In the Over the air area, Type box, select an alarm type. Currently, only 
Pip Tones are available. A pip tone is a 600 Hz tone with a duration of 200 
ms.

3. In the Pip method box, select an option that specifies how the pip tones 
are transmitted.

Option Description

Tail transmission A single pip tone is transmitted at the end of every 
transmission.

Periodically with Tx A pip tone is transmitted at the beginning of each 
transmission and regularly during the transmission at 
the interval specified by the Pip interval box.

Periodically with no Tx A pip tone is transmitted regularly when the base 
station is not otherwise transmitting. Pip tones are 
transmitted at intervals specified by the Pip interval 
box. 
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4. In the Pip interval box, specify the interval between pip tone 
transmissions.

5. In the Pip level box, specify the level of the pip tones in dB. This is the 
level relative to speech. More precisely, it is relative to the maximum 
transmit deviation of the current channel.

6. Click OK to confirm your changes and close the form.

Notifying Over the Line
The Service Kit lets you configure the way the base station notifies alarms over 
its balanced or unbalanced line interface. To start and stop the over-the-line 
alarm, see “Over the line alarm actions” on page 190.

To configure the over-the-line alarm

1. Select Configure > Alarms > Notification Methods. 

2. In the Over the line area, Type box, select an alarm type. Currently, only 
Pip Tones are available. A pip tone is a 600 Hz tone with a duration of 200 
ms.

3. In the Pip method box, select an option that specifies how the pip tones 
are sent.

4. In the Pip interval box, specify the interval between pip tone 
transmissions.

5. In the Pip level box, specify the level of the pip tones in dB. This level is 
relative to the line level specified in the channel profile for the current 
channel.

Option Description

Tail transmission A single pip tone is sent down the line at the end of 
every transmission

Periodically with Tx A pip tone is sent down the line at the beginning of 
each transmission and regularly during the 
transmission at the interval specified by the Pip 
interval box.

Periodically with no Tx A pip tone is sent down the line regularly when the 
base station is not transmitting RF. Pip tones are 
transmitted at intervals specified by the Pip interval 
box. 
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Configuring Alarm Center Communications 

If the base station has a dial-up modem and is able to connect via a telephone 
line to a PC running the Tait Alarm Center program, you need to enable and 
configure that connection. 

To configure base station communications with an Alarm Center

1. Select Configure > Communications > Alarm Center. The Alarm Center 
form appears.

2. Select the Alarm Center connection check box. 

3. Specify which base station serial port will be used. (Currently, Front panel 
is the only option.)

4. In the Number to dial box, enter the telephone number of the Alarm 
Center computer’s modem.

5. In the Number of retries box, specify the number of times that the base 
station will attempt to connect to the Alarm Center before giving up.  

Note: Make sure that this number is sufficiently high. If the Alarm 
Center is connected to another base station or if it is sending an 
email over its modem, the dial-up will fail and the base station must 

retry. For an Alarm Center with n base stations, it is a good idea to have n + 1 
retries.

6. In the Time between retries box, specify the length of time that the base 
station will wait before trying again to connect to the Alarm Center.

7. In the Modem command string box, specify any command string that is 
to be sent to the base station’s modem to configure it and prepare it for 
dialling.

8. Specify whether the base station modem is to use tone dialling or pulse 
dialling. Most modern telephone systems use tone dialling.



142 Part G: Alarms MB8100-00-00-806  © TEL 2003

9. In the Minimum interval box, specify the minimum time that must elapse 
after the base station sends an alarm log or email message before it can send 
another. Select a number and specify whether it is minutes or hours. Make 
sure that the interval is large enough to prevent the base station keeping the 
Alarm Center busy when other base stations are trying to contact it.

10.Click OK to confirm your changes and close the form. 

11.Create suitable Task Manager tasks that instruct the base station to send the 
alarm log or status message, using the action Send alarm log now. 
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Configuring Email Messaging

If the base station has an Alarm Reporting license and is set up with a dial-up 
connection using a telephone line, it can email alarms, for example, to the 
maintenance technician’s PC.

The Email form lets you enable and configure the sending of email messages. 
The base station passes the configuration information on to its Alarm Center 
along with the status message. The Alarm Center then builds the email using 
that information and sends it to the SMTP server address provided.  

To configure email messaging

1. Select Configure > Communications > Email.

2. Select the Email notification box to enable the base station to send emails 
via an Alarm Center.

3. In the Recipient box, enter the email address of the person to receive the 
email. If you want emails to be sent to multiple addresses, separate the 
addresses with a comma. 

4. In the Reply address box, enter an email address for replies. The base 
station itself cannot receive replies to the emails it sends; they will go instead 
to this address. 

5. In the Subject line box, enter the text for the subject of the emails. 

6. In the Leading information box, enter text that will be added to the 
message body before the actual content of the email. 

7. In the SMTP server box, enter the IP address of the server that the Alarm 
Center will send emails to.

8. Set up suitable Task Manager actions that send email in response to 
appropriate events.

Tip: Select Diagnose > Reciter > Misc I/O and send a test email to 
verify that the configuration works. 
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Part H Diagnosing

Using the Service Kit, you can carry out diagnostic tests on the 
base station and its modules. While you can view a diagnostic 
form in Run mode, the base station must be in Standby mode for 
the test itself.

Generally a diagnostic form displays relevant information, so that 
you can monitor base station status before, during, and after the 
test. Often you can combine different tests.

Some diagnostic tests check aspects of the base station. Others 
provide you with a simple function (for example, a voltage on the 
RSSI output pin) that facilitates setting up or troubleshooting the 
base station’s interface to external equipment. 

Topics

Carrying Out Diagnostic Tests

System Tests

Reciter Tests

Power Amplifier Tests

Power Management Unit Tests
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Carrying Out Diagnostic Tests

Most diagnostic tests are carried out in a similar way. The following describes 
how to do it. 

When you start a test, it uses the base station’s existing settings such as frequency 
and level, unless you enter different values.  When you stop a test or it comes 
to an end, the base station always returns to the configuration it was in before 
the test began. For example, after making a test transmission at a manually 
selected frequency, the base station reverts to the frequency it was previously 
configured for. 

To carry out a diagnostic test

1. Connect and log on to the base station. You can be remotely connected, 
but you do need to be on site to test the control panel and the speaker.

2. Click Diagnose.

3. Click Mode and select Standby mode.

4. In the navigation pane, select an item. The corresponding form appears.

5. In the form, check the base station’s current status and click Start Test. 

This either carries out the test or it enables other buttons on the form so that 
you can carry out a test. The item in the navigation pane turns red and the 
Start Test button changes to Stop Test. 

During the test, the base station will respond to any faults that occur (if, for 
example, the PA overheats, it will fold the power back) but there will be no 
alarm notification, because Task Manager is not active in Standby mode.

6. If desired, you can navigate to other forms to view monitoring screens, 
check the base station’s configuration. Some tests also allow you to 
simultaneously carry out other tests.

7. If necessary, click Stop Test to end the test (some tests end automatically). 
Selecting Run mode or disconnecting the Service Kit also ends the test. 
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System Tests

The Service Kit can initiate self-tests on the base station you are logged on to 
and verify that the control panel controls are working. 

Self-Tests
In the Self Tests form (Diagnose > System > Self Tests), you can ask the base 
station to carry out a set of self-tests. The base station itself determines whether 
it passes a test. The form displays the result of those tests. 

You can use the option buttons to configure the display to show all test results, 
only tests that failed, or only tests that passed.

To run base station self-tests

1. Click Run Tests. The tests can take up to 90 seconds. When the tests are 
completed, the Self Tests form displays the results. 

2. If the base station fails a test, click Reset Base Station (Administrator access 
level required). This may enable the base station to recover.  You need to 
connect the Service Kit again and log on to the base station.

3. Click Run Tests again. If the base station still does not pass the tests, note 
any failure codes displayed in the Code column and send the base station for 
repair.
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Control Panel Tests
The Control Panel form (Diagnose > System > Control Panel) lets you carry 
out tests to verify that the controls on the front of the BSS are working. You 
need to be at the base station site to carry out these tests. The base station can 
test all controls, including those used by the other channel.

To test control panel buttons

1. In the Button test area, click Start Test. This disables all control panel 
functions. The base station will now pass any control panel inputs to the 
Service Kit. 

2. Press a button on the control panel. 

3. Check that the corresponding LED in the Service Kit form turns green.

4. Repeat steps 2 and 3 for each other button you want to test.

5. Click Stop Test to conclude the test. 

To test the microphone’s PTT button

1. In the Button test area, click Start Test. This disables all control panel 
functions. The base station will now pass any control panel inputs to the 
Service Kit. 

2. Press the PTT button on the microphone.

3. Check that the PTT button LED in the Service Kit form turns green.

4. Click Stop Test to conclude the test. 

To test the speaker

1. In the Speaker Test area, click Start Test.

2. Turn up the volume and listen to confirm that a 700 Hz test tone at 0 dBm 
is coming from the speaker.

3. Click Stop Test to conclude the test. 

To test the control panel LEDs

1. In the LED test area, click Start Test.
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2. Check that each of the control panel LEDs is going on and off in a 
recognisable sequence.

3. Click Stop Test to conclude the test. 
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Reciter Tests

The Service Kit lets you carry out tests on the receiver, synthesiser lock ranges, 
audio lines, and the various digital inputs and outputs.

Receiver Tests
The Receiver form (Diagnose > Reciter > Receiver) lets you carry out various 
tests on the receiver part of the TB8100 reciter.

Testing Receiver Operation
The Set receiver frequency test provides a quick way to get the receiver 
operating. You manually set the receiver frequency and do not need to alter the 
base station’s configuration. 

1. Connect an RF source to the reciter. 

2. Select Diagnose > Reciter > Receiver. In the Frequency box, enter the 
frequency you want to receive on. Alternatively, use the arrow buttons to 
shift the frequency up or down.

3. In the Channel Spacing box, select a value from the drop-down list.

4. Click Start Test.  

In the Receiver Values area, a green LED indicates whether the receiver 
synthesiser managed to lock onto the frequency. The area also displays the 
current RSSI and SINAD and the receiver’s operating frequency.

5. If there is no response, check the Receiver state LED and box to verify 
that the receiver is on. If it is not on, the Exciter state LED and box 
indicate whether the whole reciter is off.

Note: The SINAD is approximate and is obtained by comparing the 
in-band audio against out-of-band noise. This value should not be 
relied upon to make calibrated measurements. 

6. If desired, unmute the receiver output as follows: 

a. In the Control area, click Start Test. 

b. Click Unmute Output.

7. If desired, modify the receive frequency by clicking the up or down arrows. 
(You can repeat this as often as you want.)
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The End Test button turns into a disabled Starting Test button until the new 
frequency has been tested.  The form now displays the new values.  

8. Click Stop Test when you are finished.

Testing Receiver Sensitivity
You can carry out a basic test of the receiver’s sensitivity without using test 
equipment. The test only works if the receiver has a 50 ohm load and is not 
receiving any RF signal. You can set this up by connecting up a test set and 
switching its RF off.

1. Disconnect the antenna and connect a 50 ohm load.

2. Select Diagnose > Reciter > Receiver. 

3. If necessary, alter the receiver’s frequency and channel spacing in the Set 
receiver test frequency area. 

4. Click Test Rx Sensitivity.  The Result box indicates whether the receiver 
passed or failed the test. If the receiver was receiving any RF, the test result 
will be ‘fail.’

Measuring Received Signal Levels
You can measure the strength of RF signal that the base station receives across 
a band of frequencies. A bar graph displays the results. 

This test lets you see what signals are out there; it does not determine the 
receiver’s sensitivity.
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To measure signal levels

1. Select Diagnose > Reciter > Signal Level.

2. In the Center frequency box, specify the middle frequency of the band 
you want to test. This can be any frequency within the receiver’s switching 
range.

3. In the Channel spacing box, select a value from the drop-down list. This 
specifies the size of the step from one frequency to the next. If this 
corresponds to the channel spacing, you will measure signal levels of the 
different channels in the band.

4. Click Start Test. The base station sets the receiver to a frequency, measures 
the RSSI, increments the frequency by the value in the Channel spacing 
box, measures its RSSI and so on for 101 steps below and above the center 
frequency you specified. 

When the test is complete, the graph displays the measured RSSI values and 
annotates the x-axis with the correct frequency values. 

Determining Synthesiser Lock Ranges
You can test the reciter’s synthesisers to determine the range of frequencies that 
the receiver and the exciter can operate on. Use these tests to check that the 
reciter is calibrated correctly for the channels that it will operate on.

The Clock source box indicates whether the reference frequency is internal 
or external to the base station.

The bottom group of boxes with LEDs indicate the lock status of various parts 
of the reciter in its current operation.

To test the exciter or receiver lock range 

1. Select Diagnose > Reciter > Synthesisers.

2. Click Start Test in the exciter or receiver row. 

The exciter or receiver checks all the channel frequencies in the band that 
the base station is type-approved to operate in.

3. In the Lower Frequency and Upper Frequency boxes, view the results 
of the test. These values report the range within which the synthesiser is able 
to lock onto the specified frequency. 

Note: The reported ranges are conservative. In fact, the base station 
will be able to transmit and receive outside the range, but with 
reduced transmit output and receive sensitivity. 

4. Click Stop Test. The exciter and receiver frequencies revert to what they 
were when you started the test.
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Audio I/O Tests
The Audio I/O form (Diagnose > Reciter > Audio I/O) lets you measure the 
level of any audio input or put a 0 dBm signal tone on the balanced or 
unbalanced line out.

In the Input area, the Audio Input gauge displays the level of the current audio 
input. In the Output area, the Audio Output gauge displays the audio level of 
the line out selected by the option buttons. The display continues to update 
every 500 ms.

Measuring the Audio Input Level
The reciter can measure the level of the current audio input and display it on 
the Service Kit. 

You can use this diagnostic tool in the following situations:

Troubleshooting: the measurement shows you whether audio is arriving at 
the base station. 

Adjusting the audio output of other equipment such as a console. 

Defining channel profiles: the measurement tells you the actual input level 
so that you can specify a value for the expected input level.

Note: Audio that is input during the test is not transmitted, because 
the base station goes into standby mode for the test.

To measure the audio input level

1. Make sure that audio is being fed into one or more inputs on the reciter’s 
system interface.

2. Select Diagnose > Reciter > Audio I/O.

3. Click the appropriate option to select the type of input you want to 
measure. 

4. In the Input area, click Start Test. 

The Audio Input gauge displays the audio level. The numeric value of the 
level appears under the gauge heading. The value is displayed in red if it is 
off the scale of the gauge. Levels are measured over a window of 100 ms and 
updated twice a second. 

5. Click Stop Test or return to Run mode to end the test.
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Generating an Audio Output
The reciter can output an audio test tone at one of three pre-defined 
frequencies. You can use this to test the reciter's ability to put audio on its 
output lines or to set up and configure the interface from external equipment 
to the base station. The audio is output at a nominal 0 dBm.

1. Select Diagnose > Reciter > Audio I/O.

2. In the Output area, specify which line out will carry the output.

3. Click Start Test.

4. View the Audio Output gauge and check that the measured level is close 
to 0 dBm (balanced line out) or 0.8 Vpp (unbalanced line out).

5. Click Stop Test or return the base station to Run mode to end the test.

Digital I/O Tests
The Digital I/O form (Diagnose > Reciter > Digital I/O)  lets you work with 
digital inputs and outputs. You can view the current state of all digital inputs 
and toggle any digital output to help you test any equipment connected to it.  

The Channel switch area indicates the channel number that is currently set by 
external equipment using the channel select lines on the system interface. If the 
area is disabled, this is because external channel selection is disabled (Configure 
> Base Station > System Interface.)

The Digital outputs area lets you toggle any digital output between active (red 
LED) and inactive (gray LED). You can do the same to the Rx Gate output.  

The Digital inputs area displays the current settings of digital inputs. You can 
also view the current state of the Tx Key input. 
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Testing Digital Outputs
You can toggle any digital output line or the Rx Gate output line between   
active and  inactive. Use this test to make sure that the output is working and 
to check that any equipment attached to that output responds as intended.

To test a digital output

1. Select Diagnose > Reciter > Digital I/O.

2. Click Start Test. This enables the Toggle buttons in the Digital Outputs 
area. This area now displays the output states as they were when you started 
the test.

3. Click the digital output’s (or Rx Gate’s) Toggle button to change its state.

When the output is activated, its LED displays Green. (If the output is not 
present on the system interface board, an error message appears.)

4. Check the response of any attached equipment.

When you have finished testing the outputs, click Stop Test. This returns all 
digital outputs to the state they were in when you started the test.

Testing Digital Inputs
The Digital inputs area displays the current state of all digital inputs to the 
reciter. 
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A digital input can be  active (red LED) or  inactive (gray LED). Many of these 
inputs can be configured as channel select lines. The Channel box indicates the 
channel number that they currently select and the text to the right indicates the 
number of bits (lines) involved and their logic settings.

To test a digital input

1. Select Diagnose > Reciter > Digital I/O.

2. Using the equipment connected to the digital input, toggle the state of that 
input.

3. In the Digital inputs area, check that the state of that input changed. 

Testing Hardware Channel Selection
If the channel that the base station operates on is to be selected by an external 
channel switch, you can verify that the base station correctly interprets the 
switch’s channel selection. 

1. Select Diagnose > Reciter > Digital I/O.

2. Using the channel switch, select a channel.

3. In the Channel switch area, check that the expected channel number 
appears.

4. If there is a discrepancy, follow these steps:

a. Check the DIP switch settings against the binary channel number 
displayed. 

b. Check that the correct channel selection option (Binary, BCD, or 
invert) is displayed. If not, select the correct option in Configure > Base 
Station > System Interface: Channel selection area.

Miscellaneous Tests
The Misc I/O form (Diagnose > Reciter > Misc I/O) lets you test the RSSI 
output and send a test email.

RSSI Tests
In the Misc I/O form, the RSSI output area lets you carry out tests on the RSSI 
output. You can:

provide a defined RSSI voltage output so that you can test equipment that 
is connected to the base station.

specify a received signal strength in dBm and test the base station’s 
conversion of the measured signal strength into an output voltage. You can 
use this test to convert an RSSI voltage to received dBm or vice versa.
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The Current output level box displays the voltage currently on the RSSI 
output pin.

Setting a Fixed RSSI Voltage
1. Select Diagnose > Reciter > Misc I/O.

2. In the Force output level to box, enter the voltage level you want.

3. In the adjacent box, select V. 

4. Click Start Test. This unlinks the RSSI output pin from the reciter’s 
operating logic. The RSSI output pin is initially set to 0 V, and then the test 
puts the selected voltage directly on the RSSI output pin.

5. Click Stop Test to stop the test. This gives control of the RSSI output back 
to the base station.

Testing the RSSI Output
1. Select Diagnose > Reciter > Misc I/O.

2. In the Force output level to box, enter a nominal received signal strength 
in dBm.

3. In the adjacent box, select dBm. 

4. Click Start Test. This unlinks the RSSI output pin from the reciter’s 
operating logic. 

The RSSI output pin is initially set to 0 V, and then the test uses the con-
figuration in Configure > Base Station > System Interface to calculate a 
voltage from the signal strength you specified and put it on the RSSI output 
pin. 

5. Using test equipment, measure the voltage on the RSSI output pin and 
confirm that it is as you would expect. Also check the voltage in the 
Current output level box. 

6. Click Stop Test to stop the test. This gives control of the RSSI output back 
to the base station, which updates the voltage with a value computed from 
the currently measured received signal strength.

Sending a Test Email
1. Select Diagnose > Reciter > Misc I/O.

2. In the Email area, click Start Test. The base station sends a test email using 
the configuration in Configuration > Communications > Email.  
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Detecting Subaudible Signalling
You can monitor the current channel for any subaudible signalling. This is a 
useful diagnostic tool if the base station is not opening the receiver gate to 
transmissions with subaudible signalling as expected. 

To detect subaudible signalling

1. Select Diagnose > Reciter > Subaudible Scan.

2. Click Start Monitoring. 

The form will now display the type and modulation frequency of any sub-
audible signalling that the base station receives.



160 Part H: Diagnosing MB8100-00-00-806  © TEL 2003

 Power Amplifier Tests

The Service Kit lets you test aspects of the PA. You can test the fan, the front 
panel, and the PA’s ability to transmit.

Control Tests
The Control Tests form (Diagnose > Power Amplifier > Control Tests) lets 
you test the PA fan and front panel fault LED. 

Alarm status Indicates whether the PA has any current alarms.

Current fault LED 
state

Indicates the current state of the LED and the fan, and lets you test them. 

Current 
temperature

The Current temperature area displays four thermometers that monitor the four 
PA temperature sensors.

Testing the PA Fault LED
You can test that the LED on the front of the PA is able to light up. (This LED 
is only visible when the front panel is removed.) 

1. Select Diagnose > Power Amplifier > Control Tests. 

2. Click Start Test. This uncouples the fault LED from the PA’s operational 
logic.

3. Click Toggle LED. If the fault LED was off, this should turn it on. 
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4. Check that the PA LED is on.

After five seconds, the test ends and the LED’s connection with the PA is 
restored. 

Testing the Fan
You can ask the base station to turn the PA fan on and off. This tests the fan 
and its control circuitry.

Test the fan after fixing a fan problem or fitting a new fan. When you fit a fan, 
use this test to verify that the fan is correctly connected, so that the PA (and not 
the PMU) activates it. 

Note: The base station can detect the motion of 3-wire fans and will 
raise an alarm if the fan does not operate.

 

To test the fan

1. Select Diagnose > Power Amplifier > Control Tests. 

2. Click Start Test. This uncouples the fan from the base station’s control but 
leaves it in its current state.

3. Click Toggle Fan. If the fan was off, this should turn it on.

4. Check that the fan is operating.  A 5-second timer counts down. When it 
expires, the test ends and control of the fan reverts to the base station. 

Testing the Transmitter
The Transmission Tests form (Diagnose > Power Amplifier > Transmission 
Tests) lets you test the ability of the PA to transmit. Use it, for example, when 
setting up and commissioning a system. You can:

transmit using the current channel configuration

specify any suitable frequency, and configure the output power and channel 
bandwidth. 

transmit carrier only or carrier modulated by your choice of modulation 
frequency and deviation level. 

Tip: Alternatively, test the transmitter by pressing the Carrier button 
on the control panel.

To ensure that you cannot inadvertently leave the base station transmitting, the 
test automatically stops after 60 seconds. 

Note: You can carry out this test together with other tests, for 
example to see the effect of transmission on battery voltage when 
the mains supply is off.
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Transmitter 
output

The Transmitter output area displays forward and reverse power gauges, and 
you can choose whether to view the values as watts or dBm. Underneath is the 
VSWR.

Alarm status If the Alarm status LED is red, there is a PA alarm and you cannot carry out the 
test. 

Manual 
transmission

The Manual transmission area lets you configure and carry out the transmission 
test.

To send a test transmission

1. If you don’t want to use the current channel configuration, specify the 
frequency and power of the test transmission as follows:

a. In the Transmitter frequency box, enter a frequency or use the arrows 
to increment or decrement the current frequency.

Important: Do not inadvertently transmit on a prohibited 
frequency. For example, 406.0-406.100 MHz is reserved 
internationally for distress beacons.

b. In the Power box, specify the RF output power that the test will run at. 
The box to the right displays the equivalent power in dBm.

2. If you want to transmit an unmodulated test signal, select the Carrier only 
option.

3. If you want to transmit a modulated test signal, select the Modulation on 
option, and configure the modulation as follows:

a. In the Deviation box, select a maximum transmit deviation.

b. In the Modulation level box, specify what percentage of the maximum 
deviation the test tone will have.

c. In the Modulation frequency box, specify the frequency of the tone 
that will modulate the test signal. 

4. Wait until the PA transmitter LED is gray (this means that the base station 
is not busy).
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5. Click Start Transmission. 

The PA outputs an RF signal on the RF Out N-connector. The Trans-
mitter output area gives you a graphical display of the forward and reverse 
power.

6. Click Stop Transmission at any time to end the test. 

If you don’t end the test, it automatically stops when the Time to autostop 
box has counted down to zero. If the transmission time was not long 
enough, click Start Transmission again.
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Power Management Unit Tests

The Service Kit lets you test aspects of the PMU and monitor additional details 
of its operation. 

Control Tests
The Control Tests form lets you simulate a mains failure. You can also check 
that the fan, the fault LED, and the auxiliary output are working. 

Simulating Mains Failure
The Control Tests form lets you simulate a mains failure so that you can test the 
BSS’s battery backup and the PMU’s DC-DC converter.

Important: This test affects any other base station in the BSS. 

Important: This test will shut the whole BSS down if there is no 
backup power supply. 

To simulate mains failure

1. Select Diagnose > Power Management > Control Tests.

2. Click Start Test at the bottom of the Control Tests form.

3. Click Mains Failure Test. 

4. Check that power to the PA and the Reciter/control panel stays on. 

Testing the Fan
You can ask the base station to turn the PMU fan on and off; this tests the fan 
and its control circuitry.
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Test the fan after fixing a fan problem or fitting a new fan. When you fit a fan, 
use this test to verify that the fan is correctly connected, so that the PA and not 
the PMU activates it. 

Note: The base station can detect the motion of 3-wire fans and will 
raise an alarm if the fan does not operate.
 

To test the fan

1. Select Diagnose > Power Management > Control Tests.

1. Click Toggle to the left of the PMU fan LED. If the fan was off, this should 
turn it on. 

2. Check that the fan is operating.

After ten seconds, the test automatically ends and the base station takes back 
control of the fan. 

Testing the PMU fault LED
You can test that the fault LED on the front of the PMU is able to light up. 
(This LED is only visible when the front panel is removed.)

1. Select Diagnose > Power Management > Control Tests.

2. Click Start Test to the left of the PMU fault LED. This uncouples the LED 
from the PMU’s operational logic.

3. Check that the PMU LED flashes on and off. (The control panel LED 
should also light up, unless all PMU alarms are disabled.) 

4. Click Stop Test to restore the LED’s connection with the PMU. 

Testing the Auxiliary Power Output
If the PMU is fitted with an auxiliary power supply submodule, you can test 
the PMU’s ability to switch its output on and off.

Note: The auxiliary power output must be on. If it is configured to 
be on only when the PMU uses mains power, make sure that the 
PMU is not using battery power.

1. Select Diagnose > Power Management > Control Tests.

2. Click Start Test at the bottom of the form.

3. Click the Toggle button above the Aux Output box.

The state of the LED should change.

4. Click Stop Test.
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Viewing Additional Details
The Supply Tests form (Diagnose > Power Management Unit > Supply 
Details) provides some additional information about the PMU. 

The form has a thermometer for each heatsink temperature sensor and an 
output voltage gauge. It also shows you all the monitoring information in 
Monitor > Monitoring > Power Management.
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Part I Task Manager

The Service Kit is your window into Task Manager. You can view 
the list of tasks, create new tasks from the available list of inputs 
and actions, and create custom inputs and actions. 

You can also monitor recent Task Manager actions and disable 
any tasks that may be causing problems. 

Topics

About Task Manager

Accessing Task Manager

Working With Task Manager

Inputs

Actions

Task Manager Examples

Customizing Task Manager

Monitoring Task Manager
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Accessing Task Manager

There are several different ways to access Task Manager forms. The different 
forms arrange the tasks differently, to present you with the most appropriate 
grouping of tasks for the part of the Service Kit you are currently in.  For 
example, if you open Task Manager from the Alarms section of the 
Configuration navigation tree, tasks relating to alarms are shown, and other 
tasks are hidden in folders. You can always access all tasks, no matter where you 
access Task Manager from

Task Grouping Best Access Method

General tasks Configure > Base Station > Task Manager

Tasks belonging to a 
channel profile

In the channel profile’s Edit Channel Profile dialog box, 
select the Task Manager tab

Tasks belonging to a 
signalling profile

In the signalling profile’s Edit Signalling Profile dialog box, 
select the Task Manager tab

Tasks that respond to 
an alarm 

Configure > Alarms > Alarms Task Manager
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Working With Task Manager

Task Manager forms let you work with the task list that the Task Manager 
processes. You can view the task list, add new tasks, modify existing ones, and 
rearrange the order and structure of tasks. Generally, a set of tasks is headed by 
a comment indicating their nature and purpose. 

The Task list item area lets you edit a selected item, which can be a task or a 
comment. When a task is selected, you can click one of the special Help icons 
to display information about the task’s input or action. The area also indicates 
the total number of enabled tasks.

The task list displays tasks in folders. Double-click a folder (or click its +/- icon) 
to open or close it. An open folder displays the tasks and comments that belong 
to it. Tasks generally have a tick; this means that they are enabled; tasks with a 
cross have been disabled. Click an item to select it; it appears inside the Task 
List Item area. 

The folders group related tasks. Tasks in a folder for a particular profile (for 
example, the default channel profile, or Signalling profile 1) are only processed 
if the current channel uses that profile.  

The buttons to the right lets you maintain the tasks in the list. For example, you 
can add an item or modify the selected item.

Maintaining the Task List
In Task Manager forms, the buttons to the right of the task list help you 
maintain the task list. To use some buttons, you must first select a task list item  
by clicking it. 

<<Update Item Saves changes you made to the selected item and updates the display in the Task 
List.

<<Insert Item Inserts the task displayed in the Task list item area just below the selected item 
in the task list. See also “Adding a Task” on page 171.
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Custom Actions Opens the Custom Actions form, where you can define your own combination 
of existing actions. 

Custom Inputs Opens the Custom Inputs form, where you can define your own combination 
of existing inputs. 

Move Up / Move 
Down

Shift the selected item up or down one line. Use these buttons to rearrange the 
order of tasks and comments in the task list.

Increase Indent / 
Decrease Indent

Let you add or remove an indent from a selected task. Indents have no effect 
on Task Manager processing; they help to make tasks easier to read and 
understand. You can only indent tasks that are under a comment. 

Enable / Disable By default, tasks are enabled; when an input condition becomes true, Task 
Manager processes the task. The Enable / Disable button lets you disable a task 
so that it has no effect, or toggle it between enabled and disabled. A standard 
base station can have up to 40 enabled tasks but up to 400 disabled ones. 

Delete The Delete button deletes the current task list item.

Adding a Task
To make full use of the base station’s capabilities, you need to add your own 
tasks to the list that Task Manager processes. This enables Task Manager to 
respond to events in a way that is tailored to your system. However, the set of 
actions must be well thought out to operate in exactly the way you want. 

Important: It is possible to create tasks that undermine the base 
station’s ability to operate properly. Make sure that the choices you 
make are appropriate. Be particularly careful with powerful actions 

such as Reset base station. 

Important: While Tait has carefully tested each input and each 
action, it is not possible to test the enormous number of possible 
combinations of inputs and actions.  Thoroughly test any tasks you 

add before commissioning the base station. If you are uncertain about anything, 
refer to your supplier.

You can add a task anywhere in the task list. However, tasks in a channel profile 
or a signalling profile folder will only be actioned if the current channel has that 
profile assigned to it.

To define a task

1. Open a Task Manager form (see “Accessing Task Manager” on page 169).

2. If desired, click the folder you want the task to appear in.

3. Select Task in the Task list item area.

4. In the drop-down text box, select IF. 

Alternatively, if you want the task to be processed when the input condition 
goes from true to false, select IF NOT. For example, tasks with the input 
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‘IF NOT Receiving valid signal’ will be processed when the base station 
stops receiving a signal with the correct subaudible signalling. 

5. Position the mouse cursor over the next drop-down box and right-click to  
open the list of available inputs. The inputs relevant to the context from 
which you accessed the Task Manager form appear in the main list; other 
inputs are grouped under headings.

6. Select an input from the list. It appears in the box.

7. In the same way, select an  action from the drop-down list of the last drop-
down text box. 

8. In the task list, click a task to indicate where you want to add the task. 
Alternatively, click a folder. 

9. Click <<Insert Item. The task appears in the task list. 

10. If necessary, use the buttons on the right to move the task up or down, or 
to indent it.

Adding a Comment
When you define a set of tasks, you need to provide a comment that names 
them and indicates what they are for and how they work. You may also want 
to add further comments on individual tasks.

To add a comment

1. Open a Task Manager form (see “Accessing Task Manager” on page 169).

2. In the Task list item area, select the Comment option. 

3. Inter the text of the comment into the box below.

4. Click <<Insert Item. The comment appears in the task list.

5. If necessary, use the buttons on the right to move the comment up or down, 
or to indent tasks under it.

6. Click OK to confirm your changes and close the form.

Disabling a Task
You can disable any task in the task list. This is an easy way to stop Task 
Manager doing something you don't want it to do. (When the base station is in 
Standby mode, Task Manager is disabled and no tasks are executed.)

To disable a task

1. In any Task Manager form, click a task.

2. Click Enable/Disable. The tick at the beginning of the task turns into a 
cross.
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Importing Tasks
You can import a file containing tasks and comments that have been exported 
from another base station. Custom inputs or actions used by any of these tasks 
will also be imported. 

Note: If an existing custom input or action has the same name as one 
to be imported, it will be overwritten without warning. 

To import task items

1. In any Task Manager form, click Import.

2. Navigate to the folder containing the TB8100 task item export file (*.t8i), 
select it, and click Open. 

Exporting Tasks
You can export tasks and comments to a file, which can be imported into other 
base stations.

To export task items

1. In any Task Manager form, click an item or a folder containing items, and 
click Select. The items turn bold. Repeat until you have selected 
everything you want to export.

2. Click Export. The Export Task Items dialog box appears.

3. Navigate to a suitable folder for the TB8100 task item export file (*.t8i) in, 
give the file a name and click Save. 
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Task Manager Inputs and Actions

Task Manager has a large set of inputs and actions. 

To select an input or action

Click in the appropriate box in the Task list item area. A menu with several 
submenus appears.

The menu shows you the input relevant to the context from which you 
accessed the Task Manager form. The submenus contain all the other inputs. 
You can select any input.

To obtain Help on a task’s input or action

1. Click the task.

2. In the Task list item area, click the Help icon beside the appropriate box.

Inputs
An input is anything that Task Manager monitors. When the state of that input 
changes from false to true, Task Manager executes tasks with that input. IF 
NOT tasks are executed when the state of the input changes from true to false. 
Most inputs are set to true when the base station transitions to Run mode. 

Many inputs read the state of a system flag. Select Monitor > Monitoring > 
Base Station to view the current state of system flags. 

General Inputs
General inputs relate to the general operation of the base station.  

Another receiver in rack
The Another receiver in rack input is true when there are two or more base 
stations in the BSS and they are responding to polls on the internal bus. This 
input is useful in combination with other inputs as a custom input. 

Example

IF Another receiver in rack AND Battery voltage low
THEN Go to channel 2.

Another receiver in rack and Battery voltage low need to be combined 
as a custom input, and Channel 2 can be set up with an extra low power output.

This example could be used to provide an extra low power output when there 
are two base stations in the BSS. It could be used in a standard configuration 
used by all base stations in a system and would not be processed in single base 
stations.

Base station in Run mode
The Base station in Run mode input becomes true when the base station 
goes into Run mode. This occurs on startup and when you tell a base station in 
Standby mode to change to Run mode. 

Use this input for tasks you want included in Task Manager’s initialization 
routine, to start timers, and to disable base station functions that you only want 
enabled under particular circumstances. You can also set a system flag to a value 
other than the usual default. 
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Important: The inverse of this input (IF NOT Base station in 
Run mode) must not be used; when the base station is not in Run 
mode, Task Manager is not operating.

Example

IF Base station in Run mode THEN Disable talk through repeater
IF Base station in Run mode THEN Disable line controlled base 

station

This example could be used to configure a backup base station with everything 
disabled but ready to go into operation when needed.

Counter at maximum
The Counter at maximum (Countername) input becomes true when the 
particular named counter reaches the maximum value set for it in Configure > 
Task Manager > Counters. 

The counter value changes through Task Manager actions such as Increment 
counter. Counter values are read at the beginning of a processing cycle. If the 
counter value changes during the processing cycle, it is immediately available; 
any subsequent tasks will use the new input. When the base station enters Run 
mode, all counters are reset to 0.

Example

IF Counter at maximum (LightTrigger) THEN Activate Digital 
Output 2. 

See “Base Station that Controls Landing Lights” on page 195.

Flag set (flagname)
The Flag set (flagname) input becomes true when Task Manager sets the 
corresponding flag. Flagname represents any name that you assigned to the flag 
in Configure > Task Manager > Flags. The state of flags is read at the beginning 
of a processing cycle. If a flag state changes during the processing cycle, it is 
immediately available; any subsequent tasks will use the new input. When the 
base station enters Run mode, each flag is cleared, unless a Task Manager task 
explicitly sets it. 

External channel select enabled
The override input External channel select enabled becomes true when 
Task Manager sets the H/W channel select flag. This occurs on entering Run 
mode and if a Task Manager task enables power saving after a previous task has 
disabled it. 

Example

IF NOT External channel select enabled THEN Go to channel 2

This example specifies the channel that the TB8100 will operate on if a Task 
Manager action disables external channel selection. This is another way of  
specifying the channel in software; you can also select a channel as the default. 
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PA fan servicing advised
The PA fan servicing advised input becomes true when the PA fan 
operating time (Monitor > Data Logging > System Data) exceeds the hours in 
the Operating time before servicing advised box (Configure > Alarms > 
Thresholds). 

Example

IF PA fan servicing advised THEN Email status now. 

This can email the status message to the technician on duty. The status message 
indicates that the PA fan needs servicing.

PMU fan servicing advised
The PMU fan servicing advised input becomes true when the PMU fan 
operating time (Monitor > Data Logging > System data) exceeds the hours in 
the Operating time before servicing advised box (Configure > Alarms > 
Thresholds).

Example

IF PMU fan servicing advised THEN Email status now. 

This can email the status message to the technician. The status message indicates 
that the PMU fan needs servicing.

Power saving enabled
The override input Power saving enabled becomes true when Task 
Manager turns the Power save system flag on. This occurs on entering Run 
mode and if a Task Manager task enables power saving after a previous task has 
disabled it. 

Timer expired
A timer can only be started by the Task Manager action Start timer. It expires 
when the timer’s maximum time has elapsed. This time was entered in 
Configure > Task Manager > Timers. 

Example

IF Timer expired (Weekly Email) THEN Email status now. 

This input can be used to set up regular actions such as emailing the status 
message. 

Tx relay enabled
The override input Tx relay enabled becomes true when Task Manager turns 
the Tx relay system flag on. This occurs on entering Run mode and if a Task 
Manager task enables power saving after a previous task has disabled it. 

Channel Profile Inputs
Channel profile inputs relate to configuration items that are defined in channel 
profiles. You can put tasks with a channel profile input into the folder for a 
particular channel profile or into the General folder. If the task is in a channel 
profile folder, it is only processed when the current channel uses that profile. It 
the task is in the General folder, it is always processed. 
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CWID enabled
The override input CWID enabled becomes true when Task Manager turns 
the CWID system flag on. This occurs on entering Run mode. It also occurs if 
a Task Manager task turns the flag on after a previous task has disabled it.

Intercom enabled
The override input Intercom enabled becomes true when Task Manager 
turns the Intercom system flag on. When the base station enters Run mode, 
Task Manager sets the Intercom system flag to off. When the Intercom 
enabled input is true, there is an audio path connecting the base station 
microphone and speaker to the audio in and out lines.

Line controlled base enabled
The override input Line controlled base enabled becomes true when 
Task Manager turns the Line connected base system flag on. This occurs on 
entering Run mode. It also occurs if a Task Manager task turns the flag on after 
a previous task has disabled it.

Loopback enabled
The override input Loopback enabled becomes true when Task Manager 
turns the Loopback system flag on. When the base station enters Run mode, 
Task Manager sets the Loopback system flag to off.

PA carrier present
Whenever the PA starts transmitting, the PA carrier present input is true. 
This input becomes true when the PA is keyed up.

PA keyed by Tx Key line
This input becomes true when the PA is keyed up to transmit as a line-
controlled base station. This means that the Tx Key line has keyed up the PA 
and that it is the line in audio that will be transmitted.

PA keyed by valid Rx
This input becomes true when the PA is keyed up to transmit as a talk-through 
repeater. This means that the receiver has keyed up the PA and the received 
signal is being transmitted. 

Receiver enabled
The override input Receiver enabled becomes true when Task Manager 
turns the Receiver system flag on.. When the base station enters Run mode, 
Task Manager sets the Receiver system flag to on.

Receiving valid signal
The Receiving valid signal input becomes true when the conditions for 
opening the receiver gate are fulfilled. The received signal must meet the 
requirements for receiver gating defined in the current channel profile and for 
subaudible signalling defined in the current signalling profile. For example, the 
signal must be strong enough and use the right CTCSS tone. 

When the base station receives a valid signal, it does not necessarily make the 
Rx Gate line active.

IF NOT Receiving valid signal THEN Transmit CWID now.

This sends a Morse code identifier at the end of each transmission.
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Rx Gate line active
The Rx Gate line active input becomes true when the Rx Gate line on the 
system interface goes low. This input is similar to Receiving valid signal, 
however the Rx Gate line becomes active not just when the base station is 
receiving a valid signal, but whenever there is a valid line audio output. This 
audio output can also come from the base station microphone or from line 
input (when loopback is enabled). 

Note: If the current channel profile does not specify an audio path 
to line out, the Rx Gate line does not become active when a valid 
signal is being received.

Talk through repeater enabled
The override input Talk through repeater enabled becomes true when 
Task Manager turns the Talk through repeater system flag on. This occurs on 
entering Run mode. It also occurs if a Task Manager task turns the flag on after 
a previous task has disabled it.

Example

You could use this input as part of a set of tasks that impose a time limit on calls 
when in repeater mode. 

IF Talk through repeater enabled AND PA keyed by valid Rx 
THEN Start timer (CallTimeLimit)

The two inputs need to be combined into a custom input. When it become 
true, a timer is started. When this timer expires, other tasks can disable the 
repeater, start a timer for the transmit lockout, and re-enable the repeater. 

Transmitter enabled
The override input Transmitter enabled becomes true when Task Manager 
turns the Transmitter system flag on. This occurs on entering Run mode. It also 
occurs if a Task Manager task turns the flag on after a previous task has disabled 
it.

Tx Key input enabled
The override input Tx Key input enabled becomes true when Task 
Manager turns the Tx Key system flag on. This occurs on entering Run mode. 
It also occurs if a Task Manager task turns the flag on after a previous task has 
disabled it.

Signalling Profile Inputs
Signalling profile inputs relate to configuration items that are defined in 
signalling profiles. You can put tasks with a signalling profile input into the 
folder for a particular signalling profile or into the General folder. If the task is 
in a signalling profile folder, it is only processed when the current channel uses 
that profile. It the task is in the General folder, it is always processed. 

Subtone decoding enabled
The override input Subtone decoding enabled becomes true when Task 
Manager turns on the Subaudible decode system flag. This occurs on entering 
Run mode. It also occurs if a Task Manager task turns the flag on after a 
previous task has disabled it.
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Subtone encoding enabled
The override input Subtone encoding enabled becomes true when Task 
Manager turns on the Subaudible encode system flag. This occurs on entering 
Run mode. It also occurs if a Task Manager task turns the flag on after a 
previous task has disabled it.

Tone nn detected 
This input becomes true when the receiver detects a subaudible tone that is 
defined in the current signalling profile (Subaudible Signalling tab). nn refers to 
the number of the tone specified in that profile (a profile can have up to 16 
tones defined). 

Example

Enable the technician to request the emailing of a status message

IF Tone 2 detected THEN Email status now

When the base station receives the subaudible tone, the base station emails a 
status message. The signalling profile is set up so that this tone only results in 
Task Manager action. To obtain status information, the technician transmits 
that subaudible tone: Task Manager then instructs the base station to email the 
status message to the configured destination. 

System I/O
System I/O inputs involve digital and audio inputs and outputs over the base 
station’s system interface board.

Balanced input low
The Balanced input low input becomes true when the audio level on the 
unbalanced line in falls below the minimum level specified in Configure > 
Alarms > Thresholds. 

This input is useful in applications where the base station can expect a signal all 
the time. It lets you define tasks that specify actions when the expected audio 
input ceases.

Example

IF Balanced input low THEN Start over the air alarm

If the line fails, the base station sends alarm pips over the air.

Digital input nn active 
The Digital input nn active input becomes true when the digital input 
becomes active.

Digital output nn active
The Digital output nn active input becomes true when the base station sets 
the digital output.

RSSI high
The RSSI high input becomes true when the RF signal that the base station is 
receiving exceeds the maximum signal strength specified in Configure > Alarms 
> Thresholds. 
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Example

IF RSSI high THEN Go to channel 2

Change to a channel with a lower output power on receiving a powerful signal.

RSSI low
The RSSI low input becomes true when the RF signal that the base station is 
receiving falls below the minimum signal strength specified in Configure > 
Alarms > Thresholds. This input is useful in applications where the base station 
can expect to be receiving a signal all the time. The input lets you specify what 
the base station is to do when the expected signal ceases.

Unbalanced input low
The Unbalanced input low Task Manager input becomes true when the 
audio input on the unbalanced line falls below the minimum level specified in 
Configure > Alarms > Thresholds. This Task Manager input is useful in 
applications where the base station can expect a signal all the time. The input 
then lets you define tasks that specify actions when the expected input ceases.

Example

Tell the base station to do something when the unbalanced line input signal 
fails.

 IF Unbalanced input low THEN Start over the air alarm

If the line fails, the base station sends alarm pips over the air.

Alarm Inputs
You can select any alarm as a Task Manager input. This makes it possible to 
individually configure the base station's response to any alarm. For information 
about base station alarms, see “Monitoring Alarms” on page 127. All alarms are 
basic inputs. Even if an alarm is disabled, tasks with that alarm as an input will 
be processed.

PA air intake temperature high
This input becomes true when the ‘Air intake temperature high’ alarm is 
triggered. For information about this alarm, see “Air intake temperature high” 
on page 132. 

PA air intake temperature low
This input becomes true when the ‘Air intake temperature low’ alarm is 
triggered. For information about this alarm, see “Air intake temperature low” 
on page 132. 

Base station alarm on
This input becomes true when any base station alarm is triggered. 

Battery protection mode on
This input becomes true when the PMU is operating in battery protection 
mode, triggering the ‘Battery protection mode’ alarm. For information about 
this alarm, see “Battery protection mode” on page 133. 
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Battery voltage high
This input becomes true when the ‘Battery voltage high’ alarm is triggered. For 
information about this alarm, see “Battery voltage high” on page 133. 

Battery voltage low
This input becomes true when the ‘Battery voltage low’ alarm is triggered. For 
information about this alarm, see “Battery voltage low” on page 133. 

Channel invalid
This input becomes true when the ‘Channel invalid’ alarm is triggered. For 
information about this alarm, see “Channel invalid” on page 128. 

Email service enabled
The Email service enabled input becomes true when Task Manager turns the 
Email alarms flag on. This occurs on entering Run mode. It also occurs if a Task 
Manager task turns the flag on after a previous task has disabled it.

External reference absent
This input becomes true when the ‘External reference absent’ alarm is triggered. 
For information about this alarm, see “External reference absent” on page 132. 

External reference invalid
This input becomes true when the ‘External reference invalid’ alarm is 
triggered. For information about this alarm, see “External reference invalid” on 
page 132. 

Fan failed
This input becomes true when the PA or PMU ‘Fan failed’ alarm is triggered. 
For information about these alarms, see “Fan failed” on page 130 for the PA or 
“Fan failure” on page 133 for the PMU. 

Forward power low
This input becomes true when the ‘Forward power low’ alarm is triggered. For 
information about this alarm, see “Forward power low” on page 130. 

Mains supply failed
This input becomes true when the PMU’s ‘Mains supply failed’ alarm is 
triggered. For information about this alarm, see “Mains supply failed” on 
page 133. 

No PA detected
This input becomes true when the ‘No PA detected’ alarm is triggered. This 
occurs when the module fails or control bus communications are disrupted. For 
information about this alarm, see “No PA detected” on page 129.

No PMU detected
This input becomes true when the ‘No PMU detected’ alarm is triggered. This 
occurs when the module fails or control bus communications are disrupted. For 
information about this alarm, see “No PMU detected” on page 133.
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Over the air alarm on
This input becomes true when Task Manager turns the over the air alarm on. 
For more information, see “Over the air alarm actions” on page 190. 

Over the line alarm on
This input becomes true when Task Manager turns the over the line alarm on. 
For more information, see “Over the line alarm actions” on page 190. 

PA alarm on
This input becomes true when any PA alarm is triggered.

PA current fault
This input becomes true when any of the PA’s current alarms are triggered. 
This happens if any part of the PA is drawing excessive current, or if one final 
stage uses significantly more current than the other. For information about these 
alarms, see “Current” on page 131.

PA is shut down
This input becomes true when the PA’s ‘Shutdown’ alarm is triggered. For 
information about this alarm, see “Shutdown” on page 130. 

PA power foldback
This input becomes true when the PA’s ‘Power foldback’ alarm is triggered. For 
information about this alarm, see “Power foldback” on page 130. 

PA startup fault
This input becomes true when the ‘Hardware configuration invalid’ alarm or 
any of the ‘Calibration invalid’ alarms are triggered. For information about 
these alarms, see “H/w configuration invalid” on page 130 and “Calibration 
invalid” on page 130.

PA supply voltage fault
This input becomes true when one of the PA’s power supply voltage alarms is 
triggered. This happens if the voltage is too high or too low. For more 
information, see “Supply voltage” on page 131. 

PA temperature high
This input becomes true when the one or more of the PA’s ‘Temperature high’ 
alarms is triggered. For information about this alarm, see “Temperature high” 
on page 131. 

PMU alarm on
This input becomes true when any PMU alarm is triggered.

PMU output fault
This input becomes true when one of the PMU’s output alarms is triggered, 
because the voltage is high or low or the current is high. For information about 
these alarms, see “Output” on page 134. 

PMU power up fault
This input becomes true when the PMU’s ‘Power up fault’ alarm is triggered. 
For information about this alarm, see “Power up fault” on page 133. 
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PMU shutdown imminent
This input becomes true when the PMU’s ‘Shutdown imminent’ alarm is 
triggered. For information about this alarm, see “Shutdown imminent” on 
page 133. 

PMU temperature high
This input becomes true when the PMU’s ‘Temperature high’ alarm is 
triggered. For information about this alarm, see “Temperature high” on 
page 133. 

Reciter alarm on
This input becomes true when any reciter alarm is triggered. 

Reverse power high
This input becomes true when the ‘Reverse power high’ alarm is triggered. For 
information about this alarm, see “Reverse power high” on page 130. 

Note: Use the VSWR fault input instead of the Reverse power high 
input if the transmit power is set to less than 20 W or if the base 
station has a 5 W PA. The resolution of the reverse power 

measurement is 1 W; only a very serious antenna fault would trigger the reverse 
power high alarm if the power setting is low.

Synthesiser failed
This input becomes true when a synthesiser goes out of lock or the external 
frequency reference is invalid and the corresponding alarm is triggered. For 
information about these alarms, see “Synthesiser out of lock” on page 129 and 
“External reference invalid” on page 132.

VSWR fault
This input becomes true when the ‘VSWR high’ alarm is triggered. For 
information about this alarm, see “VSWR high” on page 130. 

Custom Inputs
The Custom Inputs submenu contains all the custom inputs that have been 
defined for the base station using Configure > Task Manager > Custom Inputs.

Actions
An action is something that Task Manager instructs the base station to do. 

There is often a group of actions relating to a particular base station function. 
For example, Task Manager can enable, disable, or toggle the talk through 
repeater function.  Enable makes the function effective, disable makes it 
ineffective, and toggle changes from the one state to the other.

Tip: To obtain Help on a task’s action, click the task. In the Task 
list item area, click the Help icon beside the action box.

General Actions
General actions relate to the general operation of the base station.
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Fan test now
The ‘do now’ action Fan test now instructs the base station to run the fans 
for 5 seconds, irrespective of the temperature. If the fans are already running, 
this has no effect.

Email status
The ‘do now’ action  Email status instructs the base station to email a status 
message via the Alarm Center, provided that an email service override action 
such as Disable Email service has not disabled this function. It sends the email 
according to the settings in Configure > Communications > Email. If necessary, 
the base station waits until the minimum interval between email notifications 
has elapsed before sending the status message. If more than one request is 
received before the minimum interval elapses, only one status message is sent. 

Power saving actions
Power saving override actions can enable, disable, or toggle the power save  
system flag. When the base station enters Run mode, the flag is enabled. 

When the power save flag is enabled, the power saving configuration in the 
current channel profile is effective. When it is disabled, there is no power 
saving.

Loopback actions
Loopback override actions can enable, disable, or toggle the Loopback system 
flag. When the base station enters Run mode, the flag is disabled. 

Note: The default state of the Loopback system flag is ‘disabled’. The 
default for most other system flags is ‘enabled’.

For Loopback actions to have any real effect, corresponding audio 
paths (balanced in and balanced out, or unbalanced in and unbalanced out) must 
be configured in the current channel profile. If all four audio paths are enabled, 
there are two loopbacks; balanced audio in to balanced audio out, unbalanced 
audio in to unbalanced audio out). 

When Loopback is enabled, corresponding input and output audio paths are 
connected to each other. A signal that is sent along the base station’s line in is 
sent back down line out. This is useful for line testing. 

When Loopback is disabled, there are no connections between input and 
output audio paths.

Example

IF Tone 15 detected THEN Enable loopback
IF Tone 16 detected THEN Disable loopback

You could use a single tone to toggle loopback, but this gives no certainty about 
the state of loopback.

Intercom actions
Intercom override actions can enable, disable, or toggle the Intercom system 
flag. When the base station enters Run mode, the flag is enabled.

For Intercom actions to have any real effect, corresponding audio paths must be 
configured in the current channel profile. This means that the base station 
microphone must be connected to the balanced and/or unbalanced line out 
The speaker is always connected to the balanced line in. 
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When this system flag is disabled, the microphone’s connections are disabled. 

When this system flag is enabled, the audio path for the microphone and the 
speaker is as configured in the current channel profile’s Signal Path tab. 

Tx Key actions
The Tx Key system flag makes it possible for Task Manager to override the Tx 
Key line. Tx Key override actions can enable, disable, or toggle the flag. When 
the base station enters Run mode, the flag is enabled. 

When the Tx Key system flag is disabled, the transmitter does not key up when 
the Tx Key line on the system interface goes active. 

When the Tx Key system flag is enabled, the transmitter keys up when the Tx 
Key line on the system interface goes active and transmits the audio provided 
to it on the balanced and/or unbalanced line in. 

The Tx Key system flag has no effect on the base station’s internal keying logic.

Reset base station
The ‘do now’ action Reset base station resets the base station. You can use 
this action in tasks designed to help the base station recover from minor faults.

Note: When a base station is reset, it reverts to its default channel. 

Example
IF Tone 2 detected THEN Reset base station

This task means that a technician can remotely reset the base station by sending 
a radio signal with the appropriate subaudible signalling.

Transmitter actions
Transmitter override actions can enable, disable, or toggle the Transmitter 
system flag. This provides you with an additional layer of control over 
transmitter operation. 

When the base station enters Run mode, the flag is enabled. 

When the Transmitter system flag is disabled, the transmitter cannot transmit. 

When the Transmitter system flag is enabled, the transmitter operates as usual. 

If the PMU is fitted with a standby converter and the Receiver and the 
Transmitter system flags are both disabled, the PMU shuts down as in Deep 
Sleep mode. 

Note: You can shut down specific forms of the transmitter 
operation. See “Talk Through Repeater Actions” on page 187 and 
“Line-Controlled Base Actions” on page 187.

Receiver actions
Receiver override actions can enable, disable, or toggle the Receiver system 
flag. This provides you with an additional layer of control over receiver 
operation. 

When the base station enters Run mode, the flag is enabled. 

When the Receiver system flag is disabled, the receiver cannot receive. 

When the Receiver system flag is enabled, the receiver operates as configured. 
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If the PMU is fitted with a standby converter and the Receiver and the 
Transmitter system flags are both disabled, the PMU shuts down as in Deep 
Sleep mode. 

External channel select actions
External channel select override actions can enable, disable, or toggle the H/W 
channel select system flag. This provides you with an additional layer of control 
over how the current channel is selected. 

When the base station enters Run mode, the flag is enabled. 

When the flag is disabled, the channel is specified in software (Configure > Base 
Station > General). The base station uses the default channel.

When the flag is enabled, the channel is specified by the Channel select lines 
connected to the system interface card. The system interface must be configured 
using the Service Kit to enable channel selection. 

Note: Other Task Manager actions can tell the base station to change 
to a different channel.

Start timer
Task Manager can start or stop any of its 16 timers. When a timer is started, it 
counts down and expires when it reaches the length of time set in Configure > 
Task Manager > Counters and Timers. You can create tasks that are executed 
when a timer expires.

Stop timer
Task Manager can start or stop any of its 16 timers. When a timer is started, it 
counts down and expires when it reaches the length of time set in Configure > 
Task Manager > Counters and Timers. You can create tasks that are executed 
when a timer expires.

Set flag
Task Manager can set or clear any of 16 numbered flags. A flag can only have 
one of two states: set or cleared. The state of a flag can be used as an input in 
other tasks.

Clear flag
Task Manager can set or clear any of 16 numbered flags. A flag can only have 
one of two states: set or cleared. The state of a flag can be used as an input in 
other tasks.

Increment counter
The Increment counter action adds one to the counter specified. When a 
counter reaches its specified maximum, it triggers actions with the input 
Counter at maximum. 

Reset counter
The Reset counter action sets the value of the counter specified to zero, so that 
it must begin counting anew. 

Decrement counter
The Decrement counter action subtracts one from the current value of the 
counter specified. 



TB8100 Service Kit User’s Manual   Task Manager Inputs and Actions 187

Channel Profile Actions
Channel profile actions relate to configuration items that are defined in channel 
profiles. You can put tasks with a channel profile action into the folder for a 
particular channel profile or into the General folder. If the task is in a channel 
profile folder, it is only processed when the current channel uses that profile. If 
the task is in the General folder, it is always processed. 

Talk Through Repeater Actions
Talk through repeater override actions can enable, disable, or toggle the Talk 
through repeater system flag. This gives you an extra layer of control over the 
audio path that feeds received audio into the transmitter. It lets you program 
the base station to operate as a talk through repeater in some situations, and to 
intelligently switch to another way of operating when the situation changes.

When the base station enters Run mode, the flag is enabled. 

When the flag is disabled, the base station cannot function as a talk through 
repeater. Any internal audio path joining receiver and transmitter is 
disconnected and receiving a valid signal does not key the transmitter. 

When the flag is enabled, the internal audio path is as configured in the channel 
profile.

If the channel profile does not configure the base station as a talk through 
repeater, these Task Manager actions have no effect. 

Line-Controlled Base Actions
Line-controlled base override actions can enable, disable, or toggle the Line 
controlled base system flag. This gives you an extra layer of control over the 
audio path that feeds line in audio into the transmitter. It lets you program the 
base station to operate as a line-controlled base station in some situations, and 
to intelligently switch to another way of operating when the situation changes.

When the base station enters Run mode, the flag is enabled. 

When the flag is disabled, the base station cannot function as a line-controlled 
base station. The Tx Key line and any internal audio path joining a line input 
to the transmitter are disconnected.  

When the flag is enabled, the internal audio path is defined by the channel 
profile and the Tx Key line can be used to key the transmitter.

If the channel profile does not configure the base station as a line-controlled 
base station, these Task Manager actions have no effect. 

Go to channel
The Go to channel action instructs the base station to change channel and 
operate according to the configuration defined by the channel with the number 
specified in the action. It stays on that channel until another Task Manager 
action changes channel or a reset returns it to the default channel.

In base stations with a complex set of Task Manager tasks, you need to 
understand exactly how this action works. It is not a ‘do now’ action; the actual 
change of operating channel happens at the end of a processing cycle. This 
means, for example, that if the task list has a Go to channel 5 action  followed 
by a Go to channel 6 action, the base station will only ever change to channel 
6.  

Note: Hardware channel selection overrides all Task Manager 
channel actions.
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Make current channel the default
The Make current channel the default action instructs the base station to 
select the channel it is currently operating on as the default channel. This action 
is the equivalent of selecting the channel in Configure > Base Station > 
General, and programming the base station with that change. If Task Manager 
changes to a new channel and makes that channel the default, the base station 
stays on that channel even after a reset.

In base stations with a complex set of Task Manager tasks, you need to 
understand exactly how this action works. The action takes what Task Manager 
views as the current channel. For example, a base station is operating on 
Channel 1 and the task list has a Go to channel 5 action followed by a Make 
current channel the default action, and then a Go to channel 6 action. 
The result of processing this list is that channel 5 is the default. It is not Channel 
1 (the current channel during the processing cycle) or channel 6 (the channel 
that the base station goes to at the end of the processing cycle).  

Note: Hardware channel selection overrides all Task Manager 
channel actions.

Go to next channel
The Go to next channel action instructs the base station to operate on the 
next valid channel in the channel table. If the base station was on Channel 001, 
it changes to Channel 002. It stays on that channel until Task Manager changes 
channel or a reset returns it to the default channel.

In base stations with a complex set of Task Manager tasks, you need to 
understand exactly how this action works. It is not a ‘do now’ action; the actual 
change of operating channel happens at the end of a processing cycle. This 
means, for example, that if the task list has two Go to next channel actions, 
the base station will move two channels down the channel table. 

Note: Hardware channel selection overrides all Task Manager 
channel actions.

CWID Actions
Task Manager can enable, disable, or toggle the CWID system flag. This 
provides you with an additional layer of control over the transmission of a 
CWID.

When the base station enters Run mode, the flag is enabled. 

When the flag is disabled, there is no automatic transmission of the CWID.

When the flag is enabled, CWID is transmitted as configured in the channel 
profile’s CWID System tab. 

If the channel profile does not provide for CWID, this flag has no effect.

Transmit CWID now
The ‘do now’ action Transmit CWID now instructs the base station to 
immediately transmit the CWID message defined in the CWID System tab. 
This action enables you to configure CWID transmissions in a way that is not 
otherwise possible. For example, you could have the CWID transmitted more 
than once a minute or at every transmit tail. 

Transmit CWID now works even if a CWID action has disabled the CWID 
system flag. 
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Power saving actions
Power saving override actions can enable, disable, or toggle the Power save 
system flag. This provides you with an additional layer of control over power 
saving. 

When the base station enters Run mode, the flag is enabled. 

When the flag is disabled, no power saving occurs.

When the flag is enabled, power saving occurs as specified in the Power Saving 
tab of the Channel profile. 

Signalling Profile Actions
Signalling profile actions relate to configuration items that are defined in 
signalling profiles. You can put tasks with a signalling profile action into the 
folder for a particular signalling profile, or into the General folder. If the task is 
in a signalling profile folder, it is only processed when the current channel uses 
that profile. If the task is in the General folder, it is always processed. 

Subaudible Decoding
Subaudible decoding override actions can enable, disable, or toggle the 
Subaudible decode system flag. This gives you an extra layer of control over the 
base station’s response to subaudible signalling.

When the base station enters Run mode, the flag is enabled. 

When the flag is enabled, any subtones are decoded and checked against the 
current signalling profile. A received signal is only valid if it contains a specified 
subtone.

When the flag is disabled, subaudible signalling is not decoded. The received 
signal is regarded as valid irrespective of its subaudible signalling.

Subaudible Encoding
Subaudible encoding override actions can enable, disable, or toggle the 
Subaudible encode system flag. This gives you an extra layer of control over the 
subaudible signalling that the base station encodes onto its transmissions.

When the base station enters Run mode, the flag is enabled. 

When the flag is enabled, the base station encodes transmissions according to 
the signalling profile’s configuration (Subaudible signalling tab). 

When the flag is disabled, transmissions are not encoded with subaudible 
signalling.

System I/O
System I/O actions affect the base station’s digital outputs.

Activate Digital Output n
The Activate Digital Output n action makes the Digital Out n line on the 
system interface active.  If this line does not exist on the current user interface, 
the action has no effect. 

In base stations with a complex set of Task Manager tasks, you need to 
understand exactly how this action works. The actual activation of the digital 
output doesn’t happen till the end of a processing cycle. So the task list can 
activate and deactivate a digital output many times, but the output line will only 
ever be activated if the last action for that digital output is to activate it. 
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IF Counter at maximum (LightTrigger) THEN Activate Digital 
Output 2. 

See “Base Station that Controls Landing Lights” on page 195.

Deactivate Digital Output n
The Deactivate Digital Output n action makes the Digital Out n line on 
the system interface inactive.  If this line does not exist on the current user 
interface, the action has no effect. 

In base stations with a complex set of Task Manager tasks, you need to 
understand exactly how this action works. The actual deactivation of the digital 
output doesn’t happen till the end of a processing cycle. So the task list can 
activate and deactivate a digital output many times, but the output line will only 
ever be deactivated if the last action for that digital output is to deactivate it. 

Tx Relay actions
Tx relay  override actions can enable, disable, or toggle the Tx Relay system 
flag. This gives you an additional layer of control over the Tx Relay Driver line 
on the system interface. When the base station enters Run mode, the flag is 
enabled. 

When the Tx Relay system flag is disabled, the Tx Relay Driver line cannot go 
active. 

When the Tx Relay system flag is enabled, the base station can control an 
antenna relay using the Tx Relay Driver line, switching the relay before 
powering its transmitter up.

If the base station is not fitted with a system interface board that provides a Tx 
Relay Driver line, the Tx Key system flag has no effect.

Alarm
Alarm actions make it possible for you to configure the way that the base station 
responds to alarm conditions.

Over the air alarm actions
Over the air alarm actions can turn the base station’s over the air alarm on or 
off. Indeed, Task Manager action is the only way that this alarm can be started 
or stopped. 

When the base station enters Run mode, Task Manager ensures that the over 
the air alarm is turned off. 

When Task Manager turns on the over the air alarm, the base station starts 
transmitting the alarm over the air according to Configure > Alarms > 
Notification Methods. 

When Task Manager turns off the over the air alarm, the base station stops 
transmitting the alarm. 

Over the line alarm actions
Over the line alarm actions can turn the base station’s over the line alarm on or 
off. Indeed, Task Manager action is the only way that this alarm can be started 
or stopped. 

When the base station enters Run mode, Task Manager ensures that the over 
the line alarm is turned off. 
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When Task Manager turns on the over the line alarm, the base station starts 
sending the alarm over the line according to Configure > Alarms > Notification 
Methods. It will be sent over audio out lines that the system interface provides 
and that are enabled in the current channel profile’s audio path. 

When Task Manager turns off the over the air alarm, the base station stops 
sending the alarm. 

Email status now
The ‘do now’ action Email status now turns on a flag requesting that the 
base station email the status message. The email will be sent via an Alarm Center 
according to the configuration in Configure > Communications > Email. 

Note: A status message can only be sent once the minimum interval 
has elapsed after the last status message or alarm log was sent. This 
avoids (for example) receiving an email every time the base station 
keys up.

Note: Task Manager can disable the email service, which will 
override any future Email status now action. See “Email service 
actions” on page 191. 

Clear alarm log
The ‘do now’ action Clear alarm log empties the alarm log of all entries. This 
can be a useful action after the alarm log has been sent. Although Alarm Center 
will not duplicate alarms in its display, clearing the alarm log reduces the 
communications load involved in sending the alarm log. 

Example

IF Timer expired (Email Timer) THEN Clear alarm log

This task could be part of a set of tasks that emails the alarm log once per day. 
When a day timer expires, the alarm log is emailed. The email timer gives the 
base station time to send the alarm log. When that timer expires, the action 
clears the log, so that alarms are not sent more than once.

Email service actions
Task Manager can enable, disable, or toggle the Email system flag. This gives 
you an extra layer of control over the base station’s emailing functions.

When the base station enters Run mode, the flag is enabled. 

When the flag is enabled, Task Manager can email status messages (see “Email 
status now” on page 191). The base station does this according to the 
configuration in Configure > Communications > Email. 

When the flag is disabled, any Email status now actions are disregarded. 

Send alarm log now
The Send alarm log now action sends the alarm log to an Alarm Center, 
according to the configuration in Configure > Communications > Alarm 
Center. This configuration must have enabled Alarm notification to the Alarm 
Center, or the action has no effect.

First, the base station attempts to connect to the Alarm Center and log on. If it 
is successful, the base station sends its name and the contents of the alarm log, 
and then logs off and disconnects.
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Example

IF Base station in Run mode THEN Start timer (24 hour Timer)
IF Timer expired (24 hour Timer) THEN Send alarm log now
IF Timer expired (24 hour Timer) THEN Start timer (24 hour Timer)

Custom Actions
The Custom Actions submenu contains all the custom actions that have been 
defined for the base station using Configure > Task Manager > Custom 
Actions. 



TB8100 Service Kit User’s Manual   Task Manager Examples 193

Task Manager Examples

Task Manager makes it possible for you to build complex functions into the 
base station. Here are some examples of to give you an idea of what can be 
done. 

Important: While Tait has carefully tested Task Manager, no 
guarantee can be given that these examples will work correctly for 
your system. Make sure that you thorougly test any set of Task 

Manager tasks before commissioning the system.

Repeater Changeover
A line-controlled base station is connected to a console that provides tone on 
idle. The following Task Manager tasks automatically convert the TB8100 to a 
talk-through repeater if the line fails. When the line is re-established, the 
TB8100 reverts to line-controlled operation. 

IF Base station in Run mode THEN Disable talk through repeater.

This disables the base station’s talk through repeater mode whenever it enters 
Run mode.

IF Balanced input low THEN Enable talk through repeater.
IF Balanced input low THEN Disable line-controlled base station.
IF Balanced input low THEN Start over the air alarm.

If the line fails, the input line level falls below the prescribed minimum. This 
triggers Task Manager actions that switch off the line-controlled base station 
mode, enable the talk through repeater mode, and start sending alarm pips over 
the air.

IF NOT Balanced input low THEN Disable talk through repeater.
IF NOT Balanced input low THEN Enable line-controlled base 

station.
IF NOT Balanced input low THEN Stop over the air alarm.

When the line is re-established, Task Manager actions re-establish the line-
controlled base station function and stop the alarm.

Data and Speech Service
A repeater needs to relay speech as well as data. The speech needs to be pre-
emphasised while the data needs the full band from < 50 Hz to 3000 Hz. 
Speech is sent with a CTCSS tone. 

The base station needs to be able to automatically change between repeating 
pre-emphasised audio and repeating full band audio.

To achieve this, follow these steps:

1. Set up Channel 1 as a speech repeater. The channel profile (Signal Path tab) 
is set to De-emph Speech Band / Pre-emph Speech Band. 

2. Set up Channel 2 as a data repeater. The channel profile (Signal Path tab) is 
set to Flat Full Band.

3. Set Timer 1 to 150 milliseconds, corresponding to the time that the base 
station needs to decode subaudible signalling.
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4. Create two custom inputs:

Data Chan Detected, which consists of Timer 1 expired AND Tone 1 
NOT detected. 

Speech Chan Detected, which consists of Timer 1 expired AND Tone 
1 detected.

5. Create the following Task Manager tasks for Channel 1:

IF Receiving valid signal THEN Start timer 1.
IF NOT Receiving valid signal THEN Stop timer 1.
IF Data Chan Detected THEN Go to channel 002.
Receiving a valid signal on Channel 1 starts a timer. If no subaudible signal-
ling is detected when the timer expires, the custom input Data Channel 
Detected becomes true and Task Manager instructs the base station to go to 
channel 002.

6. Create the following Task Manager tasks for Channel 2

IF Receiving valid signal THEN Start timer 1.
IF NOT Receiving valid signal THEN Stop timer 1.
IF Speech Chan Detected THEN Go to channel 001.
Receiving a valid signal on Channel 2 starts a timer. If subaudible signalling 
is detected before the timer expires, the custom input Speech Channel 
Detected becomes true and Task Manager instructs the base station to go to 
channel 001.

Base Station with Automatic Charging
If the battery voltage goes low, the base station operates on lower power, starts 
the generator and sends transmitter pips. As soon as the battery voltage is back 
to normal, transmitter power is increased. The generator continues for one 
hour (or until a high battery voltage alarm is triggered). This ensures that the 
battery is properly charged.

To set this up, follow these steps:

1. Set up Channel 1 at 100 watts for mains power and 60 watts for battery 
power.

2. Set up Channel 2 as a low battery channel, with only 25 watts output power.

3. Set up Timer 1 as Generator On timer with a duration of one hour.

4. Set up a custom action End of Charging with the following actions:

Deactivate Digital Output #1 AND

Stop timer #1 (Generator On timer)

Stop over the air alarm

5. Set up the following Task Manager tasks:

IF Battery voltage low THEN Go to channel 002
IF NOT Battery voltage low THEN Go to channel 001.
When the battery voltage is low, this switches operation to Channel 002, 
which has a reduced PA output power.

IF Battery voltage low THEN Activate Digital Output #1.
IF Battery voltage low THEN Start over the air alarm
IF Battery voltage low THEN Start timer #1.
When the battery voltage is low, a digital output is set, which starts the gen-
erator. Additional actions turn on over the air pips and start a timer that will 
turn the generator off. 
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IF Battery voltage high THEN End of Charging
IF Timer #1 expired THEN End of Charging
These two tasks stop the generator when the battery voltage gets too high 
or when the Generator On time expires.

Base Station with Auxiliary Antenna
You can set up a base station with an auxiliary antenna and use Task Manager 
actions to automatically switch to that antenna when there is an antenna 
mismatch. The service person can use a radio to send CTCSS tone 2 to switch 
the antenna back.

IF Base station in Run mode THEN Deactivate Digital Output 2

This sets the antenna relay at power up.

IF VSWR fault THEN Activate Digital Output 5
IF VSWR fault THEN Email status now

If a VSWR fault occurs, Task Manager automatically swaps the antenna over 
and emails the alarm log.

IF Tone 02 detected THEN Deactivate Digital Output 5

To switch the antenna back, the technician transmits a signal with CTCSS 
tone 2.

Base Station Regularly Emails its Status
It is straightforward to use Task Manager tasks to have the base station email its 
status to the maintenance technician, for example, once a week.

To do this, you define a timer with a one week duration. When the timer 
expires, the status is emailed and the timer re-started. 

IF Base station in Run mode THEN Start timer (1 week timer)
IF Timer expired (1 week timer) THEN Email status
IF Timer expired (1 week timer) THEN Start timer (1 week timer)

This combination of tasks emails the status of the base station once a week.

 Base Station that Controls Landing Lights
A small private airport does not have full time air traffic control. When landing 
at night, the pilot needs to switch on the runway lights. Pilots have VHF radios 
without CTCSS, Selcall, or any other signalling. The pilot presses PTT three 
times within two seconds to switch on the lights.

1. Wire Digital Output #6 to control the lights.

2. Give Counter #1 a maximum of 3.

3. Give Timer #1 a maximum of 2 seconds.

4. Give Timer #2 a maximum of 30 minutes 

5. Set up the following Task Manager tasks:

IF Receiving valid signal THEN Start timer (Timer 1)
IF Receiving valid signal THEN Increment counter (Counter 1)
IF Timer expired (Timer 1) THEN Reset counter (Counter 1)
This set of tasks detects three presses of PTT, provided they occur before 
Timer #1 expires.
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IF Counter at maximum (Counter 1) THEN Start timer (Timer 2)
IF Counter at maximum (Counter 1) THEN Activate Digital 

Output 6
IF Counter at maximum (Counter 1) THEN Reset counter 

(Counter 1)
This set of tasks starts the lights timer, turns the lights on, and re-starts the 
counter for detecting three presses of PTT.

IF Timer expired (Timer 2) THEN Deactivate Digital Output 6
This task turns the lights off when the 30 minutes has elapsed.

Simplex Operation
If the TB8100 is to be used as a simplex line-connected base station with an 
antenna relay, the receiver must be disabled when the transmitter is keyed up. 
This can easily be done using Task Manager:

IF PA keyed by Tx Key line THEN Disable receiver
IF NOT PA keyed by Tx Key line THEN Enable receiver

Note: Testing this on your system may uncover a need to build in 
some timing to ensure that the receiver is disabled before the 
transmitter starts.

Scanning Repeater
In a two-repeater site, Task Manager makes it possible for either repeater to 
turn into a scanning repeater if the other repeater fails. The scanning repeater 
handles both channels, providing a complete backup system. 

When a repeater fails, the other starts scanning. It changes to a channel, waits a 
few 100 ms, checks the received signal, and, if nothing is there, it goes to the 
next channel. If there is a signal, it will just repeat it as usual, complete with all 
the signalling and line output requirements for that channel.  Here a single base 
station is providing the same service but with a poorer throughput.

IF Base station in Run mode THEN Start timer (ChangeChannel)
IF Receiving valid signal THEN Stop timer (ChangeChannel)
IF Receiving valid signal THEN Stop timer (On Channel)
IF NOT Receiving valid signal THEN Start timer (On Channel)
IF Timer expired (ChangeChannel) THEN Go to next channel
IF Timer expired (ChangeChannel) THEN Start timer 

(ChangeChannel)
IF Timer expired (On Channel) THEN Go to next channel
IF Timer expired (On Channel) THEN Start timer 

(ChangeChannel)

This example is a straightforward scanner.  It will search through all the 
channels in the channel table looking for activity. A small variation on this can 
make it stay on its home channel until an external signal triggers the scanning.

Digital Inputs with Special Functions
Task Manager tasks make it possible for digital inputs to have a great variety of 
functions.

Subtone Decode Disable Pin
When digital input # is active, the base station disables the decoding of 
subaudible signalling.
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IF Digital input # active THEN Disable subaudible decoding
IF NOT Digital input # active THEN Enable subaudible decoding

Cancel Alarms Pin
When the digital input is activated, Task Manager action ceases to dial up an 
Alarm Center to send alarm logs and status messages. 

IF Digital input # active THEN Disable alarm service
IF NOT Digital input # active THEN Enable alarm service
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Customizing Task Manager

Customizing Task Manager adds to its power and flexibility. There are several 
options available. You can create custom inputs or actions and define timers, 
counters, and flags. You can then use them to create tasks that will be executed 
when the custom input becomes true, the timer expires, the counter reaches its 
maximum, or the flag is activated. 

Working With Custom Inputs
The Custom Inputs form (Configure > Task Manager > Custom Inputs) lets 
you work with custom inputs. It lists the existing custom inputs and lets you see 
what combination of standard inputs each consists of. You can also create new 
custom inputs and edit or rename existing ones. 

A custom input is a user-defined Task Manager input that consists of a 
combination of standard inputs. Custom inputs make it possible to define tasks 
that will be processed when a combination of inputs becomes true. (A Task 
Manager task can only have one input.)

Viewing a Custom Input
1. Click an item in the Custom Input Name column.

2. View the display in the rest of the form. It shows the standard inputs used 
to create the custom input, whether they are negated, and the logic of their 
combination. The standard truth table determines the outcome for the 
different states of any pair. (See “Truth Table” on page 199.)

The Logic column shows graphically how the standard inputs will be com-
bined. First the input is negated, if its Not check box is selected. Then it is 
combined with the adjacent input to which it is joined by a line. The result 
of that combinatorial operation is combined with the input or result that it 
is joined to, and so on, until the final result is obtained. In this way, up to 
eight standard inputs can be combined to produce an input that can only be 
true or false.
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Defining a Custom Input
1. Click New. 

2. Edit the name that appears in the Custom Input Name column.

3. Click in an Input box and select an input from the list. 

4. If you want the negative of the input to contribute to the custom input’s 
logic, select the Not check box alongside.

5. Repeat steps 3 and 4 for all the standard inputs that will go to make up the 
custom input. The Input boxes that you choose will determine the order in 
which the standard inputs are combined. 

6. Under the Logic heading, select the appropriate options in the drop-down 
boxes to give the logical combination of inputs that you want. (For 
information about the effect of the different options, see “Truth Table” on 
page 199.)

7. Click OK.

Truth Table
The truth table below displays the possible individual values for input A and 
input B, and the result when you combine those values using each of the six 
available logic operators.  So, for example, if A is true and B is false and we 
combine A and B using XOR, the result is true. 

Working With Custom Actions
The Custom Actions form (Configure > Task Manager > Custom Actions) lets 
you work with custom actions. It displays the list of existing custom actions. If 
you select a custom action, it displays the set of standard actions that it consists 
of. You can also create new custom actions and edit or rename existing ones. 

A custom action is a user-defined Task Manager action that consists of more 
than one standard action. It saves you writing several different tasks with the 
same input.

A B AND NAND XOR XNOR OR NOR

false false false true false true false true

false true false true true false true false

true false false true true false true false

true true true false false true true false
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Viewing a Custom Action
1. Click an item in the Custom Action Name column.

2. View the Standard Actions column. It lists the standard actions that the  
custom action consists of.

Defining a Custom Action
1. Click New. 

2. Edit the name that appears in the Custom Action Name column.

3. Click in the first row of the Standard Actions column and select an action 
from the list. 

4. Repeat step 3 for all the standard actions that will go to make up the custom 
action. 

5. Click OK.

Defining Counters, Timers, and Flags
Counters, timers, and flags make it possible for Task Manager to do such things 
as respond to three presses of PTT or to email a status message once a week.

Note: Short timers may not be accurate. This is because it may take 
Task Manager longer than 10 ms to process its tasks, causing it to 
miss the next instruction to go through its task list. Tait recommends 

that you avoid short timers (< 50 ms) if the task list has more than 10 enabled 
tasks. 

To define a counter

1. Select Configure > Task Manager > Counters.

2. If desired, enter a suitable name for the counter into the Name box.

3. In the Maximum box, enter the highest number that the counter can 
reach. 

When the counter reaches its maximum, the input Counter at maximum 
becomes true for that counter and any tasks containing it are processed.

To define a timer

1. Select Configure > Task Manager > Timers.

2. If desired, enter a suitable name for the timer into the Name box..

3. In the Maximum box, enter the highest number that the timer can reach.

4. In the Time box, enter the number that the timer will count down from.

5. In the Units box, specify what unit of time the number you entered 
represents. 

When the timer reaches its maximum, the input Timer expired becomes 
true for that timer and any tasks containing it are processed.

To define a flag

1. Select Configure > Task Manager > Flags.

2. If desired, enter a suitable name for the flag into the Name box.

3. Click OK.
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Monitoring Task Manager

The items under Monitor > Task Manager provide options for monitoring 
Task Manager. If the base station is behaving unexpectedly, you can view the 
state of system flags to see whether Task Manager has overridden the normal 
configuration. Alternatively, open the Recent Actions form to see a list of 
actions that Task Manager has recently carried out. You also can view the 
current state of timers, counter, and flags.

Viewing System Flag States
The System Flags form (Monitor > Task Manager > System Flags) displays the 
current state of flags that Task Manager sets in the base station firmware. A 
green LED means that the flag is enabled. A gray LED means that it is disabled.  
Most flags are enabled by default, but Loopback, Over the air alarms, and 
Over the line alarms are disabled. When the base station enters or re-enters 
Run mode, Task Manager sets all flags to their default values. Flags only change 
when Task Manager executes a task that enables, disables, or toggles them.

Important: The System Flags area shows you the state of the flags, 
not necessarily the state of the corresponding base station function. 
It is important to understand this distinction. For example, if the 

Loopback flag is enabled, the base station’s audio will in fact be looped back 
only if the current channel profile provides compatible line in and line out 
audio paths. If the Email alarms flag is enabled, the base station will only 
actually email alarms if email alarm notification is enabled and correctly 
configured in Configure > Communications > Email. 

Use the System Flags area to find out whether Task Manager has enabled or 
disabled any functions. If a system flag does not show the default setting, Task 
Manager has changed it. Checking the state of the alarm notification functions 
is particularly important. 

The System Flags area is an important place to check, if the base station is not 
behaving as expected; Task Manager actions may be responsible. 

Loopback When the Loopback flag is enabled, audio from the line input is connected 
directly to line output. Loopback can only happen if the current channel 
profile’s signal path has a line input and a line output. A balanced input can only 
be looped back to a balanced output and an unbalanced input can only be 
looped back to an unbalanced output. By default, the flag is disabled.

Intercom When the Intercom flag is enabled, a technician at the base station can 
communicate with a console over the line. The Base Station’s microphone is 
connected to line output. When the flag is disabled, the microphone is 
disconnected, but the speaker still remains connected to the receiver Path A.

Tx Key When the Tx Key flag is enabled, the Tx Key line on the system interface can 
be used to key up the transmitter. When the flag is disabled, you can still 
transmit microphone audio using the PTT key, but the Tx Key line has no 
effect, which means that line audio is not transmitted.

Receiver When the Receiver flag is enabled, the receiver is able to receive as usual, 
according to the current channel configuration. When the flag is disabled, the 
receiver is unable to pass any received audio.
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Transmitter When the Transmitter flag is enabled, the transmitter is able to transmit as usual, 
according to the current channel configuration. When the flag is disabled, the 
transmitter is unable to transmit signal at all.

Talk through 
repeater

When the Talk through repeater flag is enabled, the base station feeds received 
audio into the transmitter according to the current channel profile. (Edit 
Channel Profile form: Audio Path tab. The Talk-through repeater box 
specifies the audio path.) When the flag is disabled, the transmitter is not given 
audio from the receiver. 

Line connected 
base

When the Line connected base flag is enabled, the base station feeds line in 
audio into the transmitter according to the current channel profile. (Edit 
Channel Profile form: Audio Path tab. The Tx audio path A or Tx audio 
path A check box must be selected.) When the flag is disabled, the transmitter 
is not given line in audio. 

Power save When the Power save flag is enabled, the base station applies power saving 
according to the current channel profile (Edit Channel Profile form: General 
tab). When the flag is disabled, power saving is not applied.

Over the air alarm When the Over the air alarm flag is enabled, an alarm is sent over the air 
according to the configuration in Configure > Alarms > Notification Methods: 
Over the air notification area. When the flag is disabled, the over the air alarm 
is turned off.

Over the line 
alarm

When the Over the line alarm flag is enabled, an alarm is sent over the line 
according to the configuration in Configure > Alarms > Notification Methods: 
Over the line notification area. When the flag is disabled, the over the line alarm 
is turned off.

Email service When the Email alarms flag is enabled, any alarms are sent via email according 
to the configuration in Configure > Communications > Email. When it is 
disabled, alarms are not sent via email.

CWID When the CWID flag is enabled, the base station transmits a continuous wave 
ID (Morse code) according to the current channel profile (Edit Channel Profile 
form: CWID System tab). When the flag is disabled, no Morse code is 
transmitted.

Subaudible 
encode

When the Subaudible encode flag is enabled, the base station encodes audio 
according to the current signalling profile (Edit Signalling Profile form: 
Subaudible signalling tab). When the flag is disabled, subaudible signalling is not 
added to audio.

Subaudible 
decode

When the Subaudible decode flag is enabled, the base station decodes any 
subaudible signalling according to the current signalling profile (Edit Signalling 
Profile form: Subaudible signalling tab). When the flag is disabled, subaudible 
signalling is not decoded, which means that there is no receiver gating based on 
subaudible signalling.
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H/W channel 
select

When the H/W channel select flag is enabled, the base station uses the channel 
number specified by external equipment. This equipment sets the channel 
number using channel selection lines on the system interface (see Configure > 
Base Station > System Interface. The Channel selection check box must be 
enabled.) When the flag is disabled, the base station uses the default channel (set 
in Configure > Base Station > General) or a channel specified by Task Manager 
action. 

Tx Relay When the Tx Relay flag is enabled in a simplex system, the base station can use 
the Tx Relay Driver line on its system interface to switch a relay that connects 
the transmitter or the receiver to the antenna. When Tx Relay is disabled, the 
Tx Relay Driver line has no effect.

Monitoring Recent Actions
The Recent Actions form displays the last 40 tasks that Task Manager carried 
out. This display shows you the situation when you opened the form: the 
display does not automatically update. 

Note: To see the current state of many parameters that Task 
Manager monitors, select Monitor > Task Manager > System Flags. 
These flags have a default state and are only altered when Task 
Manager executes a task.

To monitor recent Task Manager actions

1. Select Monitor > Task Manager > Recent Actions. 

2. If you want to update the display, click Read Last 40 Statements. 
Statements (actions) executed after you opened the form are added to the 
display.

Viewing Timers
The Timers form (Monitor > Task Manager > Timers) displays the current 
state of any timers that you configured for Task Manager. 

The Name column lists the timers. A bar graph shows how far each timer has 
progressed towards its maximum value, which is displayed in the Maximum 
column. 

Viewing Counters
The Counters form (Monitor > Task Manager > Timers) displays the current 
state of any counters that you configured for Task Manager. 

The Name column lists the counters. A bar graph shows how far each counter 
has progressed towards its maximum value, which is displayed in the Maximum 
column.

Viewing Flag States
The Flags form (Monitor > Task Manager > Timers) displays the current state 
of any custom flags that you configured for Task Manager. 

Each of the possible flags has an LED alongside it. A Green LED means that the 
timer is set. A gray LED means that is is cleared.
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Glossary

This glossary contains an alphabetical list of terms and 
abbreviations related to the TB8100 base station. For 
information about trunking, mobile, or portable terms, consult 
the glossary provided with the relevant documentation.

A

access level There are three different levels of access to a base station: 
Administrator, User, and Read-only. The User access level has a 
configurable access profile; the Administrator decides which 
functions that access level can carry out.

action An action is the second part of a Task Manager task. It specifies 
what the base station must do when the first part (the input) 
becomes true.

active Digital outputs are active when the base station pulls their voltage 
low and current is flowing. Digital inputs are active when 
external equipment is pulling them to ground. All base station 
digital inputs and outputs are open collector.

ADC Analog-to-Digital Converter. A device for converting an analog 
signal to a digital signal that represents the same information.

Alarm log The alarm log is a list of the last 50 alarms that the base station 
generated. This list is stored in the base station. To view it, select 
Monitor > Alarms > Reported Alarms.

Alarm Center Alarm Center is a utility provided with the Service Kit that is able 
to receive, store, and display alarms from any number of base 
stations with dial-up connections. Participating base stations need 
an Alarm Reporting license. Alarm Center also routes emailed 
messages to the email server.

alarm notification Alarm notification is the process by which the base station passes 
on information about an alarm condition. It can notify alarms 
over the air, over the line, via email, or to an Alarm Center. It 
can also activate a digital output. If the Service Kit is logged on 
to the base station, it is automatically notified of any alarms.
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air intake 
temperature

The temperature of the air as measured at the PA’s air intake.

anti-kerchunking Anti-kerchunking is a base station configuration that discourages 
users from kerchunking. 

B

balanced line A balanced line has two wires carrying equal and opposite signals. 
It is typically used in a line-connected base station for connecting 
to the despatcher console. The system interface identifies the 
balanced line in as Rx+ and Rx-, and the balanced line out as 
Tx+ and Tx-.

BCD BCD (binary coded decimal) is a code in which a string of four 
binary digits represents a decimal number.

BSS A BSS (base station system) is a subrack containing at least one 
TB8100 base station. 

C

Calibration Kit The TB8100 Calibration Kit is a utility for defining the 
switching ranges of the receiver and the exciter and for flattening 
the receiver response across its switching range. It can also be 
used to calibrate various parts of the reciter and the PA circuitry.

CCDI2 CCDI2 (computer controlled data interface version 2) is a 
proprietary Tait command protocol used between computer 
equipment and a Tait radio.

channel A channel is:
1. A frequency pair (or just a single frequency in a simplex 
system).
2. A set of configuration information that defines the frequency 
pair and other settings. Also referred to as a channel 
configuration. Generally, ‘channel’ has this meaning in the 
Service Kit.
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channel profile A channel profile is a named set of configuration items relating 
to the base station’s RF configuration, transmitter power output 
and power saving modes. Like the signalling profile, it can be 
applied to any channel. Together, these profiles define most 
configuration items.

channel spacing Channel spacing is the bandwidth that a channel nominally 
occupies. If a base station has a channel spacing of 12.5 kHz, 
there must be a separation of at least 12.5 kHz between its 
operating frequencies and those of any other equipment. 

channel table The channel table is the base station’s database of channel 
configurations. To view it, select Configure > Base Station > 
Channel Table.

CODEC An IC which combines analog-to-digital conversion (coding) 
and digital-to-analog conversion (decoding).

configuration file A configuration file consists of all the configuration settings 
needed for a base station, stored as a file in the configurations 
folder. Configuration files have the extension *.t8c.

connection A connection is a named group of settings that the Service Kit 
uses when establishing communications with a BSS.

control bus The control bus is used for communications between modules in 
a base station system. It is an I2C bus, a bi-directional two-wire 
serial bus which is used to connect integrated circuits (ICs). I2C 
is a multi-master bus, which means that multiple chips can be 
connected to the same bus, and each one can act as a master by 
initiating a data transfer. 

control panel The control panel is an area at the front of the BSS with buttons, 
LEDs and other controls that let you interact with the BSS.

CTCSS CTCSS (continuous tone coded squelch system), also known as 
PL (private line) is a type of signalling that uses subaudible tones 
to segregate groups of users.

custom action A custom action is a user-defined Task Manager action that 
consists of more than one pre-defined action.

custom input A custom input is a user-defined Task Manager input that 
consists of a combination of pre-defined inputs.
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CWID CWID (Continuous Wave IDentification) is a method of 
automatically identifying the base station using a Morse code. 
Continuous wave means transmission of a signal with a single 
frequency that is either on or off, as opposed to a modulated 
carrier. 

D

DAC Digital-to-Analog Converter. A device for converting a digital 
signal to an analog signal that represents the same information.

DCS DCS (digital coded squelch), also known as DPL (digital private 
line), is a type of subaudible signalling used for segregating groups 
of users. DCS codes are identified by a three-digit octal number, 
which forms part of the continuously repeating codeword. 
When assigning DCS signalling for a channel, you specify the 
three-digit code.

de-emphasis De-emphasis is a process in the receiver that restores pre-
emphasised audio to its original relative proportions. 

duty cycle Duty cycle is used in relation to the PA. It is the proportion of 
time (expressed as a percentage) during which the PA is operated. 
The TB8100 PA can be operated continuously. 

E

EIA Electronic Industries Alliance. Accredited by the American 
National Standards Institute (ANSI) and responsible for 
developing telecommunications and electronics standards in the 
USA.

EMC Electromagnetic Compatibility. The ability of equipment to 
operate in its electromagnetic environment without creating 
interference with other devices.

ETSI European Telecommunications Standards Institute. The non-
profit organisation responsible for producing European 
telecommunications standards.
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F

flag A flag is a programming term for a “yes/no” indicator used to 
represent the current status of something. The base station has a 
set of system flags that are read and set by Task Manager. There 
is also a separate set of flags that you can use in your own Task 
Manager tasks. 

frequency band The range of frequencies that the equipment is capable of 
operating on.

front panel The cover over the front of the BSS containing fans for the PA 
and PMU.

G

gating Gating is the process of opening and closing the receiver gate. 
When a valid signal is received, the receiver gate opens. 

H

hiccup mode Many power supplies switch off in the event of a short-circuit 
and try to start again after a short time (usually after a few 
seconds). This “hiccup”-type of switching off and on is repeated 
until the problem is eliminated.

hysteresis Hysteresis is the difference between the upper and lower trigger 
points. For example, the receiver gate opens when the upper 
trigger point is reached, but will not close until the level falls to 
the lower trigger point. An adequate hysteresis prevents the 
receiver gate from repeatedly opening and closing when the level 
is about that of the trigger point. 

Hysteresis mode A mode of PMU operation designed to save power. The PMU 
is mainly turned off, but switches back on intermittently to 
maintain output voltage when the output current is low.
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I

inactive Digital outputs are inactive if the base station is doing nothing to 
them. They are floating, open collector outputs. Digital inputs 
are inactive when they are open circuit. 

Intercom mode Intercom mode makes it possible for the operator at the dispatch 
center and the servicing technician at the base station to 
communicate with each other over the line. It connects the base 
station microphone to line out.

isolator An isolator is a passive two-port device which transmits power in 
one direction, and absorbs power in the other direction. It is used 
in a PA to prevent damage to the RF circuitry from high reverse 
power.

K

kerchunking Kerchunking is transmitting for a second or less without saying 
anything in order to test the base station. This results in a 
‘kerchunk’ sound.

L

line-controlled base 
station

A TB8100 is a line-controlled base station when it receives audio  
(sending it out via its systems interface), transmits audio received 
over its systems interface, and its transmitter is keyed via the Tx 
Key line.

logging on Once you are connected to a BSS, you log on to a base station. 
This establishes communications between the Service Kit and a 
particular base station.

N

navigation pane The navigation pane is the left-hand pane of the Service Kit 
application window. It displays a hierarchical list of items. When 
you click an item, the main pane displays the corresponding 
form.
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0

operating range Operating range is another term for switching range.

P

PA The PA (power amplifier) is a base station module that boosts the 
exciter output to transmit level.

PMU The PMU (power management unit) is a module that provides 
power to the BSS.

pre-emphasis Pre-emphasis is a process in the transmitter that boosts higher 
audio frequencies. 

R

reciter The reciter is a module of a TB8100 base station that acts as 
receiver and exciter.

reverse tone burst Reverse tone bursts can be used with CTCSS. When reverse 
tone bursts are enabled, the phase of the generated tones is 
reversed for a number of cycles just before transmission ceases. If 
the receiver is configured for reverse tone burst, it responds by 
closing its gate.

RSSI RSSI (Received Signal Strength Indicator) is a level in dBm or 
volts that indicates the strength of the received signal. 

Run mode Run mode is the normal operating mode of the base station.

signalling profile A signalling profile is a named set of configuration items related 
to signalling that can be applied to any channel. Items include 
subaudible signalling and transmit timers. 

S

sensitivity The sensitivity of a radio receiver is the minimum input signal 
strength required to provide a useable signal.
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SINAD SINAD (Signal plus Noise and Distortion) is a measure of signal 
quality. It is the ratio of (signal + noise + distortion) to (noise + 
distortion). A SINAD of 12 dB corresponds to a signal to noise 
ratio of 4:1. The TB8100 can provide an approximate SINAD 
value while in service by comparing the in-band audio against 
out-of-band noise. This value should not be relied upon to make 
calibrated measurements.

Sleep mode Sleep mode is a power saving state in which a part of the base 
station is switched off, and then periodically switched on again. 

Standby mode Standby mode is a mode of base station operation in which active 
service is suspended so that special operations can be carried out, 
such as programming the base station with a new configuration. 

status message A status message is a set of information about the base station that 
can be emailed. It identifies the base station, indicates the current 
operating channel, lists the status of all alarms, and gives the 
current values of a number of other monitored parameters. It also 
contains the alarm log. 

subaudible 
signalling

Subaudible signalling is signalling that is at the bottom end of the 
range of audible frequencies. The TB8100 base station supports 
CTCSS and DCS subaudible signalling. 

subtone A subtone (subaudible signalling tone) is a CTCSS tone or a DCS 
code. 

switching range The switching range is the range of frequencies (about 10 MHz) 
that the equipment is tuned to operate on. This is a subset of the 
equipment’s frequency band.

system flag System flags are binary indicators that are read and set by Task 
Manager. Generally, they are used to disable or enable 
configured base station functions.

system interface The system interface is the set of inputs to and outputs from the 
base station (excluding power and RF), provided by a board 
inside the reciter. A range of different boards are available for 
different applications. 
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T

TB8100 Base Station A Tait TB8100 base station consists of the equipment necessary 
to receive and transmit on one channel. Generally, this means a 
reciter, a PA, and a PMU. Often abbreviated to TB8100 or base 
station. 

Talk Through 
Repeater

A TB8100 is a talk through repeater when its audio path is 
configured to pass the audio it receives on to the transmitter.

Task Manager Task Manager is a part of the TB8100 base station firmware that 
carries out tasks in response to inputs. These tasks are formulated 
using the Service Kit.

template file A template file contains configuration information that can be 
used to create a new base station configuration. Template files 
have the extension *.t8t.

transmit lockout The transmit lockout feature prevents the base station from 
transmitting for a time once the transmit timer has expired. It is 
designed to prevent users from monopolizing the base station.

U

Unbalanced line An unbalanced line has one wire earthed. It is typically used for 
short connections, for example, between a base station and a 
repeater on the same site. The system interface identifies the 
wires of unbalanced lines with Rx audio, Tx audio, and Audio 
Ground. Audio Ground is common to line in and line out.

V

valid signal A valid signal is a signal that the receiver responds to by opening 
the receiver gate. A signal is valid for example when it is stronger 
than a minimum level and when it has the specified subtone.

VSWR Voltage Standing Wave Ratio (VSWR) is the ratio of the 
maximum peak voltage anywhere on the line to the minimum 
value anywhere on the line. A perfectly matched line has a 
VSWR of 1:1. A high ratio indicates that the antenna subsystem 
is poorly matched.
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W

Watchdog A watchdog circuit checks that the system is still responding. If 
the system does not respond (because the firmware has locked 
up), the circuit resets the system. 
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Index

A
access level 40
access profile 82
AC-DC converter 60, 66
actions (Task Manager) 183

alarm 190
channel profile 187
custom 192
general 183
signalling profile 189
System I/O 189

Add Channel Profile dialog box, accessing 92
Administrator access level 40
advanced profile features 91
Advanced Profiles and Task Manager license 15,

91
air intake temperature 64
alarm 13, 125

adjusting thresholds 137
configuring for fan 81
disabling 136
emailing 143
flashing icon 20
list of recent 135
monitoring 127
monitoring from Service Kit 20
notification methods 139
notifying Alarm Center 141
over the air 139
over the line 140
polling interval 35
reported alarms 135
Task Manager actions 190
Task Manager inputs 180
turning over-the-air alarm on and off 190
turning the over-the-line alarm on and off

190
using CWID as 105
using pip tone as 139

Alarm Center 12
sending alarms to 141

alarm log 135
clearing (by Task Manager action) 191
saving to file 135
sending (by Task Manager action) 191

alarm notification 13
setting up 13

Alarm Reporting license 15

Alarm status LED 58
antenna relay 79
antenna, automatic switching of (Task Manager

code) 195
anti-kerchunking 113
application window 31
audio filter 101
audio input

measuring level of 154
monitoring 63
monitoring level of 63
summing from line and receiver 100

audio output
configuring line level 101
generating 155
monitoring 63
monitoring level of 63

audio path 99
automatic gain control 97
auxiliary power output

availability of 60
configuring 80
monitoring state of 67
testing 165

B
balanced line

measuring level of 154
bandwidth 119
base station

naming 74
operation mode 4
programming 44
resetting 41
resetting (by Task Manager action) 185
self-tests 148
testing 145
upgrading firmware 48

base station system
connecting to 38

basic tasks 29
battery

automatic charging of (Task Manager code)
194

configuring minimum voltage 80
state of 66

battery backup
testing 164



216 Index  MB8100-00-00-806   © TEL 2003 

battery charger
configuring auxiliary power as 80
monitoring state of 67

battery protection mode 133
battery voltage

monitoring 65
system data on 69

BCD format 76
BSS

connecting to 38

C
calibration

date of 58
Carrier gating 98
carrier, maximum frequency deviation 81
Celsius 33
channel 5

adding 121
block copying 121
configuring 85
copying 121
defining a set of 87
editing (when custom profiles are used) 120
exporting 122
getting started 87
importing 122
profiles assigned to 61
selecting (by Task Manager action) 187
selecting default 74
selecting default (by Task Manager action)

188
selecting externally 75
selecting one to operate on 123
setting up 87
source of channel selection 62

Channel Guard see subaudible signalling
channel profile

adding 92
customizing the default 88
editing 95
list of 92
naming 96
Task Manager actions for 187
working with 92

channel spacing 119
of receiver 96
when block copying 121

channel table 5, 117
arrow in 117
working with 117

clock reference, source of 62

coded squelch see DCS code
comment, in Task Manager 172
compatibility file 48
configuration

creating 43
creating template from 45
file location 33
printing 84
programming base station with 44
reading 43
saving to file 44
tutorial 24
viewing 22
ways of working with 42

connecting
directly 38
remotely 12

connection 34
adding 34
dial-up 35
direct 34
displayed in status bar 32
editing 37
intermittent 35
over-the-air 36
slow 35
types of 34
using USB instead of a serial port 34

control panel
status of power supply to 66
testing 149
testing LEDs 149

counter
defining 200
Task Manager action 186
viewing 203

CTCSS 7
decode speed 115
decoding reverse tone burst 115
detect bandwidth 80
detection time 80
gating options 115
reject bandwidth 80
setting deviation of 97

CTCSS characteristics 80
current channel 5

details of 61
Current Status form 127
custom action 11, 199

defining 200
viewing 200

custom input 11, 198
defining 199
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viewing 198
custom profile 6, 91
CWID 105

automatic transmission of 106
disabling (by Task Manager action) 188
transmitting (by Task Manager action) 188

D
dBm, converting to microvolts 78
DC-DC converter 60, 66
DCS code 7

matching base station’s code to radios’ code 7
setting deviation of 97

DCS end tone 114
Decode signal column 111
de-emphasis 101
Deep Sleep mode 8, 104
default channel 5

selecting 74
setting 123

default channel profile 88
default profile 6
Default Radio System license 15
default signalling profile 90
Delay before relay opens box 79
diagnosing 23

how to 147
overview 145

dial-up connection 35
digital input

assigning function to (Task Manager code)
196

viewing state of 156
digital output

activating (Task Manager action) 189
deactivating (Task Manager action) 190
toggling 156
viewing status of 156

Digital Private Line see DCS code 7
direct connection 34

access profile for 82
disconnecting 47
do now action 11
Download mode 4

selecting 41
duty cycle

average over life of base station 68
monitoring 64

E
email 143

automatic sending of (Task Manager code)
195

disabling (by Task Manager) 191
sending (Task Manager action) 184
testing 158

enabling additional features 51
exciter, switching range of 57
external channel selection 75

disabling 76
disabling (by Task Manager action) 186
testing 157

external reference
alarm 132
specifying frequency of 81

F
Fahrenheit 33
fan

alarms 81
monitoring operating hours 81
operating time (PA) 69
operating time (PMU) 69
rotation detector 81
testing 160, 161, 164
testing (Task Manager action) 184

fault diagnosis 23
feature enabler 15
feature set

disabling 52
filter

on audio path 101
firmware

folder for upgrade files 33
upgrading 48

flag
defining 200
viewing 203

form 31
forward power 64

G
gating, of receiver 94
getting started 17

H
hang time 114
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hardware channel selection 75
testing 157

heatsink temperature
of PA 160
of PMU 166

hysteresis, in receiver gating 99

I
IF and IF NOT tasks 10
inputs (Task Manager) 174

alarm 180
custom 198
for channel profile 176
for signalling profile 178
for system I/O 179
general 174

installation 24
intercom mode, disabling (by Task Manager ac-

tion) 184
interface See system interface board
isolator 59

K
kerchunking 113
keyup time

configuring 105

L
license file, folder to store in 33
license key 51
line in

setting expected level 103
line level

of input 103
setting for line out 101

line output
overriding receiver gating 99

line-controlled base station, disabling (by Task
Manager action) 187

local connection See direct connection
lock range

determining 153
lockout

of transmitter 113
log files, location of 33
logging off 47
logging on 39
loopback, enabling (Task Manager action) 184
low current option 8

M
mains supply, state of 66
Max Tx deviation box 97
microphone

testing microphone channel switch 149
testing PTT operation 149

microvolts, converting to dBm 78
mid band 96, 119
mode 4

changing 41
viewing current 32

monitoring 21, 55
operational information 61
PA 64
PMU 65
polling interval 35
reciter 63
subaudible signalling 159

Morse code 105
multiple

in Channel Profiles form 92
in channel table 117

N
naming the base station 74
narrow band 96, 119
navigation pane 21, 31

red item in 147
Noise gating 98
Normal power saving mode 8, 104

O
Only output line audio when Rx Gate is valid

99
operating channel 123
operating time 68
operation mode 4
output current 67
over the air alarm

turning on and off 190
over the line alarm

turning on and off 190
Override actions (Task Manager) 10

P
PA

alarm status 129
fan operating time 69, 69
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monitoring air intake temperature 64
monitoring duty cycle 64
monitoring operational information on 64
monitoring temperature of 64, 160
not detected 129
power rating 59
state of power supply to 66
testing fault LED 160
version 59
viewing information on 58

password 40
changing 46

Permanent option button 68
PGM800Win, comparing Service Kit with 3
pip tone

over the air 139
over the line 140

PMU
alarm status 133
auxiliary power output 80
available inputs 60
available outputs 60
configuring shutdown voltage 80
monitoring heatsink temperatures 166
monitoring operational information on 65
monitoring output current 67
monitoring output voltage 166
product code 59
serial number 60
submodules in 60
testing 164
testing fault LED 165
version 60
viewing information on 59

polling interval 35
power output

monitoring 64
of PA 64
setting 93, 97
to PA 66
to reciter 66

power saving 8
configuring 94, 104
disabling (by Task Manager action) 189
effect on quality of service 8
overriding (by Task Manager action) 184

Power Saving Modes license 15
Power shutdown voltage box 80
Power startup voltage box 80
pre-emphasis 101
printing a configuration 84
Private Line see CTCSS tone
profile 6

advanced features of 91
programming base station 44

Q
quality of service 8
Quasi Synch mode 81

R
Read icon 43
Read only access level 40
receiver

audio path 100
disabling (by Task Manager action) 185
lock range 153
measuring received signal level 152
operating without a configuration 151
switching range 57
testing 151

Receiver channel box 96, 96
receiver gating 98

applying to line out 99
configuring 94

receiver sensitivity
AGC affects 97
testing 152

receiver squelch 98
reciter

alarm status 128
lock range 153
monitoring operational information on 63
serial number of 58
state of power supply to 66
testing 151
version 58
viewing information on 57

Relay closing settling time box 79
relay line 79
reminder tone 109, 116

enabling 112
remote connection 12

access profile for 82
repeater

for speech and data (Task Manager code) 193
setting gain of 97
simplex 196

repeater changeover (Task Manager code) 193
reported alarms 135
Reported Alarms form 135
resets, number of 69
Resettable option button 68
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resetting the base station 41
reverse power 64
reverse tone burst 114, 115

decoding 115
RF power output

setting 93, 97
RSSI

alarm 132
monitoring 63
system data on 69

RSSI gating 98
RSSI output

configuring 76
setting a voltage 158
testing 157

Run mode 4
Rx cycling 95, 104
Rx Gate output

toggling 156
viewing status of 156

S
scanning repeater (Task Manager code) 196
See channel profile and signalling profile
See channel table, entry in profile dialog box 88
self-tests 148
sensitivity of receiver 152
serial port 35, 37

USB to serial converter 34
Service Kit

appllication window 31
installing 24
monitoring alarms 20
number of resets 69
upgrading 50

signal level
measuring across band 152

signal path 99
signalling profile

adding 107
customising the default 90
editing 109
list of 107
Task Manager actions 189
Task Manager inputs 178
working with 107

simplex operation (Task Manager code) 196
simulcast

configuring base station for 81
SINAD

measurement method 151

monitoring 63
SINAD gating 98
Sleep mode 8, 104
Soft-off time 115
software feature enabler 15, 51
speaker, testing 149
speech band filter 101
squelch See receiver gating
squelch tail 113
Standby converter

state of DC supply to 66
Standby mode 4
Start after box 95, 105
status bar 32
subaudible band filter 101
Subaudible deviation 97
subaudible signalling 7

disabling decoding of (Task Manager action)
189

disabling encoding of (Task Manager action)
189

monitoring 159
Subaudible Signalling tab 110
subtone 7

encoding options 112
specifying the ones to recognize 111

switching range 57
exciter 57
when last altered 58

synthesiser
alarm 129
determining lock range 153
out of lock 129

system alarms 131
system data 68
system flags 201
system I/O

Task Manager actions 189
system interface 14
system interface board 75

configuring for external channel selection 75
installed version 57
pin assignments on 75
viewing details of 75

T
T800, comparing TB8100 with 3
tail timers 113
talk through repeater

disabling 187
Talk through repeater box 102
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talk through repeater gain 97
task

adding 171
disabling 172
exporting 173
importing 173

Task Manager 9, 167
accessing 169
actions 10
adding comments 172
adding tasks 171
custom actions 192
customizing 198
disabling tasks 172
example tasks 193
exporting tasks 173
flags 201
importing tasks 173
input types 10
inputs 174
monitoring recent actions 203
number of resets 69
tasks 10
working with 170

temperature
Celsius or Fahrenheit 33
monitoring on PA 64, 160
monitoring on PMU 166
system data on 69

template 45
test tone, generating 155
testing 23

audio output 155
auxiliary power output 165
battery backup 164
control panel 149
digital I/O 155
email 158
external channel selection 157
fan 160, 161, 164
I/O 154
lock range 153
PA 160
PA fault LED 160
PMU 164
PMU fault LED 165
receiver sensitivity 152
RSSI output 157
transmitter 161

Thresholds form 137
timer

defining (Task Manager) 200
starting (by Task Manager action) 186

stopping (by Task Manager action) 186
viewing 203

toolbar 31
traffic light 4, 41
transmit lockout 113
transmit timers 113
transmitter

configuring audio path for 103
disabling (by Task Manager action) 185
keying sources 100
power output 64
setting keyup time 105
summing audio from line and receiver 100
testing 161

transmitter power output 97
setting 93

troubleshooting
PC to base station communications 35

truth table 199
tutorial 24
Tx Key

disabling (by Task Manager action) 185
Tx keyup time 95, 105
Tx max deviation 119
Tx relay 79

disabling (by Task Manager action) 190
Type box 75

U
unbalanced line

measuring level of 154
monitoring 63

Untitled.t8c file 43, 44
upgrading

base station firmware 48
Service Kit 50

USB port 34
User access level 40

configuring profile of 82

V
version number

of PA 59
of PMU 60
of reciter 58

Vpp, of line in 103
VSWR

monitoring 64
system data on 69
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W
watchdog resets 69

wide band 96, 119
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